Bug 1288861 - Transmission interface glitch
Transmission interface glitch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-06 12:40 EST by observer45
Modified: 2016-02-05 21:25 EST (History)
10 users (show)

See Also:
Fixed In Version: transmission-2.84-10.fc23 transmission-2.84-10.fc22 transmission-2.84-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-23 22:31:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
how it looks (169.97 KB, image/png)
2015-12-06 12:40 EST, observer45
no flags Details

  None (edit)
Description observer45 2015-12-06 12:40:39 EST
Created attachment 1102822 [details]
how it looks

Description of problem:
Transmission draws lines when torrent list is scrollable. Dont know how to describe it better - look at the attached picture. 
Also the filters toolbars cuts some pixels from numbers (i've changed font & restarted transmission to make it more visible)


Version-Release number of selected component (if applicable):
transmission-gtk-2.84-8.fc23.x86_64

How reproducible:
Just add some torrents to transmission and reduce window height to make list scrollable.
Comment 1 delirio 2016-01-16 06:55:37 EST
Found a solution at ubuntu's bugzilla - they already fixed this. Sad thing - this is broken about a year (since 3.16). This bug also affects Fedora 22. Here is a patch (found link at ubuntu's bugzilla).

https://trac.transmissionbt.com/changeset/14519/trunk/gtk/tr-window.c
Comment 2 Gwyn Ciesla 2016-01-20 09:12:41 EST
Thanks for the patch, life's been full and I wasn't aware of it.  I'll get builds out ASAP.
Comment 3 Fedora Update System 2016-01-20 10:54:56 EST
transmission-2.84-10.fc23 libnatpmp-20150609-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7fb3ad6fe3
Comment 4 Fedora Update System 2016-01-20 10:55:15 EST
transmission-2.84-10.fc22 libnatpmp-20150609-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-663165e811
Comment 5 Fedora Update System 2016-01-21 23:59:18 EST
libnatpmp-20150609-1.fc23, transmission-2.84-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7fb3ad6fe3
Comment 6 Fedora Update System 2016-01-22 02:56:28 EST
libnatpmp-20150609-1.el7, transmission-2.84-10.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-949b0c7348
Comment 7 Fedora Update System 2016-01-23 16:30:51 EST
libnatpmp-20150609-1.fc22, transmission-2.84-10.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-663165e811
Comment 8 Fedora Update System 2016-01-23 22:31:21 EST
libnatpmp-20150609-1.fc23, transmission-2.84-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Leszek Matok 2016-01-26 15:24:10 EST
This just landed on my system. Thank you so much!
Comment 10 Fedora Update System 2016-02-01 01:31:57 EST
libnatpmp-20150609-1.fc22, transmission-2.84-10.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-02-05 21:25:19 EST
libnatpmp-20150609-1.el7, transmission-2.84-10.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.