Bug 1288864 - Printing on Xerox 6015 does not work. CUPS Filter Failed
Printing on Xerox 6015 does not work. CUPS Filter Failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-06 12:52 EST by ceesiebo
Modified: 2015-12-07 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 17:23:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
troubleshoot file created with system-config-printer (32.71 KB, text/plain)
2015-12-06 12:52 EST, ceesiebo
no flags Details
journal messages CUPS (95.41 KB, text/plain)
2015-12-07 13:26 EST, ceesiebo
no flags Details

  None (edit)
Description ceesiebo 2015-12-06 12:52:23 EST
Created attachment 1102824 [details]
troubleshoot file created with system-config-printer

Description of problem:
Printing a document does not work. After printing a pdf or a txt file, the print is put in the queue, but the printing then stops. No document is printed. The job itself does not arrive at the printer. It stays in the print-queue. The printer that I use is XEROX Multifunctional Workcentre 6015. When checking CUPS page (localhost:631) the job has the status Filter failed.

Version-Release number of selected component (if applicable):


How reproducible:
Easy to reproduce. Print a document on the XEROX 6015

Steps to Reproduce:
1.Start system-config-printer
2.Double click the Xerox printer
3.Choose print test page

Actual results:
Print job stays in queue

Expected results:
Document is printed on Xerox printer

Additional info:
Comment 1 Jiri Popelka 2015-12-07 09:47:48 EST
Thanks for the troubleshooter output, it's however missing journal log messages.
Please try to get them according to:
https://fedoraproject.org/wiki/How_to_debug_printing_problems#Getting_debug_information_by_other_means
Comment 2 ceesiebo 2015-12-07 13:26 EST
Created attachment 1103332 [details]
journal messages CUPS
Comment 3 ceesiebo 2015-12-07 13:28:12 EST
Hi Jiri,

I did the instruction and added the journal log messages. Also strange is that when I do the su -c 'cupsctl LogLevel=debug2' I get an error message : cupsctl Internal Server Error

Regards,
Cees
Comment 4 Jiri Popelka 2015-12-07 13:43:06 EST
Thanks, I see few issues in the log:

> cupsd[3553]: Xerox_Xerox_WorkCentre_6015N: error while loading shared libraries: libcups.so.2: cannot open shared object file: No such file or directory
> cupsd[3553]: PID 3839 (/usr/lib/cups/filter/xrhk2ap) stopped with status 127 (File too large)

Looks like you use a driver from Xerox, which has some problems.
I'm afraid I can't help you with that, but according to
http://www.openprinting.org/printer/Xerox/Xerox-WorkCentre_6015
there should be a driver in a foo2hbpl package, so you can
$ dnf install foo2hbpl
and try to use a Xerox WorkCentre 6015 driver from there.

> cupsd[3553]: Unable to open raster stream - : Broken pipe
> cupsd[3553]: GPL Ghostscript 9.16: Unrecoverable error, exit code 1

This GS error is I think caused by the above one.
Comment 5 ceesiebo 2015-12-07 14:07:51 EST
(In reply to Jiri Popelka from comment #4)
> Thanks, I see few issues in the log:
> 
> > cupsd[3553]: Xerox_Xerox_WorkCentre_6015N: error while loading shared libraries: libcups.so.2: cannot open shared object file: No such file or directory
> > cupsd[3553]: PID 3839 (/usr/lib/cups/filter/xrhk2ap) stopped with status 127 (File too large)
> 
> Looks like you use a driver from Xerox, which has some problems.
> I'm afraid I can't help you with that, but according to
> http://www.openprinting.org/printer/Xerox/Xerox-WorkCentre_6015
> there should be a driver in a foo2hbpl package, so you can
> $ dnf install foo2hbpl
> and try to use a Xerox WorkCentre 6015 driver from there.
> 
> > cupsd[3553]: Unable to open raster stream - : Broken pipe
> > cupsd[3553]: GPL Ghostscript 9.16: Unrecoverable error, exit code 1
> 
> This GS error is I think caused by the above one.

Hi Jiri,

I followed the instruction and added a printer with the f002hbpl and printing works again. Thanks for your support!

Regards,
Cees

Note You need to log in before you can comment on or make changes to this bug.