Bug 1288867 - [nmcli] Failed to add/activate new connection: The access point /org/freedesktop/NetworkManager/AccessPoint/$NUM was not in the scan list.
[nmcli] Failed to add/activate new connection: The access point /org/freedesk...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-06 13:15 EST by Lokesh Mandvekar
Modified: 2016-01-08 15:31 EST (History)
6 users (show)

See Also:
Fixed In Version: NetworkManager-1.2.0-0.4.20151112gitec4d653.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 15:31:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lokesh Mandvekar 2015-12-06 13:15:03 EST
Description of problem:
nmcli doesn't add/connect to a new wifi network.

I have a couple of connections saved which get connected to automatically, but if I try to manually connect to them using nmcli, it gives me this same error.

Version-Release number of selected component (if applicable):
NetworkManager-1.2.0-0.3.20151112gitec4d653.fc24.x86_64

How reproducible:
consistent

Steps to Reproduce:
1. nmcli dev wifi connect $network [password $password]

Actual results:
Error: Failed to add/activate new connection: The access point /org/freedesktop/NetworkManager/AccessPoint/$NUM was not in the scan list.

Expected results:
should connect to wifi network
Comment 1 Lokesh Mandvekar 2015-12-06 13:16:54 EST
same error no matter what getenforce says.
Comment 2 Jirka Klimes 2015-12-07 09:07:59 EST
$ nmcli dev wifi connect $network [password $password]

is a command for creating a new profile and activate it, see nmcli manual page.

To activate an existing connection, simply use
$ nmcli connection up profile-name

Anyway, what network (SSID) did you use for 'nmcli dev wifi connect'? Was it hidden (with disabled broadcast of SSID)? In that case you should use "hidden" option.
Can you see the network in 'nmcli dev wifi' list?
Comment 3 Jirka Klimes 2015-12-07 09:36:00 EST
Well, I can reproduce 'nmcli device wifi connect' error. It has been fixed upstream, but the fix is not in rawhide snapshot.
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=914d875dc2ea2e410c422cf9d027d33e47396cdf

The new master snapshot will be made for rawhide soon (after other issues are resolved).
Comment 4 Lokesh Mandvekar 2015-12-11 14:04:11 EST
great thanks, any ETA on the new build?
Comment 5 Peter Gervase 2015-12-22 07:32:27 EST
I'm using MATE for now (KDE if it'd ever start correctly), and when I click on the wireless icon and then click on my network from the list of available networks, I get this error. However, if I go to connect to a hidden network and then select my network, it works just fine.
Comment 6 Lokesh Mandvekar 2015-12-28 08:15:43 EST
Jirka, could you do a new build for rawhide atleast? This bug has pretty much put me under 'house arrest' so to speak.
Comment 7 David King 2016-01-08 15:31:14 EST
I pushed a minimal fix (the patch and a couple of patches which allow building against the libsoup in Rawhide) to Rawhide, until a new git snapshot is prepared. Mike Hill tested a scratch build for me, and said that it fixes the problem for him.

Note You need to log in before you can comment on or make changes to this bug.