Bug 1288871 - Component Statuses not properly reported in OpenShift
Component Statuses not properly reported in OpenShift
Status: CLOSED DUPLICATE of bug 1268988
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Paul Weil
Jianwei Hou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-06 14:12 EST by Federico Simoncelli
Modified: 2015-12-08 08:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 08:57:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Federico Simoncelli 2015-12-06 14:12:05 EST
Description of problem:
Component statuses in OpenShift are broken:

https://github.com/openshift/origin/issues/5865
https://github.com/openshift/origin/issues/3667


How reproducible:
100%

Steps to Reproduce:
1. Install and configure a fully functional OpenShift cluster


Actual results:

# oc get componentstatuses
NAME                 STATUS      MESSAGE   ERROR
controller-manager   Unhealthy             Get http://127.0.0.1:10252/healthz: dial tcp 127.0.0.1:10252: connection refused
scheduler            Unhealthy             Get http://127.0.0.1:10251/healthz: dial tcp 127.0.0.1:10251: connection refused
etcd-0               Unhealthy             Get http://oshift01.eng.lab.tlv.redhat.com:4001/health: malformed HTTP response "\x15\x03\x01\x00\x02\x02"


Expected results:

The status of the components should be properly reported.

Additional info:
Comment 1 Paul Weil 2015-12-08 08:57:44 EST

*** This bug has been marked as a duplicate of bug 1268988 ***

Note You need to log in before you can comment on or make changes to this bug.