Bug 128890 - Alerts on a session startup
Alerts on a session startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libbonobo (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-07-30 17:56 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 15:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-07-30 17:56:49 EDT
Description of problem:

After the latest round of updates, not always but often enough,
when a desktop session starts I am greeted with an alert which
says the following:

<quote>
There was an error starting the GNOME Settings Daemon.

Smome things, such as themes, sounds, or background settings
may not work correctly.

The Settings Daemon restarted too many times

The last error message was:

Child process did not give an error message, unknown failure
occured.

GNOME will still try to restart the Settings Daemon next time
you log in.
</quote>

Nothing seems to be particularly amiss and on the next attempt
to logon usually there is no alert.  This happens both for
non-root and root sessions.  The only possible clue is that
in /var/log/messages things like that show up:

Jul 30 15:05:35 dyna0 bonobo-activation-server (michal-13328): iid
OAFIID:BrokenNoType:20000808 has a NULL type
Jul 30 15:05:35 dyna0 bonobo-activation-server (michal-13328): invalid
character '#' in iid 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'
Jul 30 15:05:37 dyna0 bonobo-activation-server (michal-13328): file
object-directory-corba.c: line 686 (add_active_server): assertion
failed: (!strcmp (iid, NAMING_CONTEXT_IID) || !strcmp(iid,
EVENT_SOURCE_IID))
Jul 30 15:05:37 dyna0 bonobo-activation-server (michal-13382): iid
OAFIID:BrokenNoType:20000808 has a NULL type
Jul 30 15:05:37 dyna0 bonobo-activation-server (michal-13382): invalid
character '#' in iid 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'

Some other component may be actually responsible since alert
started to show up later then the latest libbonobo update was
done.  Other most likely candidates seem to be 
libgnomeui, ORBit2 and gtk2.

Version-Release number of selected component (if applicable):
libbonobo-2.6.0-3

How reproducible:
about fifty-fifty
Comment 1 Jeffrey C. Ollie 2004-08-03 01:07:34 EDT
This has been happening to me for a while now also.  I don't remember
when it started but it's been a week or two.  I didn't bother putting
it into bugzilla because I figured it was just breakage related to the
switch to Gnome 2.7.

I find that you get the error on the first login after a reboot, but
if you log out and then log back in you don't get the error.
Comment 2 Mike 2004-08-03 01:10:26 EDT
I'll just add a confirmation to this issue:

http://marc.theaimsgroup.com/?l=fedora-test-list&m=109150099304512&w=2

Regards, Mike Klinke
Comment 3 Jeffrey C. Ollie 2004-08-03 01:12:19 EDT
Also, I see the same messages from bonobo-activation-server in
/var/log/messages
Comment 4 Daniel Veillard 2004-08-03 03:25:24 EDT
One of the problem might be related to fam->gamin switch, the gnome
settings daemon seems to have issue with gamin. This is being
investigated.

Daniel
Comment 5 Jim Cornette 2004-08-03 07:07:43 EDT
I noticed this error since upgrading from rawhide on 7/23/04. Gamin
was one of the few programs pulled in. This error happened only when
starting GNOME on a reboot or powerup. 
Comment 6 Steven Usdansky 2004-08-03 07:24:32 EDT
Didn't pay attention to when it started in FC3t1, but saw it yesterday
in FC2 when I updated libbonobo and libbonobo-devel to 2.6.2-1.
Downgraded FC2 back to 2.6.0 and problem vanished
Comment 7 Mike 2004-08-04 11:57:49 EDT
As an additional note to this issue; I re-installed FC3t1 from scratch
and updated to the latest revision levels on a vanilla "Workstation"
install last night and this:

"There was an error starting the GNOME Settings Daemon"

error message seems to have disappeared when I boot up now.

Regards,  Mike Klinke
Comment 8 Srini 2004-09-20 00:02:33 EDT
I have a variation of the same problem.  This occurs with FC2.  
Everything seemed to be OK until some files were updated by yum.  Now 
I get this problem.

ALso the problem seems to occur for all users and does not go away 
even after reboot.

Regards
Srinivasan
Comment 9 Ray Strode [halfline] 2005-04-25 15:36:23 EDT
Hi, so this is probably fixed now.  If anyone sees this problem with fc3 or the
fc4 test releases feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.