Bug 1288901 - Nectar's tests are attempting to contact example.com, which is not allowed in mock and causes Koschei to fail
Nectar's tests are attempting to contact example.com, which is not allowed in...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-nectar (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-06 19:43 EST by Randy Barlow
Modified: 2015-12-18 15:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 15:38:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2015-12-06 19:43:50 EST
Description of problem:
Koschei rebuilds of Nectar are failing:

https://kojipkgs.fedoraproject.org//work/tasks/3599/12063599/build.log

Since Nectar's tests currently seem to attempt to contact the Internet, we have two options:

0) We modify the spec file so that it does not run the tests. If we go this route we need to file a bug with upstream Nectar to request that the tests not depend on the Internet so that we can re-enable the tests later.

1) We can work upstream to fix the tests and make a new release there that addresses the issue.
Comment 1 Ina Panova 2015-12-16 07:59:44 EST
Fixed in python-nectar-1.4.2-1.fc24
Comment 2 Ina Panova 2015-12-16 10:48:27 EST
Unfortunately the build failed,moving back to assigned
Comment 3 Randy Barlow 2015-12-18 14:30:57 EST
I'm going to disable the tests for now. We can re-enable them in the future when we have time to make them more stable.
Comment 4 Randy Barlow 2015-12-18 15:38:00 EST
This is fixed in python-nectar-1.4.2-2.fc24.src.rpm:

http://koji.fedoraproject.org/koji/taskinfo?taskID=12240709

Note You need to log in before you can comment on or make changes to this bug.