This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1288906 - capsule installation repos
capsule installation repos
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.4
Unspecified Unspecified
high Severity high (vote)
: GA
: 6.2
Assigned To: Stephen Wadeley
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-06 20:25 EST by jnikolak
Modified: 2016-12-01 02:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-01 02:51:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jnikolak 2015-12-06 20:25:21 EST
Document URL: 

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/sect-Red_Hat_Satellite-Installation_Guide-Obtaining_the_Required_Packages_for_the_Capsule_Server.html

Section Number and Name: 
7.3


Describe the issue: 

This section  is missing information and in addition its confusing because you have two different procedures to register. However its not clearly outlined if you need both, one or the other. 


Once you get past that hurdle, it becomes more confusing as its asking you to attach the repos.

However in initial step, we have registered only using
# subscription-manager register --org "Default_Organization"

That part is missing steps, because we haven't added the subscription. 
In addition, if you use subscription-manager list --available it will list the subscription connected to your redhat account and not the one that is attached to the Satellite.


<=========start of example=====================

# subscription-manager repos
This system has no repositories available through subscriptions.


subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:   RHEL Client Tool for Satellite MDP
Provides:            Red Hat Satellite Tools 6 MDP
                     Red Hat Enterprise Linux Server
SKU:                 MCTxxxxx
Contract:            xxxxxxx
Pool ID:             xxxxxxxxxxxxxxxx
Provides Management: Yes
Available:           14
Suggested:           1
Service Level:       Self-Support
Service Type:        L1-L3
Subscription Type:   Standard
Ends:                01/01/2022
System Type:         Physical

Subscription Name:   Employee SKU
Provides:            Oracle Java (for RHEL Server) - AUS
                     Oracle Java (for RHEL Client)
                     Red Hat Enterprise Linux 7 High Availability High Touch Beta
                     Red Hat Enterprise Linux 6 Server HTB
                     Red Hat EUCJP Support (for RHEL Server)
                     Red Hat Enterprise Linux for Power, little endian
                     Red Hat Enterprise Linux EUS Compute Node
                     Red Hat Enterprise Linux for Power, big endian - Extended Update Support
                     Red Hat OpenShift Enterprise JBoss EAP add-on

<=========end of example=====================
Comment 1 Andrew Dahms 2016-05-03 01:06:12 EDT
Assigning to Ali for review.

Ali - I believe some clarification may already have been provided in the 6.2 beta documentation, but the note about registration seems like a good point.

Is there any clarification we can add to the 6.2 beta docs to help users understand the difference between the two?
Comment 2 Andrew Dahms 2016-11-01 09:19:08 EDT
Moving to 'NEW' while assigned to the default assignee.

Ali has since left the team in this capacity, and this bug shall be re-triaged as the schedule allows.
Comment 3 Stephen Wadeley 2016-11-07 09:49:26 EST
Hello


In the 6.1 Guide, we should have removed the second occurrence of this step:

Register the Capsule server with your organization by using the organization label:


It occurs first in "Obtaining the Required Packages for the Capsule Server"

and then again, erroneously, in "Running the Installation and Configuration Program for Capsule Server"

I also noticed these two lines:

     Satellite Capsule Server with content functionality.
    Satellite Capsule Server without content functionality. 

{referring to --pulp    "true" }

but then those two option are not given in the section "Installing a Capsule Server", only in "Configuring Red Hat Satellite Capsule Server with a Custom Server Certificate"

in "Procedure 7.2. To Set a Custom Server Certificate When Running capsule-certs-generate for the First Time:"

in "Procedure 7.3. To Set a Custom Server Certificate After Running capsule-certs-generate:"


and again in the next section " ⁠7.5.2.1. Installing a Capsule Server with BMC Options"
Comment 4 Stephen Wadeley 2016-11-07 14:51:58 EST
Hello

Capsule Installation in the 6.2 Installation Guide can be found here:

https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/installation-guide/chapter-4-installing-capsule-server


I think apart from not mentioning that you need to sync the repos in the Satellite first, the procedure in the 6.2 Installation Guide looks OK.
Comment 5 Stephen Wadeley 2016-11-07 15:31:43 EST
Re comment 3

In the 6.1 Guide, in the section "Running the Installation and Configuration Program for Capsule Server",

the step:
 "On the Capsule Server, install the katello-ca-consumer-latest package from the Satellite serve" 

is also a duplicate of what was done in the previous section "Obtaining the Required Packages for the Capsule Server"

so that is two steps duplicated.
Comment 17 Stephen Wadeley 2016-12-01 02:51:29 EST
Hello

These changes are now live on the customer portal.


Thank you

Note You need to log in before you can comment on or make changes to this bug.