Bug 1288910 - USB devices on POWER8 disappear after a reboot
USB devices on POWER8 disappear after a reboot
Status: CLOSED CURRENTRELEASE
Product: RHEV for Power
Classification: Red Hat
Component: kernel (Show other bugs)
unspecified
ppc64le Linux
high Severity high
: rc
: ---
Assigned To: David Gibson
Red Hat Kernel QE team
: HardwareEnablement
Depends On:
Blocks: 1444027 1507957 1513404
  Show dependency treegraph
 
Reported: 2015-12-06 20:44 EST by David Gibson
Modified: 2018-04-17 20:53 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-17 20:53:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output taken from petitboot shell (82.65 KB, text/plain)
2015-12-09 09:55 EST, Thomas Huth
no flags Details
output taken from PowerKVM (82.16 KB, text/plain)
2015-12-09 10:08 EST, Thomas Huth
no flags Details
content of /sys/firmware/opal/msglog (87.35 KB, text/plain)
2015-12-24 04:22 EST, Laurent Vivier
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 133877 None None None Never

  None (edit)
Description David Gibson 2015-12-06 20:44:26 EST
NOTE: "kernel" is a placeholder component only - this is almost certainly a hardware or firmware bug.

Description of problem:

USB flash drives connected to a POWER8 machine appear initially to the host OS.  However after rebooting the machine, the devices are no longer visible in lsusb or dmesg.

How reproducible:

Seems to be 100% for us, but when BenH at IBM tried it he reproduced it once, then couldn't again.

Steps to Reproduce:
1.  Physically connect a USB flash drive to a POWER8 machine (e.g. 8247-22L)
2.  lsusb in the host OS
3.  Reboot the machine
4.  lsusb in the host OS

Actual results:

Flash drive appears in the first lsusb, not the second, after reboot.

Expected results:

Flash drive continues to appear until it is physically removed.

Additional info:
Comment 1 IBM Bug Proxy 2015-12-07 07:10:22 EST
------- Comment From fnovak@us.ibm.com 2015-12-07 12:09 EDT-------
reverse mirror of RHBZ 1288910 - USB devices on POWER8 disappear after a reboot
Comment 2 IBM Bug Proxy 2015-12-07 09:50:54 EST
------- Comment From seg@us.ibm.com 2015-12-07 14:49 EDT-------
*** Bug 133292 has been marked as a duplicate of this bug. ***
Comment 3 IBM Bug Proxy 2015-12-07 11:10:43 EST
------- Comment From gbertazi@br.ibm.com 2015-12-07 16:06 EDT-------
Questions for Red Hat:

1) What is the firmware level of this machine?

2) When was the usb gadget first connected?  Can you reproduce the issue in the first boot by connecting it before starting the boot sequence(i.e. by having the USB gadget attached before the probe of the USB host controller)?
Comment 6 Thomas Huth 2015-12-08 10:04:36 EST
(In reply to IBM Bug Proxy from comment #3)
> ------- Comment From gbertazi@br.ibm.com 2015-12-07 16:06 EDT-------
> Questions for Red Hat:
> 
> 1) What is the firmware level of this machine?

It's version 810, as far as I know:

# cat /proc/device-tree/ibm,opal/firmware/ml-version
ML FW810.40 FW810.40 FW810.40
# cat /proc/device-tree/ibm,opal/firmware/mi-version
MI SV810_146 SV810_146 SV810_146

> 2) When was the usb gadget first connected?

It was connected while the machine was up and running Linux - i.e. the USB disk was "hot-plugged".

> Can you reproduce the issue in
> the first boot by connecting it before starting the boot sequence(i.e. by
> having the USB gadget attached before the probe of the USB host controller)?

Not sure if I've got that right - when should the USB disk be attached? Before powering the machine on? Or while petitboot is already running?

FWIW, we already tried to completely power the machine off via the FSP, even reset the FSP, but the USB disk never appeared again after booting as long as it was plugged. It only appears when freshly "hot-plugging" it while Linux is already up and running.

(I have to add that my testing capabilities are a little bit limited since I do not have physical access to the machine since it is located in a completely different location - so I've got to ask for a lab technician each time we need to re-plug the USB gadget)
Comment 7 Thomas Huth 2015-12-08 10:11:55 EST
In case this helps, here's some console output of Linux:

Initially, the USB disk did not show up (though it was plugged),
since the machine has already been rebooted shortly before:

[root ~]# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Then, after re-plugging the USB disk while the machine was running,
it showed up again:

[root ~]# lsusb
Bus 002 Device 002: ID 0781:5583 SanDisk Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
[root ~]# dmesg
...
[44364.004267] usb 2-4: new SuperSpeed USB device number 2 using xhci_hcd
[44364.029004] usb 2-4: New USB device found, idVendor=0781, idProduct=5583
[44364.029072] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[44364.029080] usb 2-4: Product: Ultra Fit
[44364.029084] usb 2-4: Manufacturer: SanDisk
[44364.029088] usb 2-4: SerialNumber: 4C530001230824121264
[44364.038743] usb-storage 2-4:1.0: USB Mass Storage device detected
[44364.039084] scsi host2: usb-storage 2-4:1.0
[44364.039208] usbcore: registered new interface driver usb-storage
[44365.035487] scsi 2:0:0:0: Direct-Access     SanDisk  Ultra Fit        1.00 PQ: 0 ANSI: 6
[44365.036043] sd 2:0:0:0: Attached scsi generic sg19 type 0
[44365.036240] sd 2:0:0:0: [sdd] 242614272 512-byte logical blocks: (124 GB/115 GiB)
[44365.037457] sd 2:0:0:0: [sdd] Write Protect is off
[44365.037504] sd 2:0:0:0: [sdd] Mode Sense: 43 00 00 00
[44365.038397] sd 2:0:0:0: [sdd] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[44365.052299]  sdd: sdd1
[44365.054079] sd 2:0:0:0: [sdd] Attached SCSI removable disk

When I then rebooted the machine, the disk was "gone" again
(though it was still physically plugged):

[root ~]# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Comment 8 IBM Bug Proxy 2015-12-08 13:10:54 EST
------- Comment From gbertazi@br.ibm.com 2015-12-08 18:12 EDT-------
(In reply to comment #7)
> Not sure if I've got that right - when should the USB disk be attached?
> Before powering the machine on? Or while petitboot is already running?

Either one is fine.  The important part for this test is that the distro kernel hasn't started loading when the USB disk is inserted.  So either powering on with the USB attached or connecting it while on Petitboot should do the job.

> FWIW, we already tried to completely power the machine off via the FSP, even
> reset the FSP, but the USB disk never appeared again after booting as long
> as it was plugged. It only appears when freshly "hot-plugging" it while
> Linux is already up and running.

I guess that did the test. :)

> In case this helps, here's some console output of Linux:
> Initially, the USB disk did not show up (though it was plugged),
> since the machine has already been rebooted shortly before:
>
> [root ~]# lsusb
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
>
> Then, after re-plugging the USB disk while the machine was running,
> it showed up again:
>
> [root ~]# lsusb
> Bus 002 Device 002: ID 0781:5583 SanDisk Corp.
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> [root ~]# dmesg

A dmesg of the boot in which the USB did not appear would helpful.  Please also provide the lspci output.

I think we'll see USB host probe failures when the gadget is attached during the XHCI driver probe.  If this is the case, it's probably a firmware regression we have already fixed.  I'm trying to get you guys a patched fw image for testing.
Comment 9 IBM Bug Proxy 2015-12-09 07:30:22 EST
------- Comment From gbertazi@br.ibm.com 2015-12-09 12:32 EDT-------
Is it possible for you to go to IBM Fix Central and do a firmware upgrade to SV840_056 (FW840.00)? That should include the USB patches that should fix this issue.

Documentation in the Fix Central page should be help in the process of firmware upgrade.  Let me know if you need any assistance..
Comment 10 Thomas Huth 2015-12-09 09:42:34 EST
(In reply to IBM Bug Proxy from comment #9)
> ------- Comment From gbertazi@br.ibm.com 2015-12-09 12:32 EDT-------
> Is it possible for you to go to IBM Fix Central and do a firmware upgrade to
> SV840_056 (FW840.00)? That should include the USB patches that should fix
> this issue.

I've now upgraded the firmware to SV840, but it apparently did not help. ... I'll collect the outputs of dmesg and lspci next ...
Comment 11 Thomas Huth 2015-12-09 09:55 EST
Created attachment 1103952 [details]
output taken from petitboot shell

I've now shut down the machine, rebooted the service processor, then powered it on again and directly entered the shell of petitboot before booting an OS. The /sys fs also only shows the four root hubs there, no additional USB device is visible, also not in the output of dmesg. It's just like the USB disk was not connected (but I am sure it is).
Comment 12 Thomas Huth 2015-12-09 10:08 EST
Created attachment 1103956 [details]
output taken from PowerKVM

Here's the dmesg output that I get when booting into PowerKVM
Comment 13 IBM Bug Proxy 2015-12-23 13:20:31 EST
------- Comment From gbertazi@br.ibm.com 2015-12-23 18:22 EDT-------
(In reply to comment #11)
> Created attachment 104368 [details]
> output taken from petitboot shell

Hi

I failed at every attempt to reproduce this in the lab.  I've got a very similar setup, same machine, same kernel, OS and FW level, but I never see the device go missing.

Looking at your logs, I see the USB device is already missing at Petitboot.  To further trace the issue, can you please collect the file /sys/firmware/opal/msglog from a boot where the device is missing and attach it to this bug?

It's very strange that the HC probe goes fine, but the gadget is simply not found at any time by the HC.  Since you see this 100% of the time, I'm starting to suspect of a physical problem with your hardware.  I suppose you have another XHCI device in your system, by looking at the logs.  Did you try switching the device to another port in the other controller, to see if the issue goes away?

I'll keep attempting to reproduce it in our lab in an automatic fashion, in the case the issue is very intermittent.

Thanks,
Comment 14 Jeff Nelson 2015-12-23 13:29:30 EST
FYI, the gadget in question is this:

http://www.amazon.com/gp/product/B00YFI1EBC

We have tried plugging it into both ports at the front of the system, but that makes no difference.

I'll let others answer the rest of your questions.
Comment 15 Laurent Vivier 2015-12-24 04:22 EST
Created attachment 1109162 [details]
content of /sys/firmware/opal/msglog

This is the content of /sys/firmware/opal/msglog taken from petiboot shell.
Comment 16 IBM Bug Proxy 2016-01-05 12:30:52 EST
------- Comment From gbertazi@br.ibm.com 2016-01-05 17:30 EDT-------
I see no gadget information in the opal logs either... Since we are failing at every attempt to reproduce it, I suspect more and more of a hardware issue.

I'm forwarding this to the Firmware team to see if they can help us confirm a hardware issue or identify the cause in the early boot process.

Samuel, can you take a look at this one and let us know what you think?
Comment 17 IBM Bug Proxy 2016-01-05 22:50:50 EST
------- Comment From sjonas@au1.ibm.com 2016-01-06 03:48 EDT-------
(In reply to comment #7)
> [44364.029080] usb 2-4: Product: Ultra Fit
> [44364.029084] usb 2-4: Manufacturer: SanDisk
> [44364.029088] usb 2-4: SerialNumber: 4C530001230824121264
> [44364.038743] usb-storage 2-4:1.0: USB Mass Storage device detected
> [44364.039084] scsi host2: usb-storage 2-4:1.0
> [44364.039208] usbcore: registered new interface driver usb-storage
> [44365.035487] scsi 2:0:0:0: Direct-Access     SanDisk  Ultra Fit

I notice the Ultra Fit is a USB3 device - do you happen to have a USB2 device that you could try to reproduce with?

Thanks,
Sam
Comment 18 Jeff Nelson 2016-01-07 01:27:56 EST
A USB2 device (1gb) was plugged in to ibm-p8-virt-01 earlier today. Laurent, would you please test to see if it is present and if it returns after a reboot?
Comment 19 Laurent Vivier 2016-01-07 03:41:24 EST
The USB device is present before _and_ after a reboot.

[Bus 001 Device 002: ID 058f:6387 Alcor Micro Corp. Flash Drive]
Comment 20 IBM Bug Proxy 2016-02-08 06:40:58 EST
------- Comment From viparash@in.ibm.com 2016-02-08 06:32 EDT-------
*** Bug 133973 has been marked as a duplicate of this bug. ***
Comment 21 IBM Bug Proxy 2016-02-08 16:53:35 EST
------- Comment From cdeadmin@us.ibm.com 2016-02-08 16:49 EDT-------
cde00 (cdeadmin@us.ibm.com) added native attachment /tmp/AIXOS05564102/opal.msglog on 2016-02-08 15:48:48
cde00 (cdeadmin@us.ibm.com) added native attachment /tmp/AIXOS05564102/file_1288910.txt on 2016-02-08 15:48:48
Comment 22 Thomas Huth 2016-05-09 13:16:08 EDT
Hello IBM! Any news from your side on this ticket?
Our team recently switched to different POWER8 machines (I think the model type is now S812L instead of S822L that we used before), and the very same problem occurs there, too: After reboot, the USB3 SanDisk devices do not show up anymore. USB2 devices seem to work fine.
Comment 23 Thomas Huth 2016-05-09 13:17:14 EDT
We've also noticed a slightly new detail now: Once the USB3 device disappeared after reboot, it does not help to remove it and plug it into the very same slot again - the slot/device then stays dead. But as soon as we plug the device into a different slot, it correctly shows up there (until the next reboot). We've tested this behavior with different slots + multiple reboots, so it's definitely not a hardware problem with one slot only. It's rather sounds like the firmware disabled the USB slot that contained the USB3 device during boot, and it can not be used anymore until the next reboot activated the (then empty) slot again.
Comment 24 IBM Bug Proxy 2016-05-10 08:51:26 EDT
------- Comment From jmstanle@au1.ibm.com 2016-05-10 08:44 EDT-------
Can we please have a copy of your kernel log (the output of dmesg)?

What is the kernel version? (uname -a)

Is this in petitboot, or in the host?
Comment 25 Thomas Huth 2016-05-10 11:36:14 EDT
It happens in petitboot already - the USB3 devices are not visible there after reboot, too, so I suspect the bug is on an even lower level (OPAL?).

There should already be some logs attached to this bug (from petitboot, PowerKVM and  /sys/firmware/opal/msglog) ... if they are missing on your side, they got lost by the bridge, I guess.

Anyway, I here's the output of petitboot from the last test that we did on the new system. We had two USB devices attached during this reboot, a USB2 stick from Lexar (which got detected right), and a USB3 stick from SanDisk (which does not show up at all):

[    0.000000] opal: OPAL V3 detected !
[    0.000000] Using PowerNV machine description
[    0.000000] Page sizes from device-tree:
[    0.000000] base_shift=12: shift=12, sllp=0x0000, avpnm=0x00000000, tlbiel=1, penc=0
[    0.000000] base_shift=12: shift=16, sllp=0x0000, avpnm=0x00000000, tlbiel=1, penc=7
[    0.000000] base_shift=12: shift=24, sllp=0x0000, avpnm=0x00000000, tlbiel=1, penc=56
[    0.000000] base_shift=16: shift=16, sllp=0x0110, avpnm=0x00000000, tlbiel=1, penc=1
[    0.000000] base_shift=16: shift=24, sllp=0x0110, avpnm=0x00000000, tlbiel=1, penc=8
[    0.000000] base_shift=24: shift=24, sllp=0x0100, avpnm=0x00000001, tlbiel=0, penc=0
[    0.000000] base_shift=34: shift=34, sllp=0x0120, avpnm=0x000007ff, tlbiel=0, penc=3
[    0.000000] Using 1TB segments
[    0.000000] Found initrd at 0xc000000028000000:0xc000000028659cd4
[    0.000000] bootconsole [udbg0] enabled
[    0.000000] CPU maps initialized for 8 threads per core
 -> smp_release_cpus()
spinning_secondaries = 95
 <- smp_release_cpus()
[    0.000000] Starting Linux PPC64 #1 SMP Thu Oct 29 19:46:07 CDT 2015
[    0.000000] -----------------------------------------------------
[    0.000000] ppc64_pft_size    = 0x0
[    0.000000] phys_mem_size     = 0x1000000000
[    0.000000] cpu_features      = 0x177c7aed18500249
[    0.000000]   possible        = 0x1f7fffef18500649
[    0.000000]   always          = 0x0000000018100040
[    0.000000] cpu_user_features = 0xdc0065c7 0xae000000
[    0.000000] mmu_features      = 0x7c000003
[    0.000000] firmware_features = 0x0000000430000000
[    0.000000] htab_address      = 0xc000000ff8000000
[    0.000000] htab_hash_mask    = 0x7ffff
[    0.000000] -----------------------------------------------------
 <- setup_system()
[    0.000000] Linux version 3.18.22-321.el7_1.13.ppc64le (mockbuild@bldple1) (gcc version 4.8.3 20140911 (IBM 4.8.3-9) (GCC) ) #1 SMP Thu Oct 29 19:46:07 CDT 2015
[    0.000000] numa: Initmem setup node 0 [mem 0x00000000-0x7ffffffff]
[    0.000000] numa:   NODE_DATA [mem 0x7ffff5400-0x7ffffffff]
[    0.000000] numa: Initmem setup node 1 [mem 0x800000000-0xfffffffff]
[    0.000000] numa:   NODE_DATA [mem 0xfffca1400-0xfffcabfff]
[    0.000000] Initializing IODA2 OPAL PHB /pciex@3fffe40000000
[    0.000000] PCI host bridge /pciex@3fffe40000000 (primary) ranges:
[    0.000000]  MEM 0x00003fe000000000..0x00003fe07ffeffff -> 0x0000000080000000 
[    0.000000]   256 (255) PE's M32: 0x80000000 [segment=0x800000]
[    0.000000]                  M64: 0x1000000000 [segment=0x10000000]
[    0.000000]   Allocated bitmap for 2040 MSIs (base IRQ 0x800)
[    0.000000] Initializing IODA2 OPAL PHB /pciex@3fffe40100000
[    0.000000] PCI host bridge /pciex@3fffe40100000  ranges:
[    0.000000]  MEM 0x00003fe080000000..0x00003fe0fffeffff -> 0x0000000080000000 
[    0.000000]   256 (255) PE's M32: 0x80000000 [segment=0x800000]
[    0.000000]                  M64: 0x1000000000 [segment=0x10000000]
[    0.000000]   Allocated bitmap for 2040 MSIs (base IRQ 0x1000)
[    0.000000] Initializing IODA2 OPAL PHB /pciex@3fffe40400000
[    0.000000] PCI host bridge /pciex@3fffe40400000  ranges:
[    0.000000]  MEM 0x00003fe200000000..0x00003fe27ffeffff -> 0x0000000080000000 
[    0.000000]   256 (255) PE's M32: 0x80000000 [segment=0x800000]
[    0.000000]                  M64: 0x1000000000 [segment=0x10000000]
[    0.000000]   Allocated bitmap for 2040 MSIs (base IRQ 0x2800)
[    0.000000] Initializing IODA2 OPAL PHB /pciex@3fffe40500000
[    0.000000] PCI host bridge /pciex@3fffe40500000  ranges:
[    0.000000]  MEM 0x00003fe280000000..0x00003fe2fffeffff -> 0x0000000080000000 
[    0.000000]   256 (255) PE's M32: 0x80000000 [segment=0x800000]
[    0.000000]                  M64: 0x1000000000 [segment=0x10000000]
[    0.000000]   Allocated bitmap for 2040 MSIs (base IRQ 0x3000)
[    0.000000] OPAL nvram setup, 1048576 bytes
[    0.000000] Zone ranges:
[    0.000000]   DMA      [mem 0x00000000-0xfffffffff]
[    0.000000]   DMA32    empty
[    0.000000]   Normal   empty
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x7ffffffff]
[    0.000000]   node   1: [mem 0x800000000-0xfffffffff]
[    0.000000] Initmem setup node 0 [mem 0x00000000-0x7ffffffff]
[    0.000000] Initmem setup node 1 [mem 0x800000000-0xfffffffff]
[    0.000000] PERCPU: Embedded 2 pages/cpu @c0000007ff300000 s46336 r0 d84736 u131072
[    0.000000] Built 2 zonelists in Node order, mobility grouping on.  Total pages: 1047680
[    0.000000] Policy zone: DMA
[    0.000000] Kernel command line: 
[    0.000000] PID hash table entries: 4096 (order: -1, 32768 bytes)
[    0.000000] Sorting __ex_table...
[    0.000000] Memory: 66848640K/67108864K available (11776K kernel code, 1088K rwdata, 4776K rodata, 576K init, 1900K bss, 260224K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=128, Order=0-3, MinObjects=0, CPUs=96, Nodes=256
[    0.000000] Hierarchical RCU implementation.
[    0.000000] 	RCU restricting CPUs from NR_CPUS=2048 to nr_cpu_ids=96.
[    0.000000] RCU: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=96
[    0.000000] NR_IRQS:512 nr_irqs:512 16
[    0.000000] ICS OPAL backend registered
[    0.000003] clocksource: timebase mult[1f40000] shift[24] registered
[    0.001934] Console: colour dummy device 80x25
[    0.003073] console [hvc0] enabled
[    0.003073] console [hvc0] enabled
[    0.003760] bootconsole [udbg0] disabled
[    0.003760] bootconsole [udbg0] disabled
[    0.004780] pid_max: default: 98304 minimum: 768
[    0.007023] Dentry cache hash table entries: 8388608 (order: 10, 67108864 bytes)
[    0.049545] Inode-cache hash table entries: 4194304 (order: 9, 33554432 bytes)
[    0.066511] Mount-cache hash table entries: 131072 (order: 4, 1048576 bytes)
[    0.066638] Mountpoint-cache hash table entries: 131072 (order: 4, 1048576 bytes)
[    0.069307] EEH: PowerNV platform initialized
[    0.069433] POWER8 performance monitor hardware support registered
[    0.069582] power8-pmu: PMAO restore workaround active.
[    0.071533] NMI watchdog: disabled (cpu48): hardware events not enabled
[    0.072301] NMI watchdog: disabled (cpu0): hardware events not enabled
[    0.158930] Brought up 96 CPUs
[    0.165308] devtmpfs: initialized
[    0.165560] EEH: devices created
[    0.165773] xor: measuring software checksum speed
[    0.261879]    8regs     : 13696.000 MB/sec
[    0.361897]    8regs_prefetch: 12371.200 MB/sec
[    0.461914]    32regs    : 14419.200 MB/sec
[    0.561933]    32regs_prefetch: 12729.600 MB/sec
[    0.661946]    altivec   : 20249.600 MB/sec
[    0.661990] xor: using function: altivec (20249.600 MB/sec)
[    0.665029] NET: Registered protocol family 16
[    0.691955] cpuidle: using governor ladder
[    0.721958] cpuidle: using governor menu
[    0.729656] PCI: Probing PCI hardware
[    0.729752] PCI: I/O resource not set for host bridge /pciex@3fffe40000000 (domain 0)
[    0.729862] PCI host bridge to bus 0000:00
[    0.729905] pci_bus 0000:00: root bus resource [mem 0x3fe000000000-0x3fe07ffeffff] (bus address [0x80000000-0xfffeffff])
[    0.729999] pci_bus 0000:00: root bus resource [mem 0x3b0000000000-0x3b0fefffffff 64bit pref]
[    0.730082] pci_bus 0000:00: root bus resource [bus 00-ff]
[    0.730330] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.730476] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    0.730553] PCI: I/O resource not set for host bridge /pciex@3fffe40100000 (domain 1)
[    0.730644] PCI host bridge to bus 0001:00
[    0.730684] pci_bus 0001:00: root bus resource [mem 0x3fe080000000-0x3fe0fffeffff] (bus address [0x80000000-0xfffeffff])
[    0.730779] pci_bus 0001:00: root bus resource [mem 0x3b1000000000-0x3b1fefffffff 64bit pref]
[    0.730860] pci_bus 0001:00: root bus resource [bus 00-ff]
[    0.731441] pci 0001:00:00.0: PCI bridge to [bus 01-0d]
[    0.732437] pci 0001:01:00.0: PCI bridge to [bus 02-0d]
[    0.732713] pci 0001:02:01.0: PCI bridge to [bus 03-07]
[    0.733197] pci 0001:02:08.0: PCI bridge to [bus 08]
[    0.733401] pci 0001:02:09.0: PCI bridge to [bus 09-0d]
[    0.733576] PCI: I/O resource not set for host bridge /pciex@3fffe40400000 (domain 2)
[    0.733731] PCI host bridge to bus 0002:00
[    0.733804] pci_bus 0002:00: root bus resource [mem 0x3fe200000000-0x3fe27ffeffff] (bus address [0x80000000-0xfffeffff])
[    0.733983] pci_bus 0002:00: root bus resource [mem 0x3b4000000000-0x3b4fefffffff 64bit pref]
[    0.734141] pci_bus 0002:00: root bus resource [bus 00-ff]
[    0.734410] pci 0002:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.734618] pci 0002:00:00.0: PCI bridge to [bus 01-ff]
[    0.734735] PCI: I/O resource not set for host bridge /pciex@3fffe40500000 (domain 3)
[    0.734889] PCI host bridge to bus 0003:00
[    0.734963] pci_bus 0003:00: root bus resource [mem 0x3fe280000000-0x3fe2fffeffff] (bus address [0x80000000-0xfffeffff])
[    0.735143] pci_bus 0003:00: root bus resource [mem 0x3b5000000000-0x3b5fefffffff 64bit pref]
[    0.735301] pci_bus 0003:00: root bus resource [bus 00-ff]
[    0.735895] pci 0003:00:00.0: PCI bridge to [bus 01-13]
[    0.737402] pci 0003:01:00.0: PCI bridge to [bus 02-13]
[    0.738019] pci 0003:02:01.0: PCI bridge to [bus 03]
[    0.738175] pci 0003:02:08.0: PCI bridge to [bus 04-08]
[    0.739634] pci 0003:02:09.0: PCI bridge to [bus 09]
[    0.739851] pci 0003:02:10.0: PCI bridge to [bus 0a-0e]
[    0.740044] pci 0003:02:11.0: PCI bridge to [bus 0f-13]
[    0.740367] pci 0000:00:00.0: PCI bridge to [bus 01]
[    0.740654] pci 0001:00:00.0: BAR 9: assigned [mem 0x3b1000000000-0x3b102fffffff 64bit pref]
[    0.740812] pci 0001:00:00.0: BAR 8: assigned [mem 0x3fe080000000-0x3fe081ffffff]
[    0.740948] pci 0001:00:00.0: BAR 7: no space for [io  size 0x3000]
[    0.741063] pci 0001:00:00.0: BAR 7: failed to assign [io  size 0x3000]
[    0.741178] pci 0001:00:00.0: BAR 7: no space for [io  size 0x3000]
[    0.741291] pci 0001:00:00.0: BAR 7: failed to assign [io  size 0x3000]
[    0.741426] pci 0001:01:00.0: BAR 9: assigned [mem 0x3b1000000000-0x3b102fffffff 64bit pref]
[    0.741587] pci 0001:01:00.0: BAR 8: assigned [mem 0x3fe080000000-0x3fe0817fffff]
[    0.741723] pci 0001:01:00.0: BAR 0: assigned [mem 0x3fe081800000-0x3fe08183ffff]
[    0.741863] pci 0001:01:00.0: BAR 7: no space for [io  size 0x3000]
[    0.741981] pci 0001:01:00.0: BAR 7: failed to assign [io  size 0x3000]
[    0.742098] pci 0001:01:00.0: BAR 7: no space for [io  size 0x3000]
[    0.742212] pci 0001:01:00.0: BAR 7: failed to assign [io  size 0x3000]
[    0.742378] pci 0001:02:01.0: BAR 9: assigned [mem 0x3b1000000000-0x3b100fffffff 64bit pref]
[    0.742536] pci 0001:02:08.0: BAR 9: assigned [mem 0x3b1010000000-0x3b101fffffff 64bit pref]
[    0.742695] pci 0001:02:09.0: BAR 9: assigned [mem 0x3b1020000000-0x3b102fffffff 64bit pref]
[    0.742854] pci 0001:02:01.0: BAR 8: assigned [mem 0x3fe080000000-0x3fe0807fffff]
[    0.742991] pci 0001:02:08.0: BAR 8: assigned [mem 0x3fe080800000-0x3fe080ffffff]
[    0.743087] pci 0001:02:09.0: BAR 8: assigned [mem 0x3fe081000000-0x3fe0817fffff]
[    0.743158] pci 0001:02:01.0: BAR 7: no space for [io  size 0x1000]
[    0.743217] pci 0001:02:01.0: BAR 7: failed to assign [io  size 0x1000]
[    0.743277] pci 0001:02:08.0: BAR 7: no space for [io  size 0x1000]
[    0.743336] pci 0001:02:08.0: BAR 7: failed to assign [io  size 0x1000]
[    0.743395] pci 0001:02:09.0: BAR 7: no space for [io  size 0x1000]
[    0.743454] pci 0001:02:09.0: BAR 7: failed to assign [io  size 0x1000]
[    0.743514] pci 0001:02:09.0: BAR 7: no space for [io  size 0x1000]
[    0.743573] pci 0001:02:09.0: BAR 7: failed to assign [io  size 0x1000]
[    0.743632] pci 0001:02:08.0: BAR 7: no space for [io  size 0x1000]
[    0.743693] pci 0001:02:08.0: BAR 7: failed to assign [io  size 0x1000]
[    0.743753] pci 0001:02:01.0: BAR 7: no space for [io  size 0x1000]
[    0.743812] pci 0001:02:01.0: BAR 7: failed to assign [io  size 0x1000]
[    0.743871] pci 0001:02:01.0: PCI bridge to [bus 03-07]
[    0.743924] pci 0001:02:01.0:   bridge window [mem 0x3fe080000000-0x3fe0807fffff]
[    0.743998] pci 0001:02:01.0:   bridge window [mem 0x3b1000000000-0x3b100fffffff 64bit pref]
[    0.744087] pci 0001:08:00.0: BAR 6: assigned [mem 0x3fe080800000-0x3fe08081ffff pref]
[    0.744159] pci 0001:08:00.0: BAR 0: assigned [mem 0x3fe080820000-0x3fe08082ffff 64bit]
[    0.744242] pci 0001:08:00.0: BAR 2: assigned [mem 0x3fe080830000-0x3fe08083ffff 64bit]
[    0.744324] pci 0001:02:08.0: PCI bridge to [bus 08]
[    0.744377] pci 0001:02:08.0:   bridge window [mem 0x3fe080800000-0x3fe080ffffff]
[    0.744451] pci 0001:02:08.0:   bridge window [mem 0x3b1010000000-0x3b101fffffff 64bit pref]
[    0.744540] pci 0001:02:09.0: PCI bridge to [bus 09-0d]
[    0.744592] pci 0001:02:09.0:   bridge window [mem 0x3fe081000000-0x3fe0817fffff]
[    0.744666] pci 0001:02:09.0:   bridge window [mem 0x3b1020000000-0x3b102fffffff 64bit pref]
[    0.744754] pci 0001:01:00.0: PCI bridge to [bus 02-0d]
[    0.744806] pci 0001:01:00.0:   bridge window [mem 0x3fe080000000-0x3fe0817fffff]
[    0.744880] pci 0001:01:00.0:   bridge window [mem 0x3b1000000000-0x3b102fffffff 64bit pref]
[    0.744967] pci 0001:00:00.0: PCI bridge to [bus 01-0d]
[    0.745019] pci 0001:00:00.0:   bridge window [mem 0x3fe080000000-0x3fe081ffffff]
[    0.745097] pci 0001:00:00.0:   bridge window [mem 0x3b1000000000-0x3b102fffffff 64bit pref]
[    0.745224] pci 0002:00:00.0: PCI bridge to [bus 01]
[    0.745496] pci 0003:00:00.0: BAR 9: assigned [mem 0x3b5000000000-0x3b503fffffff 64bit pref]
[    0.745579] pci 0003:00:00.0: BAR 8: assigned [mem 0x3fe280000000-0x3fe282ffffff]
[    0.745650] pci 0003:00:00.0: BAR 7: no space for [io  size 0x4000]
[    0.745709] pci 0003:00:00.0: BAR 7: failed to assign [io  size 0x4000]
[    0.745769] pci 0003:00:00.0: BAR 7: no space for [io  size 0x4000]
[    0.745829] pci 0003:00:00.0: BAR 7: failed to assign [io  size 0x4000]
[    0.745908] pci 0003:01:00.0: BAR 9: assigned [mem 0x3b5000000000-0x3b503fffffff 64bit pref]
[    0.746033] pci 0003:01:00.0: BAR 8: assigned [mem 0x3fe280000000-0x3fe2827fffff]
[    0.746170] pci 0003:01:00.0: BAR 0: assigned [mem 0x3fe282800000-0x3fe28283ffff]
[    0.746310] pci 0003:01:00.0: BAR 7: no space for [io  size 0x4000]
[    0.746426] pci 0003:01:00.0: BAR 7: failed to assign [io  size 0x4000]
[    0.746541] pci 0003:01:00.0: BAR 7: no space for [io  size 0x4000]
[    0.746655] pci 0003:01:00.0: BAR 7: failed to assign [io  size 0x4000]
[    0.746833] pci 0003:02:08.0: BAR 9: assigned [mem 0x3b5000000000-0x3b500fffffff 64bit pref]
[    0.746992] pci 0003:02:09.0: BAR 9: assigned [mem 0x3b5010000000-0x3b501fffffff 64bit pref]
[    0.747150] pci 0003:02:10.0: BAR 9: assigned [mem 0x3b5020000000-0x3b502fffffff 64bit pref]
[    0.747309] pci 0003:02:11.0: BAR 9: assigned [mem 0x3b5030000000-0x3b503fffffff 64bit pref]
[    0.747467] pci 0003:02:01.0: BAR 8: assigned [mem 0x3fe280000000-0x3fe2807fffff]
[    0.747604] pci 0003:02:08.0: BAR 8: assigned [mem 0x3fe280800000-0x3fe280ffffff]
[    0.747742] pci 0003:02:09.0: BAR 8: assigned [mem 0x3fe281000000-0x3fe2817fffff]
[    0.747878] pci 0003:02:10.0: BAR 8: assigned [mem 0x3fe281800000-0x3fe281ffffff]
[    0.748015] pci 0003:02:11.0: BAR 8: assigned [mem 0x3fe282000000-0x3fe2827fffff]
[    0.748152] pci 0003:02:08.0: BAR 7: no space for [io  size 0x1000]
[    0.748266] pci 0003:02:08.0: BAR 7: failed to assign [io  size 0x1000]
[    0.748381] pci 0003:02:09.0: BAR 7: no space for [io  size 0x1000]
[    0.748495] pci 0003:02:09.0: BAR 7: failed to assign [io  size 0x1000]
[    0.748610] pci 0003:02:10.0: BAR 7: no space for [io  size 0x1000]
[    0.748724] pci 0003:02:10.0: BAR 7: failed to assign [io  size 0x1000]
[    0.748839] pci 0003:02:11.0: BAR 7: no space for [io  size 0x1000]
[    0.748953] pci 0003:02:11.0: BAR 7: failed to assign [io  size 0x1000]
[    0.749069] pci 0003:02:11.0: BAR 7: no space for [io  size 0x1000]
[    0.749182] pci 0003:02:11.0: BAR 7: failed to assign [io  size 0x1000]
[    0.749297] pci 0003:02:10.0: BAR 7: no space for [io  size 0x1000]
[    0.749411] pci 0003:02:10.0: BAR 7: failed to assign [io  size 0x1000]
[    0.749526] pci 0003:02:09.0: BAR 7: no space for [io  size 0x1000]
[    0.749640] pci 0003:02:09.0: BAR 7: failed to assign [io  size 0x1000]
[    0.749755] pci 0003:02:08.0: BAR 7: no space for [io  size 0x1000]
[    0.749869] pci 0003:02:08.0: BAR 7: failed to assign [io  size 0x1000]
[    0.749985] pci 0003:03:00.0: BAR 0: assigned [mem 0x3fe280000000-0x3fe28000ffff 64bit]
[    0.750133] pci 0003:03:00.0: BAR 2: assigned [mem 0x3fe280010000-0x3fe280011fff 64bit]
[    0.750282] pci 0003:02:01.0: PCI bridge to [bus 03]
[    0.750379] pci 0003:02:01.0:   bridge window [mem 0x3fe280000000-0x3fe2807fffff]
[    0.750497] pci 0003:02:08.0: PCI bridge to [bus 04-08]
[    0.750549] pci 0003:02:08.0:   bridge window [mem 0x3fe280800000-0x3fe280ffffff]
[    0.750622] pci 0003:02:08.0:   bridge window [mem 0x3b5000000000-0x3b500fffffff 64bit pref]
[    0.750711] pci 0003:09:00.0: BAR 6: assigned [mem 0x3fe281000000-0x3fe28107ffff pref]
[    0.750782] pci 0003:09:00.1: BAR 6: assigned [mem 0x3fe281080000-0x3fe2810fffff pref]
[    0.750852] pci 0003:09:00.2: BAR 6: assigned [mem 0x3fe281100000-0x3fe28117ffff pref]
[    0.750924] pci 0003:09:00.3: BAR 6: assigned [mem 0x3fe281180000-0x3fe2811fffff pref]
[    0.750994] pci 0003:09:00.0: BAR 0: assigned [mem 0x3b5010000000-0x3b501000ffff 64bit pref]
[    0.751089] pci 0003:09:00.0: BAR 2: assigned [mem 0x3b5010010000-0x3b501001ffff 64bit pref]
[    0.751184] pci 0003:09:00.0: BAR 4: assigned [mem 0x3b5010020000-0x3b501002ffff 64bit pref]
[    0.751278] pci 0003:09:00.1: BAR 0: assigned [mem 0x3b5010030000-0x3b501003ffff 64bit pref]
[    0.751373] pci 0003:09:00.1: BAR 2: assigned [mem 0x3b5010040000-0x3b501004ffff 64bit pref]
[    0.751467] pci 0003:09:00.1: BAR 4: assigned [mem 0x3b5010050000-0x3b501005ffff 64bit pref]
[    0.751562] pci 0003:09:00.2: BAR 0: assigned [mem 0x3b5010060000-0x3b501006ffff 64bit pref]
[    0.751656] pci 0003:09:00.2: BAR 2: assigned [mem 0x3b5010070000-0x3b501007ffff 64bit pref]
[    0.751751] pci 0003:09:00.2: BAR 4: assigned [mem 0x3b5010080000-0x3b501008ffff 64bit pref]
[    0.751845] pci 0003:09:00.3: BAR 0: assigned [mem 0x3b5010090000-0x3b501009ffff 64bit pref]
[    0.751939] pci 0003:09:00.3: BAR 2: assigned [mem 0x3b50100a0000-0x3b50100affff 64bit pref]
[    0.752037] pci 0003:09:00.3: BAR 4: assigned [mem 0x3b50100b0000-0x3b50100bffff 64bit pref]
[    0.752180] pci 0003:02:09.0: PCI bridge to [bus 09]
[    0.752276] pci 0003:02:09.0:   bridge window [mem 0x3fe281000000-0x3fe2817fffff]
[    0.752416] pci 0003:02:09.0:   bridge window [mem 0x3b5010000000-0x3b501fffffff 64bit pref]
[    0.752582] pci 0003:02:10.0: PCI bridge to [bus 0a-0e]
[    0.752677] pci 0003:02:10.0:   bridge window [mem 0x3fe281800000-0x3fe281ffffff]
[    0.752817] pci 0003:02:10.0:   bridge window [mem 0x3b5020000000-0x3b502fffffff 64bit pref]
[    0.752982] pci 0003:02:11.0: PCI bridge to [bus 0f-13]
[    0.753078] pci 0003:02:11.0:   bridge window [mem 0x3fe282000000-0x3fe2827fffff]
[    0.753217] pci 0003:02:11.0:   bridge window [mem 0x3b5030000000-0x3b503fffffff 64bit pref]
[    0.753379] pci 0003:01:00.0: PCI bridge to [bus 02-13]
[    0.753475] pci 0003:01:00.0:   bridge window [mem 0x3fe280000000-0x3fe2827fffff]
[    0.753615] pci 0003:01:00.0:   bridge window [mem 0x3b5000000000-0x3b503fffffff 64bit pref]
[    0.753780] pci 0003:00:00.0: PCI bridge to [bus 01-13]
[    0.753875] pci 0003:00:00.0:   bridge window [mem 0x3fe280000000-0x3fe282ffffff]
[    0.754015] pci 0003:00:00.0:   bridge window [mem 0x3b5000000000-0x3b503fffffff 64bit pref]
[    0.754219] pci 0000:00     : [PE# 000] Secondary bus 0 associated with PE#0
[    0.754490] pci 0000:01     : [PE# 001] Secondary bus 1 associated with PE#1
[    0.754759] pci 0001:00     : [PE# 000] Secondary bus 0 associated with PE#0
[    0.755035] pci 0001:01     : [PE# 001] Secondary bus 1 associated with PE#1
[    0.755306] pci 0001:02     : [PE# 002] Secondary bus 2 associated with PE#2
[    0.755574] pci 0001:03     : [PE# 003] Secondary bus 3 associated with PE#3
[    0.755847] pci 0001:08     : [PE# 004] Secondary bus 8 associated with PE#4
[    0.756118] pci 0001:09     : [PE# 005] Secondary bus 9 associated with PE#5
[    0.756390] pci 0002:00     : [PE# 000] Secondary bus 0 associated with PE#0
[    0.756660] pci 0002:01     : [PE# 001] Secondary bus 1 associated with PE#1
[    0.756865] pci 0003:00     : [PE# 000] Secondary bus 0 associated with PE#0
[    0.757073] pci 0003:01     : [PE# 002] Secondary bus 1 associated with PE#2
[    0.757278] pci 0003:02     : [PE# 003] Secondary bus 2 associated with PE#3
[    0.757482] pci 0003:03     : [PE# 004] Secondary bus 3 associated with PE#4
[    0.757686] pci 0003:04     : [PE# 005] Secondary bus 4 associated with PE#5
[    0.757892] pci 0003:09     : [PE# 001] Secondary bus 9 associated with PE#1
[    0.758097] pci 0003:0a     : [PE# 006] Secondary bus 10 associated with PE#6
[    0.758301] pci 0003:0f     : [PE# 007] Secondary bus 15 associated with PE#7
[    0.758822] PCI: Domain 0000 has 8 available 32-bit DMA segments
[    0.758881] PCI: 0 PE# for a total weight of 0
[    0.758931] PCI: Domain 0001 has 8 available 32-bit DMA segments
[    0.758990] PCI: 1 PE# for a total weight of 15
[    0.759038] pci 0001:08     : [PE# 004] Assign DMA32 space
[    0.759094] pci 0001:08     : [PE# 004] Setting up 32-bit TCE table at 0..80000000
[    0.762389] IOMMU table initialized, virtual merging enabled
[    0.762503] pci 0001:08     : [PE# 004] Setting up window#0 0..7fffffff pg=1000
[    0.762642] pci 0001:08     : [PE# 004] Enabling 64-bit DMA bypass
[    0.762761] PCI: Domain 0002 has 8 available 32-bit DMA segments
[    0.762873] PCI: 0 PE# for a total weight of 0
[    0.762967] PCI: Domain 0003 has 8 available 32-bit DMA segments
[    0.763080] PCI: 2 PE# for a total weight of 50
[    0.763174] pci 0003:09     : [PE# 001] Assign DMA32 space
[    0.763271] pci 0003:09     : [PE# 001] Setting up 32-bit TCE table at 0..80000000
[    0.766567] pci 0003:09     : [PE# 001] Setting up window#0 0..7fffffff pg=1000
[    0.766712] pci 0003:09     : [PE# 001] Enabling 64-bit DMA bypass
[    0.766783] pci 0003:03     : [PE# 004] Assign DMA32 space
[    0.766880] pci 0003:03     : [PE# 004] Setting up 32-bit TCE table at 0..80000000
[    0.770224] pci 0003:03     : [PE# 004] Setting up window#0 0..7fffffff pg=1000
[    0.770362] pci 0003:03     : [PE# 004] Enabling 64-bit DMA bypass
[    0.771345] EEH: PCI Enhanced I/O Error Handling Enabled
[    0.772790] OF: no ranges; cannot translate
[    0.773309] powernv-rng: Registering arch random hook.
[    0.774221] opal-power: OPAL EPOW, DPO support detected.
[    0.783069] create_dump_obj: New platform dump. ID = 0x2a00000e Size 8090794
[    0.982540] raid6: altivecx1  4605 MB/s
[    1.152583] raid6: altivecx2  7659 MB/s
[    1.322615] raid6: altivecx4 15146 MB/s
[    1.492648] raid6: altivecx8 20128 MB/s
[    1.662685] raid6: int64x1   2305 MB/s
[    1.832710] raid6: int64x2   3836 MB/s
[    2.002740] raid6: int64x4   7644 MB/s
[    2.172772] raid6: int64x8   4600 MB/s
[    2.172815] raid6: using algorithm altivecx8 (20128 MB/s)
[    2.172845] raid6: using intx1 recovery algorithm
[    2.172981] vgaarb: loaded
[    2.173105] random: nonblocking pool is initialized
[    2.173274] SCSI subsystem initialized
[    2.173389] usbcore: registered new interface driver usbfs
[    2.173448] usbcore: registered new interface driver hub
[    2.173773] usbcore: registered new device driver usb
[    2.173848] pps_core: LinuxPPS API ver. 1 registered
[    2.173897] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[    2.173984] PTP clock support registered
[    2.174722] Switched to clocksource timebase
[    2.177118] NET: Registered protocol family 2
[    2.177579] TCP established hash table entries: 524288 (order: 6, 4194304 bytes)
[    2.178717] TCP bind hash table entries: 65536 (order: 4, 1048576 bytes)
[    2.178955] TCP: Hash tables configured (established 524288 bind 65536)
[    2.179079] TCP: reno registered
[    2.179169] UDP hash table entries: 32768 (order: 4, 1048576 bytes)
[    2.179426] UDP-Lite hash table entries: 32768 (order: 4, 1048576 bytes)
[    2.180159] NET: Registered protocol family 1
[    2.180606] RPC: Registered named UNIX socket transport module.
[    2.180666] RPC: Registered udp transport module.
[    2.180715] RPC: Registered tcp transport module.
[    2.180762] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    2.180876] pci 0003:03:00.0: enabling device (0140 -> 0142)
[    2.181017] Trying to unpack rootfs image as initramfs...
[    3.416626] Freeing initrd memory: 6464K (c000000028000000 - c000000028650000)
[    3.417209] Hypercall H_BEST_ENERGY not supported
[    3.455721] futex hash table entries: 32768 (order: 6, 4194304 bytes)
[    3.456197] audit: initializing netlink subsys (disabled)
[    3.456262] audit: type=2000 audit(1462807064.450:1): initialized
[    3.456523] HugeTLB registered 16 MB page size, pre-allocated 0 pages
[    3.456583] HugeTLB registered 16 GB page size, pre-allocated 0 pages
[    3.462820] NFS: Registering the id_resolver key type
[    3.462892] Key type id_resolver registered
[    3.462928] Key type id_legacy registered
[    3.463752] SGI XFS with ACLs, security attributes, no debug enabled
[    3.466003] msgmni has been set to 32768
[    3.466699] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    3.466837] io scheduler noop registered
[    3.466907] io scheduler deadline registered
[    3.467168] io scheduler cfq registered (default)
[    3.476219] hvc0: raw protocol on /ibm,opal/consoles/serial@0 (boot console)
[    3.476521] hvc1: hvsi protocol on /ibm,opal/consoles/serial@1
[    3.476650] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
[    3.476974] Generic RTC Driver v1.07
[    3.477066] pseries_rng: Registering IBM pSeries RNG driver
[    3.477195] powernv_rng: Registered powernv hwrng.
[    3.477282] [drm] Initialized drm 1.1.0 20060810
[    3.477341] [drm] radeon kernel modesetting enabled.
[    3.479311] brd: module loaded
[    3.480062] loop: module loaded
[    3.480279] Loading iSCSI transport class v2.0-870.
[    3.480497] alua: device handler registered
[    3.480583] qla2xxx [0000:00:00.0]-0005: : QLogic Fibre Channel HBA Driver: 8.07.00.16-k.
[    3.480750] iscsi: registered transport (qla4xxx)
[    3.480854] QLogic iSCSI HBA Driver
[    3.480924] Emulex LightPulse Fibre Channel SCSI driver 10.4.8000.0.
[    3.481037] Copyright(c) 2004-2014 Emulex.  All rights reserved.
[    3.481210] mpt2sas version 18.100.00.00 loaded
[    3.481341] ipr: IBM Power RAID SCSI Device Driver version: 2.6.0 (November 16, 2012)
[    3.481544] ipr 0001:08:00.0: Found IOA with IRQ: 0
[    3.481820] ipr 0001:08:00.0: enabling device (0140 -> 0142)
[    3.481942] ipr 0001:08:00.0: Using 64-bit DMA iommu bypass
[    3.482148] ipr 0001:08:00.0: Received IRQ : 509
[    3.482254] ipr 0001:08:00.0: Request for 2 MSIXs succeeded.
[    3.482715] ipr 0001:08:00.0: Initializing IOA.
[    3.482810] scsi host0: IBM 0 Storage Adapter
[    3.483011] libcxgbi:libcxgbi_init_module: tag itt 0x1fff, 13 bits, age 0xf, 4 bits.
[    3.483147] libcxgbi:ddp_setup_host_page_size: system PAGE 65536, ddp idx 3.
[    3.483284] Chelsio T3 iSCSI Driver cxgb3i v2.0.0 (Jun. 2010)
[    3.483408] iscsi: registered transport (cxgb3i)
[    3.483501] Chelsio T4/T5 iSCSI Driver cxgb4i v0.9.4
[    3.483600] iscsi: registered transport (cxgb4i)
[    3.483694] QLogic NetXtreme II iSCSI Driver bnx2i v2.7.10.1 (Jul 16, 2014)
[    3.483815] iscsi: registered transport (bnx2i)
[    3.485544] iscsi: registered transport (be2iscsi)
[    3.485592] In beiscsi_module_init, tt=c00000000115e998
[    3.485680] st: Version 20101219, fixed bufsize 32768, s/g segs 256
[    3.485830] tun: Universal TUN/TAP device driver, 1.6
[    3.485877] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[    3.486004] pcnet32: pcnet32.c:v1.35 21.Apr.2008 tsbogend@alpha.franken.de
[    3.486094] cnic: QLogic NetXtreme II CNIC Driver cnic v2.5.20 (March 14, 2014)
[    3.486207] bnx2x: Broadcom NetXtreme II 5771x/578xx 10/20-Gigabit Ethernet Driver bnx2x 1.710.51-0 (2014/02/10)
[    3.486401] tg3.c:v3.137 (May 11, 2014)
[    3.486451] tg3 0003:09:00.0: enabling device (0140 -> 0142)
[    3.511678] tg3 0003:09:00.0: Using 64-bit DMA iommu bypass
[    3.511986] tg3 0003:09:00.0 eth0: Tigon3 [partno(00RX892) rev 5719001] (PCI Express) MAC address 98:be:94:03:73:a4
[    3.512082] tg3 0003:09:00.0 eth0: attached PHY is 5719C (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[1])
[    3.512177] tg3 0003:09:00.0 eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    3.512248] tg3 0003:09:00.0 eth0: dma_rwctrl[00000000] dma_mask[64-bit]
[    3.512383] tg3 0003:09:00.1: enabling device (0140 -> 0142)
[    3.533621] tg3 0003:09:00.1: Using 64-bit DMA iommu bypass
[    3.533894] tg3 0003:09:00.1 eth1: Tigon3 [partno(00RX892) rev 5719001] (PCI Express) MAC address 98:be:94:03:73:a5
[    3.533990] tg3 0003:09:00.1 eth1: attached PHY is 5719C (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[1])
[    3.534083] tg3 0003:09:00.1 eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    3.534154] tg3 0003:09:00.1 eth1: dma_rwctrl[00000000] dma_mask[64-bit]
[    3.534288] tg3 0003:09:00.2: enabling device (0140 -> 0142)
[    3.563662] tg3 0003:09:00.2: Using 64-bit DMA iommu bypass
[    3.563921] tg3 0003:09:00.2 eth2: Tigon3 [partno(00RX892) rev 5719001] (PCI Express) MAC address 98:be:94:03:73:a6
[    3.564016] tg3 0003:09:00.2 eth2: attached PHY is 5719C (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[1])
[    3.564110] tg3 0003:09:00.2 eth2: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    3.564180] tg3 0003:09:00.2 eth2: dma_rwctrl[00000000] dma_mask[64-bit]
[    3.564314] tg3 0003:09:00.3: enabling device (0140 -> 0142)
[    3.593657] tg3 0003:09:00.3: Using 64-bit DMA iommu bypass
[    3.593932] tg3 0003:09:00.3 eth3: Tigon3 [partno(00RX892) rev 5719001] (PCI Express) MAC address 98:be:94:03:73:a7
[    3.594027] tg3 0003:09:00.3 eth3: attached PHY is 5719C (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[1])
[    3.594121] tg3 0003:09:00.3 eth3: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    3.594192] tg3 0003:09:00.3 eth3: dma_rwctrl[00000000] dma_mask[64-bit]
[    3.594436] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[    3.594495] e100: Copyright(c) 1999-2006 Intel Corporation
[    3.594561] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[    3.594630] e1000: Copyright (c) 1999-2006 Intel Corporation.
[    3.594712] e1000e: Intel(R) PRO/1000 Network Driver - 2.3.2-k
[    3.594771] e1000e: Copyright(c) 1999 - 2014 Intel Corporation.
[    3.594849] ixgbe: Intel(R) 10 Gigabit PCI Express Network Driver - version 3.19.1-k
[    3.594918] ixgbe: Copyright (c) 1999-2014 Intel Corporation.
[    3.594995] ixgb: Intel(R) PRO/10GbE Network Driver - version 1.0.135-k2-NAPI
[    3.595065] ixgb: Copyright (c) 1999-2008 Intel Corporation.
[    3.595200] myri10ge: Version 1.5.3-1.534
[    3.595270] QLogic/NetXen Network Driver v4.0.82
[    3.595335] Solarflare NET driver v4.0
[    3.595616] aoe: AoE v85 initialised.
[    3.595713] xhci_hcd 0003:03:00.0: xHCI Host Controller
[    3.595789] xhci_hcd 0003:03:00.0: new USB bus registered, assigned bus number 1
[    3.595939] xhci_hcd 0003:03:00.0: Using 64-bit DMA iommu bypass
[    3.596370] hub 1-0:1.0: USB hub found
[    3.596419] hub 1-0:1.0: 4 ports detected
[    3.596584] xhci_hcd 0003:03:00.0: xHCI Host Controller
[    3.596712] xhci_hcd 0003:03:00.0: new USB bus registered, assigned bus number 2
[    3.597016] hub 2-0:1.0: USB hub found
[    3.597097] hub 2-0:1.0: 4 ports detected
[    3.597269] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.597384] ehci-pci: EHCI PCI platform driver
[    3.597489] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    3.597604] ohci-pci: OHCI PCI platform driver
[    3.597730] usbcore: registered new interface driver usb-storage
[    3.597947] mousedev: PS/2 mouse device common for all mice
[    3.598337] md: linear personality registered for level -1
[    3.598432] md: raid0 personality registered for level 0
[    3.598524] md: raid1 personality registered for level 1
[    3.598616] md: raid10 personality registered for level 10
[    3.598831] md: raid6 personality registered for level 6
[    3.598923] md: raid5 personality registered for level 5
[    3.599015] md: raid4 personality registered for level 4
[    3.599109] md: multipath personality registered for level -4
[    3.599223] md: faulty personality registered for level -5
[    3.599596] device-mapper: ioctl: 4.28.0-ioctl (2014-09-17) initialised: dm-devel@redhat.com
[    3.599988] device-mapper: multipath: version 1.7.0 loaded
[    3.600083] device-mapper: multipath round-robin: version 1.0.0 loaded
[    3.600231] powernv-cpufreq: cpufreq pstate min -38 nominal -9 max 0
[    3.604098] usbcore: registered new interface driver usbhid
[    3.604190] usbhid: USB HID core driver
[    3.604295] ipip: IPv4 over IPv4 tunneling driver
[    3.604497] TCP: cubic registered
[    3.604569] NET: Registered protocol family 17
[    3.604714] Key type dns_resolver registered
[    3.605015] registered taskstats version 1
[    3.608138] Btrfs loaded
[    3.608615] console [netcon0] enabled
[    3.608656] netconsole: network logging started
[    3.914655] usb 1-2: new high-speed USB device number 2 using xhci_hcd
[    4.058974] usb 1-2: ep 0x81 - rounding interval to 128 microframes, ep desc says 255 microframes
[    4.059055] usb 1-2: ep 0x2 - rounding interval to 128 microframes, ep desc says 255 microframes
[    4.059435] usb-storage 1-2:1.0: USB Mass Storage device detected
[    4.059715] scsi host1: usb-storage 1-2:1.0
[    5.377985] scsi 1:0:0:0: Direct-Access     Lexar    USB Flash Drive  1100 PQ: 0 ANSI: 4
[   27.692531] ipr 0001:08:00.0: Starting IOA initialization sequence.
[   27.692771] ipr 0001:08:00.0: Starting IOA initialization sequence.
[   27.694591] ipr 0001:08:00.0: Adapter firmware version: 13512900
[   27.695742] ipr 0001:08:00.0: IOA initialized.
[   27.708661] scsi 0:3:0:0: No Device         IBM      57D7001SISIOA    0150 PQ: 0 ANSI: 0
[   27.708798] scsi 0:3:0:0: Resource path: 0/FE
[   27.716180] scsi 0:0:0:0: Direct-Access     IBM      HUC109060CSS600  E700 PQ: 0 ANSI: 6
[   27.716267] scsi 0:0:0:0: Resource path: 0/00-00
[   27.726963] scsi 0:0:1:0: Direct-Access     IBM      HUC109060CSS600  E700 PQ: 0 ANSI: 6
[   27.727099] scsi 0:0:1:0: Resource path: 0/00-01
[   27.739537] scsi 0:0:2:0: Direct-Access     IBM      HUC109060CSS600  E700 PQ: 0 ANSI: 6
[   27.739672] scsi 0:0:2:0: Resource path: 0/00-02
[   27.747030] scsi 0:0:3:0: Direct-Access     IBM      HUC109060CSS600  E700 PQ: 0 ANSI: 6
[   27.747194] scsi 0:0:3:0: Resource path: 0/00-04
[   27.758894] scsi 0:0:4:0: Direct-Access     IBM      HUC109060CSS600  E700 PQ: 0 ANSI: 6
[   27.759029] scsi 0:0:4:0: Resource path: 0/00-05
[   27.796676] scsi 0:0:5:0: Direct-Access     IBM      HUC109060CSS600  E700 PQ: 0 ANSI: 6
[   27.796811] scsi 0:0:5:0: Resource path: 0/00-06
[   27.797453] scsi 0:1:0:0: No Device         IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.797541] scsi 0:1:0:0: Resource path: 0/FD-00
[   27.797838] scsi 0:1:1:0: No Device         IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.797924] scsi 0:1:1:0: Resource path: 0/FD-01
[   27.798221] scsi 0:1:2:0: No Device         IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.798307] scsi 0:1:2:0: Resource path: 0/FD-02
[   27.798608] scsi 0:1:3:0: No Device         IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.798693] scsi 0:1:3:0: Resource path: 0/FD-03
[   27.798979] scsi 0:1:4:0: No Device         IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.799065] scsi 0:1:4:0: Resource path: 0/FD-04
[   27.799362] scsi 0:1:5:0: No Device         IBM      IPR-0   58DBBC00      PQ: 0 ANSI: 3
[   27.799475] scsi 0:1:5:0: Resource path: 0/FD-05
[   27.799856] scsi 0:2:0:0: Direct-Access     IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.800021] scsi 0:2:0:0: Resource path: 0/FC-02-00
[   27.800375] scsi 0:2:1:0: Direct-Access     IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.800538] scsi 0:2:1:0: Resource path: 0/FC-01-00
[   27.800876] scsi 0:2:2:0: Direct-Access     IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.801041] scsi 0:2:2:0: Resource path: 0/FC-00-00
[   27.801378] scsi 0:2:3:0: Direct-Access     IBM      IPR-0   58DBBC00      PQ: 0 ANSI: 3
[   27.801541] scsi 0:2:3:0: Resource path: 0/FC-05-00
[   27.801901] scsi 0:2:4:0: Direct-Access     IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.802065] scsi 0:2:4:0: Resource path: 0/FC-04-00
[   27.802426] scsi 0:2:5:0: Direct-Access     IBM      IPR-0   6DE2AA00      PQ: 0 ANSI: 3
[   27.802590] scsi 0:2:5:0: Resource path: 0/FC-03-00
[   28.096929] scsi 0:0:6:0: Enclosure         IBM      VSBPD12M1 6GSAS    03 PQ: 0 ANSI: 2
[   28.097066] scsi 0:0:6:0: Resource path: 0/00-16
[   28.097348] scsi 0:0:7:0: Enclosure         IBM      VSBPD12M1 6GSAS    03 PQ: 0 ANSI: 2
[   28.097434] scsi 0:0:7:0: Resource path: 0/00-15
[   28.218822] ata1.00: ATAPI: IBM.    RMBO0140532, RA64, max UDMA/133
[   28.221117] ata1.00: configured for UDMA/133
[   28.223169] scsi 0:0:8:0: CD-ROM            IBM.     RMBO0140532      RA64 PQ: 0 ANSI: 2
[   28.223341] scsi 0:0:8:0: Resource path: 0/00-0F
[   28.234958] scsi 0:3:0:0: Attached scsi generic sg0 type 31
[   28.235221] scsi 0:0:0:0: Attached scsi generic sg1 type 12
[   28.235469] scsi 0:0:1:0: Attached scsi generic sg2 type 12
[   28.235692] scsi 0:0:2:0: Attached scsi generic sg3 type 12
[   28.235929] scsi 0:0:3:0: Attached scsi generic sg4 type 12
[   28.236162] scsi 0:0:4:0: Attached scsi generic sg5 type 12
[   28.236375] scsi 0:0:5:0: Attached scsi generic sg6 type 12
[   28.236623] scsi 0:1:0:0: Attached scsi generic sg7 type 31
[   28.236877] scsi 0:1:1:0: Attached scsi generic sg8 type 31
[   28.237103] scsi 0:1:2:0: Attached scsi generic sg9 type 31
[   28.237349] scsi 0:1:3:0: Attached scsi generic sg10 type 31
[   28.237598] scsi 0:1:4:0: Attached scsi generic sg11 type 31
[   28.237853] scsi 0:1:5:0: Attached scsi generic sg12 type 31
[   28.238147] sd 0:2:0:0: Attached scsi generic sg13 type 0
[   28.238340] sd 0:2:0:0: [sda] Spinning up disk...
[   28.238586] sd 0:2:1:0: Attached scsi generic sg14 type 0
[   28.238811] sd 0:2:1:0: [sdb] Spinning up disk...
[   28.239038] sd 0:2:2:0: Attached scsi generic sg15 type 0
[   28.239632] sd 0:2:3:0: Attached scsi generic sg16 type 0
[   28.240159] sd 0:2:4:0: Attached scsi generic sg17 type 0
[   28.240760] sd 0:2:5:0: Attached scsi generic sg18 type 0
[   28.241313] scsi 0:0:6:0: Attached scsi generic sg19 type 13
[   28.241897] scsi 0:0:7:0: Attached scsi generic sg20 type 13
[   28.252439] sd 0:2:2:0: [sdc] Spinning up disk...
[   28.252558] sd 0:2:4:0: [sde] Spinning up disk...
[   28.252563] sd 0:2:3:0: [sdd] Spinning up disk...
[   28.252996] sd 0:2:5:0: [sdf] Spinning up disk...
[   28.256651] sr 0:0:8:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[   28.256744] cdrom: Uniform CD-ROM driver Revision: 3.20
[   28.257268] sr 0:0:8:0: Attached scsi generic sg21 type 5
[   28.257570] scsi 1:0:0:0: alua: supports implicit and explicit TPGS
[   28.258074] scsi 1:0:0:0: alua: No target port descriptors found
[   28.258213] scsi 1:0:0:0: alua: not attached
[   28.258634] sd 1:0:0:0: Attached scsi generic sg22 type 0
[   28.258847] sd 1:0:0:0: [sdg] 62517248 512-byte logical blocks: (32.0 GB/29.8 GiB)
[   28.259565] sd 1:0:0:0: [sdg] Write Protect is off
[   28.260192] sd 1:0:0:0: [sdg] No Caching mode page found
[   28.260305] sd 1:0:0:0: [sdg] Assuming drive cache: write through
[   28.265583]  sdg:
[   28.267269] sd 1:0:0:0: [sdg] Attached SCSI removable disk
[   29.514659] .ready
[   29.514855] sd 0:2:0:0: [sda] 1115734016 512-byte logical blocks: (571 GB/532 GiB)
[   29.514933] sd 0:2:0:0: [sda] 4096-byte physical blocks
[   29.515201] sd 0:2:0:0: [sda] Write Protect is off
[   29.544652] .ready
[   29.544807] sd 0:2:1:0: [sdb] 1115734016 512-byte logical blocks: (571 GB/532 GiB)
[   29.544883] sd 0:2:1:0: [sdb] 4096-byte physical blocks
[   29.545125] sd 0:2:1:0: [sdb] Write Protect is off
[   29.584651] .ready
[   29.584808] sd 0:2:2:0: [sdc] 1115734016 512-byte logical blocks: (571 GB/532 GiB)
[   29.584884] sd 0:2:2:0: [sdc] 4096-byte physical blocks
[   29.585126] sd 0:2:2:0: [sdc] Write Protect is off
[   29.614714] sd 0:2:0:0: [sda] Cache data unavailable
[   29.614809] sd 0:2:0:0: [sda] Assuming drive cache: write through
[   29.624658] .ready
[   29.624854] sd 0:2:3:0: [sdd] 1115734016 512-byte logical blocks: (571 GB/532 GiB)
[   29.624956] sd 0:2:3:0: [sdd] 4096-byte physical blocks
[   29.625273] sd 0:2:3:0: [sdd] Write Protect is off
 Petitboot (dev.20151103)                                      8247-21L 214454A
 ──────────────────────────────────────────────────────────────────────────────
  [Disk: sdf2 / 1a8ec443-ed10-4dbd-bfd9-260012048bb2]
    Red Hat Enterprise Linux Server (0-rescue-eda36317625a4c6d93e823ba56bbbf3f)
    Red Hat Enterprise Linux Server (3.10.0-393.el7.ppc64le) 7.3 (Maipo)
  [Network: eth0 / 98:be:94:03:73:a4]
    netboot eth0 (pxelinux.0)

  System information
  System configuration
...
Comment 26 IBM Bug Proxy 2017-06-12 14:00:20 EDT
------- Comment From cdeadmin@us.ibm.com 2017-06-12 13:57 EDT-------
Comment 27 IBM Bug Proxy 2017-11-07 22:20:26 EST
------- Comment From sesmith@au1.ibm.com 2017-11-07 22:11 EDT-------
I wonder if this is a duplicate of https://bugzilla.linux.ibm.com/show_bug.cgi?id=158100
Comment 28 David Gibson 2018-04-17 20:53:35 EDT
I'd completely forgotten about this bug.  I believe we're no longer hitting it with current firmwares, so I'm closing.

Note You need to log in before you can comment on or make changes to this bug.