Bug 1288943 - [abrt] blivet-gui: AttributeError: 'NoneType' object has no attribute 'format'
[abrt] blivet-gui: AttributeError: 'NoneType' object has no attribute 'format'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blivet-gui (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vojtech Trefny
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6148418275817be0747fed0bc50...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 00:34 EST by Timothy M. Butterworth
Modified: 2016-01-14 03:55 EST (History)
2 users (show)

See Also:
Fixed In Version: blivet-gui-1.0.3-1 blivet-gui-1.0.3-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 03:55:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (768 bytes, text/plain)
2015-12-07 00:34 EST, Timothy M. Butterworth
no flags Details
File: blivet-gui-com.log (108.46 KB, text/plain)
2015-12-07 00:34 EST, Timothy M. Butterworth
no flags Details
File: blivet-gui-tb (206.50 KB, text/plain)
2015-12-07 00:34 EST, Timothy M. Butterworth
no flags Details
File: blivet.log (62.73 KB, text/plain)
2015-12-07 00:34 EST, Timothy M. Butterworth
no flags Details
File: description (855 bytes, text/plain)
2015-12-07 00:34 EST, Timothy M. Butterworth
no flags Details
File: environ (4.70 KB, text/plain)
2015-12-07 00:34 EST, Timothy M. Butterworth
no flags Details
File: program.log (34.21 KB, text/plain)
2015-12-07 00:35 EST, Timothy M. Butterworth
no flags Details

  None (edit)
Description Timothy M. Butterworth 2015-12-07 00:34:37 EST
Description of problem:
I simply clicked on sdb a External USB 3.0 hard drive on the left Disks selection window.

Version-Release number of selected component:
blivet-gui-1.0.2-1.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
blivet-gui.log: 
cmdline:        /usr/bin/python3  /usr/bin/blivet-gui
executable:     /usr/bin/blivet-gui
hashmarkername: blivet-gui
kernel:         4.2.6-301.fc23.x86_64
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           Python
version:        23

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/blivetgui/list_devices.py", line 191, in on_disk_selection_changed
    self.blivet_gui.update_partitions_view()
  File "/usr/lib/python3.4/site-packages/blivetgui/blivetgui.py", line 164, in update_partitions_view
    self.list_partitions.update_partitions_list(self.list_devices.selected_device)
  File "/usr/lib/python3.4/site-packages/blivetgui/list_partitions.py", line 76, in update_partitions_list
    if self._is_group_device(child):
  File "/usr/lib/python3.4/site-packages/blivetgui/list_partitions.py", line 125, in _is_group_device
    if luks_device.format and luks_device.format.type in ("lvmpv", "btrfs", "mdmember"):
AttributeError: 'NoneType' object has no attribute 'format'
Comment 1 Timothy M. Butterworth 2015-12-07 00:34:42 EST
Created attachment 1103006 [details]
File: backtrace
Comment 2 Timothy M. Butterworth 2015-12-07 00:34:45 EST
Created attachment 1103007 [details]
File: blivet-gui-com.log
Comment 3 Timothy M. Butterworth 2015-12-07 00:34:52 EST
Created attachment 1103008 [details]
File: blivet-gui-tb
Comment 4 Timothy M. Butterworth 2015-12-07 00:34:54 EST
Created attachment 1103009 [details]
File: blivet.log
Comment 5 Timothy M. Butterworth 2015-12-07 00:34:57 EST
Created attachment 1103010 [details]
File: description
Comment 6 Timothy M. Butterworth 2015-12-07 00:34:59 EST
Created attachment 1103011 [details]
File: environ
Comment 7 Timothy M. Butterworth 2015-12-07 00:35:02 EST
Created attachment 1103012 [details]
File: program.log
Comment 8 Vojtech Trefny 2015-12-07 05:59:55 EST
Thanks for the logs. Could you please test new version of blivet-gui if it fixes your problem? Thanks.

https://vtrefny.fedorapeople.org/rpms/blivet-gui-1.0.3-1.fc22.noarch.rpm
Comment 9 Timothy M. Butterworth 2015-12-07 13:37:03 EST
I installed the new version and it is no longer crashing almost immediately. I did some basic feature testing: I unlocked a LUKS drive, checked device information for a number of different partitions.

It looks like the issue is resolved with the update.

The version information still shows 1.0.2 throught the GUI.

thanks
Comment 10 Fedora Update System 2016-01-04 03:13:59 EST
blivet-gui-1.0.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8a9237c084
Comment 11 Fedora Update System 2016-01-04 15:53:27 EST
blivet-gui-1.0.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8a9237c084
Comment 12 Timothy M. Butterworth 2016-01-04 22:59:50 EST
Thanks I have not experienced any issues with 1.0.3 so far!
Comment 13 Fedora Update System 2016-01-14 03:54:57 EST
blivet-gui-1.0.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.