Bug 1288963 - [GlusterD]Probing a node having standalone volume, should not happen
Summary: [GlusterD]Probing a node having standalone volume, should not happen
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard: glusterd
Depends On: 1287951 1287992
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-07 06:25 UTC by Atin Mukherjee
Modified: 2016-04-19 07:50 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1287992
Environment:
Last Closed: 2016-02-14 03:21:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2015-12-07 06:26:20 UTC
REVIEW: http://review.gluster.org/12888 (glusterd: Disallow peer with existing volumes to be probed in cluster) posted (#1) for review on release-3.7 by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Vijay Bellur 2015-12-24 15:45:41 UTC
REVIEW: http://review.gluster.org/12888 (glusterd: Disallow peer with existing volumes to be probed in cluster) posted (#2) for review on release-3.7 by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Vijay Bellur 2015-12-28 05:35:58 UTC
REVIEW: http://review.gluster.org/12888 (glusterd: Disallow peer with existing volumes to be probed in cluster) posted (#3) for review on release-3.7 by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Vijay Bellur 2015-12-29 09:09:27 UTC
COMMIT: http://review.gluster.org/12888 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 8a9a532fd141a5456fea9729abf4273bd653cc39
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Dec 3 14:54:32 2015 +0530

    glusterd: Disallow peer with existing volumes to be probed in cluster
    
    Backport of http://review.gluster.org/12864
    
    As of now we do allow peer to get added in the trusted storage pool even if it
    has a volume configured. This is definitely not a supported configuration and
    can lead to issues as we never claim to support merging clusters. A single node
    running a standalone volume can be considered as a cluster.
    
    Change-Id: Id0cf42d6e5f20d6bfdb7ee19d860eee67c7c45be
    BUG: 1288963
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/12864
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-on: http://review.gluster.org/12888

Comment 5 Atin Mukherjee 2016-02-14 03:21:48 UTC
Fix is already available in latest 3.7.x release.

Comment 6 Kaushal 2016-04-19 07:50:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.