Bug 1288967 - Normalize Manager entry in ipa user-add
Normalize Manager entry in ipa user-add
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Abhijeet Kasurde
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 01:34 EST by Abhijeet Kasurde
Modified: 2016-11-04 01:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:42:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console.log (1.52 KB, text/plain)
2016-09-02 03:06 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Abhijeet Kasurde 2015-12-07 01:34:11 EST
Description of problem:
Try adding user with manager. Description after user-add command shows LDAP entry instead of human readable entry.


# echo Passw0rd1 | ipa user-add --first f --last f f --password 
--------------
Added user "f"
--------------
  User login: f
  First name: f
  Last name: f
  Full name: f f
  Display name: f f
  Initials: ff
  Home directory: /home/f
  GECOS: f f
  Login shell: /bin/sh
  Kerberos principal: f@TESTRELM.TEST
  Email address: f@testrelm.test
  UID: 1273200001
  GID: 1273200001
  Password: True
  Member of groups: ipausers
  Kerberos keys available: True

# echo Passw0rd1 | ipa user-add --first g --last g g --password --manager f 
--------------
Added user "g"
--------------
  User login: g
  First name: g
  Last name: g
  Full name: g g
  Display name: g g
  Initials: gg
  Home directory: /home/g
  GECOS: g g
  Login shell: /bin/sh
  Kerberos principal: g@TESTRELM.TEST
  Email address: g@testrelm.test
  UID: 1273200004
  GID: 1273200004
  Manager: uid=f,cn=users,cn=accounts,dc=testrelm,dc=test
  Password: True
  Member of groups: ipausers
  Kerberos keys available: True
# ipa user-find --manager f 
--------------
1 user matched
--------------
  User login: g
  First name: g
  Last name: g
  Home directory: /home/g
  Login shell: /bin/sh
  Email address: g@testrelm.test
  UID: 1273200004
  GID: 1273200004
  Manager: f
  Account disabled: False
  Password: True
  Kerberos keys available: True
----------------------------
Number of entries returned 1
----------------------------


Version-Release number of selected component (if applicable):
ipa-server-4.2.0-15.el7_2.3.x86_64

How reproducible:
100%

Actual results:
Manager entry shown as LDAP entry instead of human readable string

Expected results:
Manager entry should be human readable string.
Comment 2 Petr Vobornik 2015-12-15 07:13:22 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5344
Comment 3 Mike McCune 2016-03-28 18:43:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Abhijeet Kasurde 2016-09-02 03:06 EDT
Created attachment 1197055 [details]
console.log

Verified using IPA version ::
ipa-server-4.4.0-8.el7.x86_64

Marking BZ as verified.
Comment 7 errata-xmlrpc 2016-11-04 01:42:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.