Bug 1288988 - Getting errors while launching the selfheal
Getting errors while launching the selfheal
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Ravishankar N
spandura
: ZStream
Depends On: 1287503
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-12-07 02:53 EST by RajeshReddy
Modified: 2016-09-17 10:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:01:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RajeshReddy 2015-12-07 02:53:39 EST
Description of problem:
=============
Getting Errors while launching the selfheal 

Commit failed on rhs-client18.lab.eng.blr.redhat.com. Please check log file for details.
Commit failed on transformers.lab.eng.blr.redhat.com. Please check log file for details.
Commit failed on interstellar.lab.eng.blr.redhat.com. Please check log file for details.
Commit failed on ninja.lab.eng.blr.redhat.com. Please check log file for details.
Commit failed on tettnang.lab.eng.blr.redhat.com. Please check log file for details.
[root@rhs-client19 afr]# 



Version-Release number of selected component (if applicable):
===========
glusterfs-api-3.7.5-9


How reproducible:


Steps to Reproduce:
=========
1. Create 7 Node setup and create 1x2 volume using two bricks from two nodes
2. Mount it on client using FUSE and create 5k files
3. Run self heal using gluster vol heal <vol> but getting fallowing error messages (Launched from the node which is part of volume)

[root@rhs-client19 afr]# gluster vol heal test_bug 
Commit failed on rhs-client18.lab.eng.blr.redhat.com. Please check log file for details.
Commit failed on transformers.lab.eng.blr.redhat.com. Please check log file for details.
Commit failed on interstellar.lab.eng.blr.redhat.com. Please check log file for details.
Commit failed on ninja.lab.eng.blr.redhat.com. Please check log file for details.
Commit failed on tettnang.lab.eng.blr.redhat.com. Please check log file for details.


Actual results:


Expected results:
======
Self heal should be launched without any error 


Additional info:
============
[root@rhs-client18 afr]# gluster vol info test_bug 
 
Volume Name: test_bug
Type: Replicate
Volume ID: b8a9cb9f-f9ba-434e-932d-86690fc939f7
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: rhs-client19.lab.eng.blr.redhat.com:/rhs/brick3/test_bug
Brick2: vertigo.lab.eng.blr.redhat.com:/rhs/brick3/test_bug
Options Reconfigured:
performance.readdir-ahead: on

[root@rhs-client18 afr]# gluster vol status test_bug
Status of volume: test_bug
Gluster process                             TCP Port  RDMA Port  Online  Pid
------------------------------------------------------------------------------
Brick rhs-client19.lab.eng.blr.redhat.com:/
rhs/brick3/test_bug                         49163     0          Y       25538
Brick vertigo.lab.eng.blr.redhat.com:/rhs/b
rick3/test_bug                              49154     0          Y       20648
NFS Server on localhost                     2049      0          Y       31421
Self-heal Daemon on localhost               N/A       N/A        Y       31430
NFS Server on ninja.lab.eng.blr.redhat.com  2049      0          Y       24485
Self-heal Daemon on ninja.lab.eng.blr.redha
t.com                                       N/A       N/A        Y       24493
NFS Server on vertigo.lab.eng.blr.redhat.co
m                                           2049      0          Y       20668
Self-heal Daemon on vertigo.lab.eng.blr.red
hat.com                                     N/A       N/A        Y       20676
NFS Server on rhs-client19.lab.eng.blr.redh
at.com                                      2049      0          Y       25559
Self-heal Daemon on rhs-client19.lab.eng.bl
r.redhat.com                                N/A       N/A        Y       25567
NFS Server on interstellar.lab.eng.blr.redh
at.com                                      2049      0          Y       62355
Self-heal Daemon on interstellar.lab.eng.bl
r.redhat.com                                N/A       N/A        Y       62363
NFS Server on transformers.lab.eng.blr.redh
at.com                                      2049      0          Y       10542
Self-heal Daemon on transformers.lab.eng.bl
r.redhat.com                                N/A       N/A        Y       10550
NFS Server on tettnang.lab.eng.blr.redhat.c
om                                          2049      0          Y       11776
Self-heal Daemon on tettnang.lab.eng.blr.re
dhat.com                                    N/A       N/A        Y       11784
 
Task Status of Volume test_bug
------------------------------------------------------------------------------
There are no active volume tasks
Comment 2 RajeshReddy 2015-12-07 05:12:04 EST
sosreports are available @/home/repo/sosreports/bug.1288988 on rhsqe-repo.lab.eng.blr.redhat.com
Comment 5 Ravishankar N 2015-12-10 01:52:20 EST
Downstream patch: https://code.engineering.redhat.com/gerrit/#/c/63367/
Comment 6 RajeshReddy 2015-12-14 05:47:50 EST
Tested with glusterfs-server-3.7.5-11, and able to run gluster vol heal full gluster vol heal so marking this bug as verified
Comment 8 errata-xmlrpc 2016-03-01 01:01:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.