Bug 1289035 - dst qemu prompt "BUG: kvm_dirty_pages_log_disable_slot: invalid parameters" after migration complete
dst qemu prompt "BUG: kvm_dirty_pages_log_disable_slot: invalid parameters" ...
Status: CLOSED DUPLICATE of bug 1294941
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.8
x86_64 All
high Severity high
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
: Regression
Depends On:
Blocks: 1359965
  Show dependency treegraph
 
Reported: 2015-12-07 04:57 EST by Qianqian Zhu
Modified: 2017-02-08 07:23 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-04 04:55:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qianqian Zhu 2015-12-07 04:57:51 EST
Description of problem:
destination qemu prompt  "BUG: kvm_dirty_pages_log_disable_slot: invalid parameters" after migration complete

Version-Release number of selected component (if applicable):
RHEL6.7GA
kernel:kernel-2.6.32-590.el6.x86_64
qemu-kvm:qemu-kvm-0.12.1.2-2.481.el6.x86_64

How reproducible:
sometimes,irregular

Steps to Reproduce:
1.launch guest with command line:
/usr/libexec/qemu-kvm -name win10 -m 2048 -cpu Westmere,check -realtime mlock=off -smp 4,sockets=2,cores=1,threads=1 -uuid 7bef3814-631a-48bb-bae8-2b1de75f7a13 -nodefaults -rtc base=localtime,driftfix=slew -global kvm-pit.lost_tick_policy=discard -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot order=d,menu=on -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/nfs/windows10.raw,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0 -msg timestamp=on -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -vga cirrus -monitor stdio -vnc :3 -drive file=/nfs/en_windows_10_enterprise_x86_dvd_6851156.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,drive=drive-ide0-1-0,id=ide0-1-0

2.same command line with -incoming tcp:0:5800 on destination host.
3.migrate -d tcp:xxx:5800

Actual results:
prompt: "BUG: kvm_dirty_pages_log_disable_slot: invalid parameters"

Expected results:
migration finish correctly, no error.

Additional info:
Comment 2 Qianqian Zhu 2015-12-08 00:25:16 EST
100% reproduced with cmd:
/usr/libexec/qemu-kvm -name win10 -m 2048 -cpu Westmere,check -realtime mlock=off -smp 4,sockets=2,cores=1,threads=1 -uuid 7bef3814-631a-48bb-bae8-2b1de75f7a13 -nodefaults -rtc base=localtime,driftfix=slew -global kvm-pit.lost_tick_policy=discard -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot order=c,menu=on -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/nfs/windows10.raw,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0 -msg timestamp=on -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -vga cirrus -monitor stdio -vnc :3 -drive file=/nfs/en_windows_10_enterprise_x86_dvd_6851156.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/usr/share/virtio-win/virtio-win-1.7.5_x86.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0  -device e1000,netdev=hostnet0,id=net0,mac=D4:AE:52:E9:57:36 -netdev tap,id=hostnet0

and same cmd plus -incoming tcp:0:5800 on dst host.


dst qemu wont prompt the error immediately after migration finished, it will prompt after do 'remote-view vnc://$dst_ip:5903'(guest works well).
Comment 4 juzhang 2015-12-09 18:41:41 EST
Hi Qian,

Could you handle comment3?

Best Regards,
Junyi
Comment 6 Juan Quintela 2016-02-24 06:53:38 EST
ok, we are missing a:

cache=none 

in

-drive file=/nfs/windows10.raw,if=none,id=drive-virtio-disk0,format=raw

For migration to work reliablely.
But not sure that is the problem we are having here.
Comment 21 Qianqian Zhu 2016-12-21 01:07:07 EST
Hi Juan,

I have reproduced this issue with qemu-kvm-0.12.1.2-2.479.el6.x86_64, with command line [1], which has cache=none.
And could not reproduce it with qemu-kvm-0.12.1.2-2.456.el6.x86_64, with same command line.
Hope it helps.

[1] /usr/libexec/qemu-kvm -name linux -m 2048 -cpu Westmere,check -realtime mlock=off -smp 4,sockets=2,cores=1,threads=1 -uuid 7bef3814-631a-48bb-bae8-2b1de75f7a13 -nodefaults -rtc base=localtime,driftfix=slew -global kvm-pit.lost_tick_policy=discard -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -boot order=c,menu=on -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/nfs/rhel68-64-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0 -msg timestamp=on -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8 -vga cirrus -monitor stdio -vnc :3 -device e1000,netdev=hostnet0,id=net0,mac=D4:AE:52:E9:57:36 -netdev tap,id=hostnet0 --incoming tcp::1234
Comment 22 Juan Quintela 2016-12-21 04:37:37 EST
Thanks.  Problem was introduced in

qemu-kvm-0.12.1.2-2.459.el6

I even found the guilty commit, but it is not obvious why it is creating the error.  Initial assessment is that the error message shouldn't be printed, not that there is any problem.

Later, Juan.
Comment 24 Gerd Hoffmann 2017-01-03 04:21:47 EST
> I have reproduced this issue with qemu-kvm-0.12.1.2-2.479.el6.x86_64, with
> command line [1], which has cache=none.
> And could not reproduce it with qemu-kvm-0.12.1.2-2.456.el6.x86_64, with
> same command line.

Can you try qemu-kvm-0.12.1.2-2.497.el6?
Possibly this is a bug 1294941 duplicate.

Note You need to log in before you can comment on or make changes to this bug.