Bug 1289041 - [abrt] simple-scan: get_display_name_from_file_list(): simple-scan killed by SIGABRT
[abrt] simple-scan: get_display_name_from_file_list(): simple-scan killed by ...
Status: CLOSED DUPLICATE of bug 1297632
Product: Fedora
Classification: Fedora
Component: simple-scan (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f198a654534262df8f4b8e22915...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 05:06 EST by Artur Flinta
Modified: 2016-02-09 05:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 05:41:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (60.39 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: core_backtrace (18.97 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: dso_list (22.06 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: environ (1.79 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: maps (101.30 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: mountinfo (3.50 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: open_fds (2.38 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: proc_pid_status (1019 bytes, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details
File: var_log_messages (1.06 KB, text/plain)
2015-12-07 05:06 EST, Artur Flinta
no flags Details

  None (edit)
Description Artur Flinta 2015-12-07 05:06:21 EST
Description of problem:
Program died during scan saving (while entering file name).

Version-Release number of selected component:
simple-scan-3.18.1-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        simple-scan
crash_function: get_display_name_from_file_list
executable:     /usr/bin/simple-scan
global_pid:     16901
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 get_display_name_from_file_list at gtkfilechooserwidget.c:6280
 #5 gtk_file_chooser_widget_should_respond at gtkfilechooserwidget.c:6824
 #6 response_cb at gtkfilechooserdialog.c:660
 #11 _g_closure_invoke_va at gclosure.c:864
 #14 button_activate_timeout at gtkbutton.c:2038
 #21 gtk_dialog_run at gtkdialog.c:1395
 #22 user_interface_choose_file_location at /home/bob/bzr/simple-scan/3.18/src/ui.vala:586
 #23 user_interface_save_document at /home/bob/bzr/simple-scan/3.18/src/ui.vala:620
 #24 _g_closure_invoke_va at gclosure.c:864
 #27 gtk_button_do_release at gtkbutton.c:1899
Comment 1 Artur Flinta 2015-12-07 05:06:27 EST
Created attachment 1103119 [details]
File: backtrace
Comment 2 Artur Flinta 2015-12-07 05:06:29 EST
Created attachment 1103120 [details]
File: cgroup
Comment 3 Artur Flinta 2015-12-07 05:06:31 EST
Created attachment 1103121 [details]
File: core_backtrace
Comment 4 Artur Flinta 2015-12-07 05:06:32 EST
Created attachment 1103122 [details]
File: dso_list
Comment 5 Artur Flinta 2015-12-07 05:06:34 EST
Created attachment 1103123 [details]
File: environ
Comment 6 Artur Flinta 2015-12-07 05:06:35 EST
Created attachment 1103124 [details]
File: limits
Comment 7 Artur Flinta 2015-12-07 05:06:38 EST
Created attachment 1103125 [details]
File: maps
Comment 8 Artur Flinta 2015-12-07 05:06:39 EST
Created attachment 1103126 [details]
File: mountinfo
Comment 9 Artur Flinta 2015-12-07 05:06:41 EST
Created attachment 1103127 [details]
File: namespaces
Comment 10 Artur Flinta 2015-12-07 05:06:42 EST
Created attachment 1103128 [details]
File: open_fds
Comment 11 Artur Flinta 2015-12-07 05:06:44 EST
Created attachment 1103129 [details]
File: proc_pid_status
Comment 12 Artur Flinta 2015-12-07 05:06:45 EST
Created attachment 1103130 [details]
File: var_log_messages
Comment 13 Christophe Fergeau 2016-02-09 05:41:00 EST
I've bee able to reproduce a crash with a similar backtrace following the steps outlined in https://bugzilla.redhat.com/show_bug.cgi?id=1297632#c13 , marking this one as a duplicate

*** This bug has been marked as a duplicate of bug 1297632 ***

Note You need to log in before you can comment on or make changes to this bug.