Bug 1289042 - system monitor does not show CPU load values correctly
system monitor does not show CPU load values correctly
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-system-monitor (Show other bugs)
7.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: David King
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 05:14 EST by Martin Krajnak
Modified: 2015-12-07 08:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 07:43:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot.jpg (192.39 KB, image/jpeg)
2015-12-07 05:14 EST, Martin Krajnak
no flags Details

  None (edit)
Description Martin Krajnak 2015-12-07 05:14:19 EST
Created attachment 1103134 [details]
screenshot.jpg

Description of problem:
In attached image you can see that processes with PID 9866,9867 have 100% CPU load in htop, but in gnome-system-utility  same processes have only 25% and 24% CPU load.

Version-Release number of selected component (if applicable):
gnome-system-monitor-3.14.1-3.el7.x86_64
kernel-3.10.0-327.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.run htop
2.run gnome-system-monitor
3.run stress --cpu 2 --timeout 60
4.compare cpu load values in both tools

Actual results:
values are different, gnome-system-monitor shows about one quarter from htop values

Expected results:
values should correspond
Comment 1 David King 2015-12-07 07:43:44 EST
This is expected, and because gnome-system monitor is showing the CPU load averaged over the number of cores, whereas htop is showing the load in terms of a single core.

There is an option to configure this behaviour in the gnome-system-monitor prefences ("Divide CPU usage by CPU count") which can be changed by the user.
Comment 2 Martin Krajnak 2015-12-07 08:52:32 EST
Good, i misunderstood the following TCMS test case

https://tcms.engineering.redhat.com/case/422330/?from_plan=15435

which was saying that values in htop and gnome-disk-utility "could be slightly different", I will update the case so we can prevent misunderstanding in future.

Note You need to log in before you can comment on or make changes to this bug.