Bug 1289043 - unable to get ImageStream images because installer is downloading ImageStream json file for 3.1 version
unable to get ImageStream images because installer is downloading ImageStream...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 05:15 EST by Johnny Liu
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: openshift-ansible-3.0.19-1.git.0.7a5270f.el7aos
Doc Type: Bug Fix
Doc Text:
The installer previously deployed ImageStream content that was only compatible with OpenShift Enterprise 3.1 when installing OpenShift Enterprise 3.0 environments. This error has been corrected and OpenShift Enterprise 3.0 installations will now receive the proper ImageStream content.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 16:19:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2015-12-07 05:15:01 EST
Description of problem:
Run installation using openshift-ansible repo to install 3.0 version, after it is done, unable to get images resource.
# openshift version
openshift v3.0.2.0-39-ga2d18e6
kubernetes v1.1.0-alpha.0-1605-g44c91b1

# oc get is -n openshift
NAME         DOCKER REPO   TAGS               UPDATED
jenkins                    1,latest           4 seconds ago
mongodb                    2.4,2.6,latest     4 seconds ago
mysql                      5.6,latest,5.5     4 seconds ago
nodejs                     0.10,latest        4 seconds ago
perl                       5.16,5.20,latest   4 seconds ago
php                        5.5,5.6            4 seconds ago
postgresql                 9.2,9.4,latest     4 seconds ago
python                     2.7,3.3,3.4        4 seconds ago
ruby                       2.0,2.2,latest     5 seconds ago

# oc get images
NAME      DOCKER REF
<empty>

That would lead to that:
# oc new-app https://github.com/openshift/simple-openshift-sinatra-sti.git -i openshift/ruby
Error from server: ImageStreamImages must be retrieved with <name>@<id>


Dig into a little more, found the ImageStream json file is updated for 3.1 version, while this change can not be recognized by openshift 3.0.2 binary.

# cat /usr/share/openshift/examples/image-streams/image-streams-rhel7.json
{
  "kind": "ImageStreamList",
  "apiVersion": "v1",
  "metadata": {},
  "items": [
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "ruby",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "2.0"
            }
          },
          {
            "name": "2.0",
            "annotations": {
              "description": "Build and run Ruby 2.0 applications",
              "iconClass": "icon-ruby",
              "tags": "builder,ruby",
              "supports": "ruby:2.0,ruby",
              "version": "2.0",
              "sampleRepo": "https://github.com/openshift/ruby-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/ruby-20-rhel7:latest"
            }
          },
          {
            "name": "2.2",
            "annotations": {
              "description": "Build and run Ruby 2.2 applications",
              "iconClass": "icon-ruby",
              "tags": "builder,ruby",
              "supports": "ruby:2.2,ruby",
              "version": "2.2",
              "sampleRepo": "https://github.com/openshift/ruby-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/rhscl/ruby-22-rhel7:latest"
            }
          }
        ]
      }
    },
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "nodejs",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "0.10"
            }
          },
          {
            "name": "0.10",
            "annotations": {
              "description": "Build and run NodeJS 0.10 applications",
              "iconClass": "icon-nodejs",
              "tags": "builder,nodejs",
              "supports":"nodejs:0.10,nodejs:0.1,nodejs",
              "version": "0.10",
              "sampleRepo": "https://github.com/openshift/nodejs-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/nodejs-010-rhel7:latest"
            }
          }
        ]
      }
    },
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "perl",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "5.16"
            }
          },
          {
            "name": "5.16",
            "annotations": {
              "description": "Build and run Perl 5.16 applications",
              "iconClass": "icon-perl",
              "tags": "builder,perl",
              "supports":"perl:5.16,perl",
              "version": "5.16",
              "sampleRepo": "https://github.com/openshift/dancer-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/perl-516-rhel7:latest"
            }
          },
          {
            "name": "5.20",
            "annotations": {
              "description": "Build and run Perl 5.20 applications",
              "iconClass": "icon-perl",
              "tags": "builder,perl",
              "supports":"perl:5.20,perl",
              "version": "5.20",
              "sampleRepo": "https://github.com/openshift/dancer-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/rhscl/perl-520-rhel7:latest"
            }

          }
        ]
      }
    },
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "php",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "5.5"
            }
          },
          {
            "name": "5.5",
            "annotations": {
              "description": "Build and run PHP 5.5 applications",
              "iconClass": "icon-php",
              "tags": "builder,php",
              "supports":"php:5.5,php",
              "version": "5.5",
              "sampleRepo": "https://github.com/openshift/cakephp-ex.git"              
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/php-55-rhel7:latest"
            }
          },
          {
            "name": "5.6",
            "annotations": {
              "description": "Build and run PHP 5.6 applications",
              "iconClass": "icon-php",
              "tags": "builder,php",
              "supports":"php:5.6,php",
              "version": "5.6",
              "sampleRepo": "https://github.com/openshift/cakephp-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/rhscl/php-56-rhel7:latest"
            }
          }
        ]
      }
    },
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "python",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "3.3"
            }
          },
          {
            "name": "3.3",
            "annotations": {
              "description": "Build and run Python 3.3 applications",
              "iconClass": "icon-python",
              "tags": "builder,python",
              "supports":"python:3.3,python",
              "version": "3.3",
              "sampleRepo": "https://github.com/openshift/django-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/python-33-rhel7:latest"
            }
          },
          {
            "name": "2.7",
            "annotations": {
              "description": "Build and run Python 2.7 applications",
              "iconClass": "icon-python",
              "tags": "builder,python",
              "supports":"python:2.7,python",
              "version": "2.7",
              "sampleRepo": "https://github.com/openshift/django-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/rhscl/python-27-rhel7:latest"
            }
          },
          {
            "name": "3.4",
            "annotations": {
              "description": "Build and run Python 3.4 applications",
              "iconClass": "icon-python",
              "tags": "builder,python",
              "supports":"python:3.4,python",
              "version": "3.4",
              "sampleRepo": "https://github.com/openshift/django-ex.git"
            },
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/rhscl/python-34-rhel7:latest"
            }
          }
        ]
      }
    },
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "mysql",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "5.5"
            }
          },
          {
            "name": "5.5",
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/mysql-55-rhel7:latest"
            }
          },
          {
            "name": "5.6",
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/rhscl/mysql-56-rhel7:latest"
            }
          }
        ]
      }
    },
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "postgresql",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "9.2"
            }
          },
          {
            "name": "9.2",
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/postgresql-92-rhel7:latest"
            }
          },
          {
            "name": "9.4",
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/rhscl/postgresql-94-rhel7:latest"
            }
          }
        ]
      }
    },
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "mongodb",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "2.4"
            }
          },
          {
            "name": "2.4",
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/mongodb-24-rhel7:latest"
            }
          },
          {
            "name": "2.6",
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/rhscl/mongodb-26-rhel7:latest"
            }
          }
        ]
      }
    },
    {
      "kind": "ImageStream",
      "apiVersion": "v1",
      "metadata": {
        "name": "jenkins",
        "creationTimestamp": null
      },
      "spec": {
        "tags": [
          {
            "name": "latest",
            "from": {
              "Kind": "ImageStreamTag",
              "Name": "1"
            }
          },
          {
            "name": "1",
            "from": {
              "Kind": "DockerImage",
              "Name": "registry.access.redhat.com/openshift3/jenkins-1-rhel7:latest"
            }
          }
        ]
      }
    }
  ]
}


If I restore the json file to older version, it is working well.
And
I I use this json file against 3.1 openshift binary, it is also working well.

Version-Release number of selected component (if applicable):
openshift 3.0.2 release version
openshift-ansible github repo

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Johnny Liu 2015-12-10 03:52:58 EST
Verified this bug, PASS.

atomic-openshift-utils from 3.1/2015-12-09.4 puddle + 3.0.z install: PASS
The latest openshift-ansible master branch + 3.0.z install: PASS

# oc get is -n openshift
NAME         DOCKER REPO                                                 TAGS                                     UPDATED
jenkins      registry.access.redhat.com/openshift3/jenkins-1-rhel7       latest,1,1.609-14 + 1 more...            20 seconds ago
mongodb      registry.access.redhat.com/openshift3/mongodb-24-rhel7      v3.0.2.0,v3.0.1.0,v3.0.0.0 + 4 more...   About a minute ago
mysql        registry.access.redhat.com/openshift3/mysql-55-rhel7        v3.0.2.0,v3.0.1.0,v3.0.0.0 + 4 more...   About a minute ago
nodejs       registry.access.redhat.com/openshift3/nodejs-010-rhel7      v3.0.0.0,0.10,0.10-12 + 4 more...        7 seconds ago
perl         registry.access.redhat.com/openshift3/perl-516-rhel7        v3.0.2.0,v3.0.1.0,v3.0.0.0 + 4 more...   About a minute ago
php          registry.access.redhat.com/openshift3/php-55-rhel7          v3.0.0.0                                 Less than a second ago
postgresql   registry.access.redhat.com/openshift3/postgresql-92-rhel7   v3.0.1.0,v3.0.0.0,9.2 + 3 more...        47 seconds ago
python       registry.access.redhat.com/openshift3/python-33-rhel7       v3.0.2.0,v3.0.1.0,v3.0.0.0 + 4 more...   30 seconds ago
ruby         registry.access.redhat.com/openshift3/ruby-20-rhel7         v3.0.1.0,v3.0.0.0,3.1.0 + 4 more...      About a minute ago
Comment 5 errata-xmlrpc 2015-12-17 16:19:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2667

Note You need to log in before you can comment on or make changes to this bug.