Bug 1289046 - Deployment failed: Went to status ERROR due to "Message: Unknown, Code: Unknown"
Deployment failed: Went to status ERROR due to "Message: Unknown, Code: Unknown"
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHELOSP (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: ---
Assigned To: Jason Montleon
Thom Carlin
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 05:18 EST by Antonin Pagac
Modified: 2016-09-13 12:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:23:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2015-12-07 05:18:57 EST
Description of problem:
The complete message in the UI:

ERROR: deployment failed with status: CREATE_FAILED and reason: Resource CREATE failed: ResourceInError: resources.Compute.resources[0].resources.NovaCompute: Went to status ERROR due to "Message: Unknown, Code: Unknown"

This happened in 26.0% of the RHELOSP deployment. Content synced successfully. This is my third re-deploy of RHELOSP, I have previously un-deployed the overcloud from the Director webUI, so it could be created again. I did not delete nodes, I'm using nodes discovered during the first RHELOSP deployment.

From the nova-compute.log:

Command: qemu-img convert -O raw /var/lib/ironic/master_images/tmpHrdQaf/ed45a705-e8cd-4b7f-84fd-62d50de7c1f8.part /var/lib/ironic/master_images/tmpHrdQaf/ed45a705-e8cd-4b7f-84fd-62d50de7c1f8.converted
Exit code: 1
Stdout: u''
Stderr: u'qemu-img: error while reading sector 715008: Input/output error\n'

and then:

NeutronClientException: 404 Not Found
The resource could not be found.

Please see attached production.log and nova-compute.log excerpts.

I tried to resume the failing tasks and got:

There was a conflict when trying to complete your request. The Stack (overcloud) already exists.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20151201.t.0
RHCIOOO-7-RHEL-7-20151201.t.1

How reproducible:
Happened to me once

Steps to Reproduce:
1. Do a RHELOSP re-deployment with previously discovered nodes and previously undeployed Overcloud
2. Deployment fails at 26.0% with above error
3. 

Actual results:
Deployment fails; upon resuming the failing task, another error appears; unable to continue deployment

Expected results:
Deployment completes successfully

Additional info:
Comment 3 Antonin Pagac 2015-12-07 06:25:48 EST
Reproduced while doing another RHELOSP re-deployment.
Comment 8 Thom Carlin 2016-07-25 16:45:29 EDT
With QCI-1.2-RHEL-7-20160723.t.0 and QCIOOO-8.0-RHEL-7-20160719.t.0, have done multiple redeploys successfully.

Marking as VERIFIED, please reopen if this reoccurs
Comment 10 errata-xmlrpc 2016-09-13 12:23:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.