Bug 128906 - Multiple perl SRPMS have conflicting filter-depends.sh
Summary: Multiple perl SRPMS have conflicting filter-depends.sh
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: perl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-31 04:02 UTC by Blair Zajac
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 14:38:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rename filter-depends.sh to filter-depends-perl.sh. (815 bytes, patch)
2004-08-02 18:06 UTC, Blair Zajac
no flags Details | Diff

Description Blair Zajac 2004-07-31 04:02:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:

Hello,

I pulled down all of the perl source RPMs from Fedora to make some
local modifications to them for our local installation.  Several of
the srpms have a filter-depends.sh and depending upon the order that
you unpack the srpms, you'll get a broken build.  In my case, I did an

rpm -ivh \
  perl-5.8.5-2.src.rpm \
  perl-libwww-perl-5.79-1.src.rpm \
  perl-Net-DNS-0.45-3.src

and my perl build doesn't install because the Mac:: and other
dependencies are not filtered out.  These are the three perl srpms
that I found that contain the identically named yet different files.

I have my ~/.rpmmacros set up like this:

%_topdir                /export/home1/blair/RPMs/build
%_builddir              %{_topdir}/BUILD
%_rpmdir                %{_topdir}/RPMS
%_sourcedir             %{_topdir}/SOURCES
%_specdir               %{_topdir}/SPECS
%_srcrpmdir             %{_topdir}/SRPMS
%_tmppath               %{_topdir}/TMP

I'm guessing that at RedHat these conflicts do not occur, but could
these three files be given unique names such as
filter-depends-perl-net-dns.sh?

Thanks,
Blair


Version-Release number of selected component (if applicable):
perl-5.8.5-2

How reproducible:
Always

Comment 1 Robert Scheck 2004-07-31 17:18:44 UTC
Theoretically the file names for patches and scripts in spec files 
are unique - as I saw it the last years at Red Hat. Maybe some patches 
were modified later and were not synchronised... :-(

Workaround: Install the first source package and rebuild it, then use 
the secound and go on like that.

Comment 2 Chip Turner 2004-08-02 14:38:52 UTC
sometimes it's filter-depends, sometimes it's filter-requires,
sometimes it's filter-depends-NAME, sometimes it's
filter-requires-NAME.  Pretty much random as to which it is.

I'm not personally going to fix it proactively, but I will try to fix
them as I work on packages.  patches, though, will be applied more
quickly, so please feel free to help out that way.  otherwise it'll be
a slow target-of-opportunity process

Comment 3 Blair Zajac 2004-08-02 18:04:57 UTC
Are you saying that you won't push a new RPM release just for this
issue, but if there's a patch to fix this issue and when there's a
new release, you'll include it?

If that's the case, I'm attaching a patch for perl.spec.  Of course,
the filter*.sh will have to be renamed separately.

When you do a new perl SRPM, do you look for CLOSED/DEFERRED bugs?
Is this the proper state for a bug with a patch in it?

Regards,
Blair

Comment 4 Blair Zajac 2004-08-02 18:06:42 UTC
Created attachment 102366 [details]
Rename filter-depends.sh to filter-depends-perl.sh.


Note You need to log in before you can comment on or make changes to this bug.