Bug 1289068 - libgfapi: Errno incorrectly set to EINVAL even on success
libgfapi: Errno incorrectly set to EINVAL even on success
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
mainline
All All
high Severity low
: ---
: ---
Assigned To: Prashanth Pai
Sudhir D
: EasyFix, Triaged
Depends On:
Blocks: 1296007
  Show dependency treegraph
 
Reported: 2015-12-07 06:33 EST by Prashanth Pai
Modified: 2016-06-16 09:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1296007 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:49:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prashanth Pai 2015-12-07 06:33:48 EST
Description of problem:
Errno is incorrectly set to EINVAL even on success, for subsequent glfs_* calls.

[root@hummingbird ~]# rpm -qa | grep glusterfs
glusterfs-3.7.6-1.fc22.x86_64
glusterfs-cli-3.7.6-1.fc22.x86_64
glusterfs-devel-3.7.6-1.fc22.x86_64
glusterfs-libs-3.7.6-1.fc22.x86_64
glusterfs-client-xlators-3.7.6-1.fc22.x86_64
glusterfs-fuse-3.7.6-1.fc22.x86_64
glusterfs-server-3.7.6-1.fc22.x86_64
glusterfs-extra-xlators-3.7.6-1.fc22.x86_64
glusterfs-api-devel-3.7.6-1.fc22.x86_64
glusterfs-api-3.7.6-1.fc22.x86_64

Example:
Even though glfs_fstat() returns success (zero), errno is set to EINVAL. It doesn't matter that the second glfs_* call is glfs_stat(). Even if you have glfs_write() twice, errno is set to EINVAL for the second call.


#include <stdio.h>
#include <stdlib.h>
#include <errno.h>
#include <sys/types.h>
#include <sys/stat.h>

#include "api/glfs.h"

int main () {

        glfs_t *fs = NULL;
        int ret = 0;
        glfs_fd_t *glfd = NULL;
        char *buf = NULL;
        struct stat sb;

        fs = glfs_new ("test");
        glfs_set_volfile_server (fs, "tcp", "localhost", 24007);
        glfs_set_logging (fs, NULL, 7);
        glfs_init (fs);
        glfd = glfs_creat(fs, "/file.txt", O_WRONLY, 0666);

        // Comment out this write to see the bug magically go away!
        ret = glfs_write (glfd, "qwertyuiopasdfghjklzxcvbnm", 26, 0);
        printf("errno after write(), before fstat(): %d\n", errno);
        ret = glfs_fstat(glfd, &sb);
        printf("glfs_fstat() returned: %d\n", ret);
        printf("errno after: %d\n", errno);

        ret = glfs_close(glfd);
        ret = glfs_fini (fs);
}  


Steps to Reproduce:
*******************

# gcc err.c -I /usr/include/glusterfs/ -lgfapi -O0 -ggdb -o ./err
# ./err

Actual results:
***************

# ./err
errno after write(), before fstat(): 0
glfs_fstat() returned: 0
errno after: 22

// After commenting out first call - glfs_write()

# ./err
errno after write(), before fstat(): 0
glfs_fstat() returned: 0
errno after: 0

Expected results:
*****************

# ./err
errno after write(), before fstat(): 0
glfs_fstat() returned: 0
errno after: 0


Additional info: 
****************
C programs usually check return value first and then the errno. But the control flow in golang is different.

ret, err := C.glfs_fstat(fd.fd, (*C.struct_stat)(unsafe.Pointer(stat)))
if err != nil {
    // Failure! handle error
} else {
    // Success! consume entity returned by C call. In this case "stat"
}
Comment 1 Prashanth Pai 2015-12-07 06:41:52 EST
This should also reproduce the behavior:

        ret = glfs_write (glfd, "qwertyuiopasdfghjklzxcvbnm", 26, 0);
        printf("errno after first write(): %d\n", errno);
        ret = glfs_write (glfd, "qwertyuiopasdfghjklzxcvbnm", 26, 0);
        printf("errno after second write(): %d\n", errno);

# ./err
errno after first write(): 0
errno after second write(): 22
Comment 2 Vijay Bellur 2015-12-08 06:15:57 EST
REVIEW: http://review.gluster.org/12909 (Fix errno being set to EINVAL even on success) posted (#1) for review on master by Prashanth Pai (ppai@redhat.com)
Comment 3 Vijay Bellur 2015-12-08 10:37:13 EST
REVIEW: http://review.gluster.org/12909 (Fix errno being set to EINVAL even on success) posted (#2) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 4 Vijay Bellur 2015-12-08 16:49:27 EST
REVIEW: http://review.gluster.org/12909 (api: Fix errno being set to EINVAL even on success) posted (#3) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 5 Vijay Bellur 2015-12-08 16:49:33 EST
REVIEW: http://review.gluster.org/12909 (api: Fix errno being set to EINVAL even on success) posted (#4) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 6 Vijay Bellur 2016-01-05 10:41:14 EST
COMMIT: http://review.gluster.org/12909 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 1e779acec75842b0e8d5a34ac2ea52f9caeff4d1
Author: Prashanth Pai <ppai@redhat.com>
Date:   Tue Dec 8 16:28:39 2015 +0530

    api: Fix errno being set to EINVAL even on success
    
    BUG: 1289068
    Change-Id: I7905ac70a537f23e1844c097a24eaa6cb762fb82
    Signed-off-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-on: http://review.gluster.org/12909
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Comment 7 Vijay Bellur 2016-01-06 01:03:59 EST
REVIEW: http://review.gluster.org/13179 (api: Fix errno being set to EINVAL even on success) posted (#1) for review on release-3.7 by Prashanth Pai (ppai@redhat.com)
Comment 8 Niels de Vos 2016-06-16 09:49:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.