Bug 1289073 - Cannot install nginx from epel
Cannot install nginx from epel
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: libunwind (Show other bugs)
epel7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jamie Nguyen
Fedora Extras Quality Assurance
:
Depends On: 1288313
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 06:50 EST by Aki Tuomi
Modified: 2015-12-10 02:50 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 02:49:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aki Tuomi 2015-12-07 06:50:28 EST
Description of problem:
When installing nginx, you get the following problem:
--> Finished Dependency Resolution
Error: Package: gperftools-libs-2.4-5.el7.x86_64 (epel)
           Requires: libunwind.so.8()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):
1:1.6.3-7.el7

How reproducible:
always

Steps to Reproduce:
1. install fresh CentOS7
2. install epel7-release
3. try to install nginx

Actual results:
Installation fails with the error above

Expected results:
nginx would be installed

Additional info:
Comment 1 Anssi Johansson 2015-12-07 06:55:46 EST
The current nginx has been built for RHEL 7.2.

To get the equivalent packages for CentOS, you will need to either wait for 7.2.1511's release or get the packages from the CR repo as described in https://wiki.centos.org/AdditionalResources/Repositories/CR
Comment 2 Jamie Nguyen 2015-12-07 07:37:00 EST
(In reply to Aki Tuomi from comment #0)
> Description of problem:
> When installing nginx, you get the following problem:
> --> Finished Dependency Resolution
> Error: Package: gperftools-libs-2.4-5.el7.x86_64 (epel)
>            Requires: libunwind.so.8()(64bit)

libunwind has been retired from EPEL7:

  https://admin.fedoraproject.org/pkgdb/package/libunwind/

libunwind is included in RHEL 7.2 now, so that is why libunwind was retired. Sadly, this means CentOS is kind of broken unless you enable CR.

As a workaround:

    # yum-config-manager --enable cr
    # yum install nginx

This certainly sucks. I'm not sure how to avoid this problem. Will ping fedora-devel mailing list.
Comment 3 Jamie Nguyen 2015-12-07 07:41:25 EST
As an aside, it looks like the Release of libunwind has gone backwards from 1.1-10 in EPEL7 [0] to 1.1-5 in RHEL [1].

[0] https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-7194
[1] http://mirror.centos.org/centos/7/cr/x86_64/Packages/
Comment 4 Anssi Johansson 2015-12-07 07:44:19 EST
Bug 1288313 is related.
Comment 5 Jamie Nguyen 2015-12-07 08:23:38 EST
I could rebuild NGINX without gperftools as a temporary solution, but that would break NGINX for anyone using the google perftools module. If I don't rebuild, then users can't even install NGINX in the first place!

It seems I'm stuck between a rock and a hard place.
Comment 6 Anssi Johansson 2015-12-07 08:36:34 EST
My (slightly biased) opinion is that you should keep nginx as is. CentOS will eventually get the updated dependencies published.
Comment 7 Jamie Nguyen 2015-12-07 08:49:20 EST
Yeah, I won't be rebuilding NGINX. New users can just enable CR, but unfortunately they might not realise that's the solution. Just posted to ML. Hopefully we can avoid this problem in the future.

https://lists.fedoraproject.org/archives/list/devel%40lists.fedoraproject.org/thread/LKZVKPEOFGL66TXLGAYWFFPZNPCAFTJC/
Comment 8 Paul Belanger 2015-12-07 11:36:54 EST
Just hit this issue this morning. Great start to the off the Monday morning.
Comment 9 Kevin Fenzi 2015-12-07 12:58:17 EST
Can't you simply rebuild gperftools against the current RHEL provided libunwind?
Comment 10 Jamie Nguyen 2015-12-07 13:01:39 EST
(In reply to Kevin Fenzi from comment #9)
> Can't you simply rebuild gperftools against the current RHEL provided
> libunwind?

Unfortunately not. libunwind isn't installable at all on CentOS unless you enable the CR repository (since it's no longer in EPEL and CentOS 7.2 hasn't been released yet.
Comment 11 Kevin Fenzi 2015-12-07 13:14:12 EST
Duh, ok. I see. ;(
Comment 12 Jamie Nguyen 2015-12-07 13:28:17 EST
https://lists.fedoraproject.org/archives/list/devel%40lists.fedoraproject.org/message/BCTGKQTIZHHIRMGWP7PASSTIPP7GLPQX/

I'd like to unretire libunwind for EPEL while waiting for CentOS 7.2, but that would break RHEL. So I think what I need to do is wait until the libunwind.rh maintainer has bumped the Release of libunwind.rh, then request for libunwind.el7 to be unretired. But this process may not even complete before CentOS 7.2 is released... thus making it rather pointless.

So, probably we just have to sit and wait for the Release to be bumped or CentOS 7.2 to be released :-(
Comment 13 David Moreau Simard 2015-12-09 12:28:17 EST
Just stepping in to say that this effectively prevents Ceph from installing properly as well, i.e, http://logs.openstack.org/95/254095/1/check/gate-puppet-ceph-puppet-beaker-rspec-dsvm-centos7/ac9f226/console.html#_2015-12-08_05_29_33_225
Comment 14 Jamie Nguyen 2015-12-09 13:25:23 EST
I opened a discussion on centos-devel [0] and after some initial misunderstandings, Johnny Hughes very kindly agreed to put the CentOS 7.2 version of libunwind in CentOS 7.1 Extras repository.

libunwind-1.1-5 is now on mirror.centos.org [1] and will eventually find its way to other mirrors. This should resolve the problem.

[0]: https://lists.centos.org/pipermail/centos-devel/2015-December/014101.html
[1]: http://mirror.centos.org/centos/7/extras/x86_64/Packages/libunwind-1.1-5.el7.x86_64.rpm
Comment 15 Paul Belanger 2015-12-09 14:18:52 EST
I can confirm nginx installs properly now.
Comment 16 Brad Hubbard 2015-12-09 16:34:06 EST
Tom,

This seems resolved as of today. Can we close it out?
Comment 17 Jamie Nguyen 2015-12-10 02:49:51 EST
Thanks Paul and Brad for confirming that this is fixed.

Closing.
Comment 18 Jamie Nguyen 2015-12-10 02:50:34 EST
Cancelling needinfo.

Note You need to log in before you can comment on or make changes to this bug.