Bug 1289093 - (CVE-2015-8476) CVE-2015-8476 php-PHPMailer: Message injection caused by line breaks in addresses
CVE-2015-8476 php-PHPMailer: Message injection caused by line breaks in addre...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
impact=low,public=20151101,reported=2...
: Security
Depends On: 1289094 1289095
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 07:32 EST by Adam Mariš
Modified: 2015-12-07 07:33 EST (History)
3 users (show)

See Also:
Fixed In Version: php-PHPMailer 5.2.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Mariš 2015-12-07 07:32:41 EST
A message injection vulnerability was found in php-PHPMailer affecting versions before 5.2.14, caused by line breaks allowed in addresses, which is valid in RFC5322, but allowing such addresses resulted in invalid RFC5321 SMTP commands. These addresses were allowed by the 'pcre8' validator pattern.

Upstream patch:

https://github.com/PHPMailer/PHPMailer/commit/6687a96a18b8f12148881e4ddde795ae477284b0

CVE assignment:

http://seclists.org/oss-sec/2015/q4/435
Comment 1 Adam Mariš 2015-12-07 07:33:09 EST
Created php-PHPMailer tracking bugs for this issue:

Affects: fedora-all [bug 1289094]
Affects: epel-all [bug 1289095]

Note You need to log in before you can comment on or make changes to this bug.