Bug 1289124 - mailx secure send option does not support TLSv1.1 or TLSv1.2
Summary: mailx secure send option does not support TLSv1.1 or TLSv1.2
Keywords:
Status: CLOSED DUPLICATE of bug 1272504
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mailx
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Nikola Forró
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1253743 1310222
TreeView+ depends on / blocked
 
Reported: 2015-12-07 13:46 UTC by Martin Poole
Modified: 2016-02-19 19:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-08 09:38:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Poole 2015-12-07 13:46:30 UTC
Description of problem:

mailx secure send option does not support TLSv1.1 or TLSv1.2

Version-Release number of selected component (if applicable):

mailx-12.4-8.el6_6


mailx -t -S smtp=smtps://rhel7-64.example.com:465 -S nss-config-dir=/etc/pki/nssdb


SSL/TLS handshake failed: Peer reports incompatible or unsupported protocol version.


Server

openssl s_server -cert ./rhel7-64.example.com.pem -key ./rhel7-64.example.com.key.nopw -accept 465 -tls1_2

Comment 2 Martin Poole 2015-12-07 17:33:28 UTC
This appears to be resolved with the updated NSS packages from

   Enable TLS 1.2 as the default in nss
   https://bugzilla.redhat.com/show_bug.cgi?id=1272504

Comment 3 Nikola Forró 2015-12-08 09:38:41 UTC
(In reply to Martin Poole from comment #2)
> This appears to be resolved with the updated NSS packages from
> 
>    Enable TLS 1.2 as the default in nss
>    https://bugzilla.redhat.com/show_bug.cgi?id=1272504
Yes, updating nss fixes this for me too. I'm closing this as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.