Bug 1289134 - git does not support TLSv1.1 or TLSv1.2
Summary: git does not support TLSv1.1 or TLSv1.2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: git (Show other bugs)
(Show other bugs)
Version: 6.7
Hardware: Unspecified Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: pstodulk
QA Contact: Karel Srot
URL:
Whiteboard:
Keywords: TestOnly
Depends On: 1272504 1289205 1299564
Blocks: 1253743 1310222
TreeView+ depends on / blocked
 
Reported: 2015-12-07 14:04 UTC by Martin Poole
Modified: 2018-01-02 08:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-15 15:07:40 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1217477 None None None Never

Description Martin Poole 2015-12-07 14:04:39 UTC
Description of problem:

git does not support TLSv1.1 or TLSv1.2

Version-Release number of selected component (if applicable):

git-1.7.1-3.el6_4.1


# git clone https://gitlab.example.com/tools/tlsscan.git
Initialized empty Git repository in /root/src/tlsscan/.git/
error:  while accessing https://gitlab.example.com/tools/tlsscan.git/info/refs

fatal: HTTP request failed



Where the server has 

  ssl_protocols  TLSv1.1 TLSv1.2;

Comment 11 Karel Srot 2017-12-15 15:07:40 UTC
Confirmed to be working on 6.10, closing as CurrentRelease, despite it sems to be fixed at least since rhel-6.8

$ rpm -q nss curl git
nss-3.28.4-4.el6_9.x86_64
nss-3.28.4-4.el6_9.i686
curl-7.19.7-53.el6_9.x86_64
git-1.7.10.4-1.el6.rfx.x86_64
$ git clone https://gitlab.quatermass.co.uk/toolsmith/tlsscan.git
Cloning into 'tlsscan'...
remote: Counting objects: 969, done.
remote: Compressing objects: 100% (378/378), done.
remote: Total 969 (delta 618), reused 924 (delta 590)
Receiving objects: 100% (969/969), 447.31 KiB, done.
Resolving deltas: 100% (618/618), done.
$ openssl s_client -connect gitlab.quatermass.co.uk:443 < /dev/null 2>&1 | grep TLS
New, TLSv1/SSLv3, Cipher is ECDHE-RSA-AES256-GCM-SHA384
    Protocol  : TLSv1.2
    TLS session ticket lifetime hint: 300 (seconds)
    TLS session ticket:


Note You need to log in before you can comment on or make changes to this bug.