Bug 1289136 - launch a vm with macvtap port is not working with kernel < 3.13
launch a vm with macvtap port is not working with kernel < 3.13
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 7.0 (Kilo)
Assigned To: Hynek Mlnarik
Eran Kuris
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 09:10 EST by Brent Eagles
Modified: 2016-10-05 15:15 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.4-4.el7ost
Doc Type: Bug Fix
Doc Text:
When you create a MacVTap passthrough to SR-IOV VF in Kernel >= 3.13 an `upper_macvtap` symbolic link is created. Previously, for kernel versions < 3.13 the only way to detect the link was by parsing the `ip link show` output. As a result, the MacVTap-assigned VF was not detected on kernel versions < 3.13. With this update, the `ip link show` command now detects MacVTap-assigned VFs, and detection of MacVTap-assigned VFs will work on all kernels.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-05 15:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1523083 None None None Never
OpenStack gerrit 255916 None None None 2016-09-15 11:19 EDT

  None (edit)
Description Brent Eagles 2015-12-07 09:10:16 EST
Cloned from launchpad bug 1523083.

Description:

the sriov agent check if vf is assigned to macvtap by the exists of upper_macvtap symbolic

https://github.com/openstack/neutron/blob/master/neutron/plugins/ml2/drivers/mech_sriov/agent/eswitch_manager.py#L85-L86

The upper_macvtap symbolic exists only in kernel 3.13 and above
see http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/drivers/net/macvlan.c?id=5831d66e8097aedfa3bc35941cf265ada2352317
"net: create sysfs symlinks for neighbour devices".

This is a problem when using rhel 7.1 which comes with kernel 3.10

Specification URL (additional information):

https://bugs.launchpad.net/neutron/+bug/1523083
Comment 2 Brent Eagles 2015-12-08 15:26:48 EST
Undoing mistaken version change. This does first occur in OSP 7 (kilo).
Comment 4 Eran Kuris 2016-10-05 02:15:33 EDT
verified on rhos 7 
 [root@compute1 ~]# rpm -qa |grep neutron 
openstack-neutron-openvswitch-2015.1.4-4.el7ost.noarch
openstack-neutron-2015.1.4-4.el7ost.noarch
python-neutronclient-2.4.0-2.el7ost.noarch
openstack-neutron-common-2015.1.4-4.el7ost.noarch
openstack-neutron-lbaas-2015.1.4-1.el7ost.noarch
python-neutron-fwaas-2015.1.2-1.el7ost.noarch
openstack-neutron-fwaas-2015.1.2-1.el7ost.noarch
python-neutron-2015.1.4-4.el7ost.noarch
python-neutron-lbaas-2015.1.4-1.el7ost.noarch
Comment 6 errata-xmlrpc 2016-10-05 15:15:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2029.html

Note You need to log in before you can comment on or make changes to this bug.