Bug 1289147 - Installer progress should be visible on host console while provisioning a pxe-less discovered host with rhel67
Installer progress should be visible on host console while provisioning a pxe...
Status: CLOSED DUPLICATE of bug 1508455
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Discovery Plugin (Show other bugs)
6.1.5
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Lukas Zapletal
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 09:28 EST by Sachin Ghai
Modified: 2018-02-17 11:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-17 11:10:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12733 None None None 2016-04-22 11:06 EDT

  None (edit)
Description Sachin Ghai 2015-12-07 09:28:28 EST
Description of problem:
I discovered a pxe-less host (with and w/o dhcp). Host was discovered successfully. However when I click on provision to provision the host with rhel67 os, I didn't see the kexec on the installer. 

On host console, discovery status was appearing and after a few minutes host rebooted and a login screen appears. On login, I can all anaconda-cfg.ks file and install.log file. 

So missing thing is user won't be able to see installer progress from console. User would get Discovery status screen to login prompt.

However if I provision the discovered host with rhel7 then I can see anaconda installer and install progress on console like package installation and post install steps.

Version-Release number of selected component (if applicable):

Sat 6.1.5 compose3(Satellite-6.1.0-RHEL-7-20151204.0)
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el6_6sat.noarch
rubygem-smart_proxy_discovery-1.0.3-2.el6.noarch
ruby193-rubygem-foreman_discovery-2.0.0.22-1.el6_6sat.noarch
foreman-discovery-image-3.0.5-3.el7sat.noarch


How reproducible:
always

Steps to Reproduce:
1. discovered a pxe-less host
2. provision it with rhel67
3.

Actual results:
User won't be able to see installer progress like package install or post-install on console. Directly login screen appears after Discovery Status screen. It creates a weird situation, like If I see at console whether provisioning started, I won't get any clue because I see the status screen. However If I wait for some-time, direct login screen appears.

It means provisioning works but without showing anaconda installer progress.

Expected results:
Installer progress should be visible on host console while provisioning a pxe-less discovered host with rhel67

Additional info:
Comment 1 Lukas Zapletal 2015-12-07 09:33:26 EST
Ack, not a blocker.
Comment 4 Bryan Kearney 2015-12-07 09:49:06 EST
Created redmine issue http://projects.theforeman.org/issues/12733 from this bug
Comment 5 Sachin Ghai 2015-12-07 11:16:13 EST
Note: this is the issue only with provisioning of pxe-less hosts. I can see installer progress while provisioning of pxe-based discovered hosts.
Comment 8 Bryan Kearney 2016-08-04 16:16:42 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 11 Roman Plevka 2018-02-14 12:03:23 EST
Isn't this the same as https://bugzilla.redhat.com/show_bug.cgi?id=1508455 ?
Comment 12 Lukas Zapletal 2018-02-15 03:42:41 EST
Yes it is, feel free to verify or close as dupe.
Comment 13 Roman Plevka 2018-02-15 03:47:31 EST
A duplicate for this one got resolved and verified.

https://bugzilla.redhat.com/show_bug.cgi?id=1508455
Comment 14 Bryan Kearney 2018-02-17 11:10:28 EST

*** This bug has been marked as a duplicate of bug 1508455 ***

Note You need to log in before you can comment on or make changes to this bug.