Bug 1289157 - Only one of my two external monitors really works
Only one of my two external monitors really works
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 09:45 EST by Peter Gervase
Modified: 2015-12-18 12:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 12:04:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot showing only one external monitor detected (3.30 MB, image/jpeg)
2015-12-07 09:45 EST, Peter Gervase
no flags Details
xwininfo -root (577 bytes, text/plain)
2015-12-07 09:46 EST, Peter Gervase
no flags Details
xdpyinfo (11.51 KB, text/plain)
2015-12-07 09:47 EST, Peter Gervase
no flags Details

  None (edit)
Description Peter Gervase 2015-12-07 09:45:44 EST
Created attachment 1103258 [details]
screen shot showing only one external monitor detected

Description of problem:
As shown in the attached screen shot, I am using a Lenovo Thinkpad W541 with my laptop screen + two external monitors. The working monitor is plugged into the laptop's vga port and the non working monitor is plugged into the video out on the dock. Both external monitors are getting a signal from the computer, but the right monitor stops after the services are all started. If I plug that right monitor into the dvi, the same thing happens. If I unplug the left monitor from the laptop's vga port and plug in that right monitor, then it works. 

Also attached is the output from 
xwininfo -root
and
xdpyinfo

I first tried with kde plasma since that's what I'd really prefer to use, but usually when I entered my username / password to login, the laptop screen would just freeze and I'd get nothing on the external monitors. I tried with gnome, and that worked for a little bit and then had issues. I then made a brand new user, and they were able to login to kde with both external monitors, but I think that failed the last time I tried it. I've been having issues with the monitors for a few weeks, so with daily updates things have varied in what works and what doesn't. 

Version-Release number of selected component (if applicable):
rawhide, fully updated.

How reproducible:
100%

Steps to Reproduce:
1. boot up the system
2.
3.

Actual results:
Only the laptop screen + the monitor connected to the onboard vga port are detected by the system, even though the other external monitor is clearly connected since it still has the status from the services starting.

Expected results:
Both external monitors work

Additional info:
Comment 1 Peter Gervase 2015-12-07 09:46 EST
Created attachment 1103260 [details]
xwininfo -root
Comment 2 Peter Gervase 2015-12-07 09:47 EST
Created attachment 1103261 [details]
xdpyinfo
Comment 3 Peter Gervase 2015-12-18 12:04:55 EST
I just did a yum update, pulled down ~900 meg or so, rebooted, and mate and gnome see the three monitors correctly. kde is still totally broken, so maybe i'll do a group reinstall there. I'll mark this bz closed.

Note You need to log in before you can comment on or make changes to this bug.