Bug 1289160 - No Requires: %{name}%{?_isa} = %{version}-%{release} in debuginfo packages
No Requires: %{name}%{?_isa} = %{version}-%{release} in debuginfo packages
Status: CLOSED DUPLICATE of bug 470691
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 09:51 EST by Jaroslav Škarvada
Modified: 2016-01-19 04:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 04:38:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2015-12-07 09:51:20 EST
Description of problem:
Fedora-review thinks that debuginfo packages should contain:
Requires: %{name}%{?_isa} = %{version}-%{release}

Maybe this assumption is wrong, but it makes sense to me - the debug package should be bound to the base binary package.

Version-Release number of selected component (if applicable):
rpm-4.12.0.1-14.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. rpm -qp DEBUGINFO.rpm --requires

Actual results:
No %{name}%{?_isa} = %{version}-%{release}

Expected results:
%{name}%{?_isa} = %{version}-%{release}

Additional info:
Spotted in e.g. bug 1279527 comment 6. AFAIK debuginfos are generated by rpmbuild thus filling against rpm to sort it out.
Comment 1 Ľuboš Kardoš 2016-01-19 04:38:15 EST

*** This bug has been marked as a duplicate of bug 470691 ***

Note You need to log in before you can comment on or make changes to this bug.