Bug 1289177 - mod_nss update incompatible with apache/httpd
mod_nss update incompatible with apache/httpd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mod_nss (Show other bugs)
22
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 10:27 EST by Lonni J Friedman
Modified: 2015-12-28 18:54 EST (History)
3 users (show)

See Also:
Fixed In Version: mod_nss-1.0.11-5.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 18:54:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lonni J Friedman 2015-12-07 10:27:54 EST
Description of problem:
The latest update to mod_nss prevents apache/httpd from starting with the error:
Cannot load modules/libmodnss.so into server: /lib64/libnssutil3.so: version `NSSUTIL_3.21' not found (required by /lib64/libnss3.so)

Version-Release number of selected component (if applicable):
1.0.11-4.fc22

How reproducible:
Run 'dnf update mod_nss' and (re)start httpd with mod_ssl configured.  It will fail to start with the error:
Cannot load modules/libmodnss.so into server: /lib64/libnssutil3.so: version `NSSUTIL_3.21' not found (required by /lib64/libnss3.so)


Actual results:
httpd fails to start

Expected results:
httpd starts every time

Additional info:
I was able to work around the problem by downgrading mod_nss with 'dnf downgrade mod_nss', which gave me version 1.0.11-3.fc22.
Comment 1 Rob Crittenden 2015-12-07 10:50:24 EST
What version of nss is installed? rpm -q nss
Comment 2 Lonni J Friedman 2015-12-07 10:54:32 EST
$ rpm -q nss
nss-3.21.0-1.1.fc22.x86_64
nss-3.21.0-1.1.fc22.i686
Comment 3 Rob Crittenden 2015-12-07 11:14:13 EST
Very strange that one would work and the other doesn't. The only difference is that -3 was built against nss 3.17 and -4 was built against 3.19.

I did a scratch build built against 3.21. Can you see if this works for you?

http://koji.fedoraproject.org/koji/taskinfo?taskID=12100142
Comment 4 Lonni J Friedman 2015-12-07 11:24:32 EST
that new build works for me:

[root@hal httpd]# ps -ef | grep httpd ; rpm -qi mod_nss
root     24064     1  5 08:22 ?        00:00:00 /usr/sbin/httpd -DFOREGROUND
apache   24067 24064  0 08:22 ?        00:00:00 /usr/sbin/httpd -DFOREGROUND
apache   24068 24064  0 08:22 ?        00:00:00 /usr/sbin/httpd -DFOREGROUND
apache   24069 24064  2 08:22 ?        00:00:00 /usr/sbin/httpd -DFOREGROUND
apache   24073 24064  2 08:22 ?        00:00:00 /usr/sbin/httpd -DFOREGROUND
apache   24075 24064  2 08:22 ?        00:00:00 /usr/sbin/httpd -DFOREGROUND
apache   24076 24064  2 08:22 ?        00:00:00 /usr/sbin/httpd -DFOREGROUND
apache   24077 24064  2 08:22 ?        00:00:00 /usr/sbin/httpd -DFOREGROUND

Name        : mod_nss
Version     : 1.0.11
Release     : 4.fc22.1
Architecture: x86_64
Install Date: Mon 07 Dec 2015 08:21:12 AM PST
Comment 5 Fedora Update System 2015-12-07 11:52:27 EST
mod_nss-1.0.11-5.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-980c228cf3
Comment 6 Fedora Update System 2015-12-07 18:21:10 EST
mod_nss-1.0.11-5.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mod_nss'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-980c228cf3
Comment 7 Fedora Update System 2015-12-28 18:54:25 EST
mod_nss-1.0.11-5.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.