Bug 128918 - atk requires too old aclocal/automake
atk requires too old aclocal/automake
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: atk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-31 10:50 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 11:16:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-07-31 10:50:27 EDT
Description of problem:
atk has a build requirement to the too old aclocal/automake 1.4,
because:

--- snipp ---
robert@tux:~ > grep aclocal\ 1.7 atk-1.7.3/aclocal.*
# generated automatically by aclocal 1.7.2 -*- Autoconf -*-
robert@tux:~ > 
robert@tux:~ > grep AC_PREREQ atk-1.7.3/configure.*
AC_PREREQ(2.54)
robert@tux:~ > 
--- snapp ---

aclocal/automake >= 1.6 is required - when it is used, because at 
current for the latest rebuild no auto* is needed.

Version-Release number of selected component (if applicable):
atk-1.7.3-1

Actual results:
To avoid problems in the future, I would suggest the following 
changes - working for me fine:

--- snipp ---
--- atk.spec       2004-07-30 17:21:16.000000000 +0200
+++ atk.spec.rsc   2004-07-31 16:45:42.000000000 +0200
@@ -11,9 +11,7 @@
 URL: http://developer.gnome.org/projects/gap/
 BuildRoot: %{_tmppath}/atk-%{PACKAGE_VERSION}-root
 BuildPreReq: glib2-devel >= %{glib2_version}
-BuildPreReq: libtool
-BuildPreReq: /usr/bin/autoconf
-BuildPreReq: /usr/bin/aclocal-1.4
+BuildPreReq: libtool, autoconf >= 2.54, automake >= 1.6

 %description
 The ATK library provides a set of interfaces for adding accessibility
--- snapp ---

Expected results:
Use of the patch ;)

Note You need to log in before you can comment on or make changes to this bug.