Bug 1289180 - Director does not create an haproxy configuration that conforms to our best-practice recommendations
Director does not create an haproxy configuration that conforms to our best-p...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Jason Guiditta
Alexander Chuzhoy
: Triaged
Depends On: 1281584
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 10:44 EST by Hugh Brock
Modified: 2016-04-26 13:42 EDT (History)
17 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.2-1.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, although the haproxy is configured to allow a value of 10000 for the 'maxconn' parameter for all proxies together, there is a default 'maxconn' value of 2000 for each proxy individually. If the specific proxy used for MySQL reached the limit of 2000, it dropped all further connections to the database and the client would not retry, which caused API timeout and subsequent commands to fail. With this update, the default value for 'maxconn' parameter has been increased to work better for production environments, As a result, the database connections are far less likely to time out.
Story Points: ---
Clone Of: 1281584
Environment:
Last Closed: 2016-04-07 17:16:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 202525 None None None Never

  None (edit)
Comment 2 Hugh Brock 2015-12-07 10:46:03 EST
Cloned this just to make sure it doesn't fall through the cracks for 8 -- it should already be in.

--H
Comment 3 Jason Guiditta 2015-12-14 14:25:22 EST
Used same doc_text as related BZ.
Comment 5 Alexander Chuzhoy 2016-02-02 12:52:55 EST
Verified:
Environment:
openstack-puppet-modules-7.0.1-2.el7ost.noarch

The default section in /etc/haproxy/haproxy.cfg has now the line:
defaults
  maxconn  4096
Comment 6 errata-xmlrpc 2016-04-07 17:16:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.