Bug 1289210 - oVirt Hosted Engine Appliance intermittently loses connectivity due to inability to restart network.service
oVirt Hosted Engine Appliance intermittently loses connectivity due to inabil...
Status: CLOSED CURRENTRELEASE
Product: ovirt-appliance
Classification: oVirt
Component: Core (Show other bugs)
3.6
Unspecified Linux
high Severity high (vote)
: ovirt-3.6.1
: 3.6
Assigned To: Fabian Deutsch
Artyom
node
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 11:42 EST by Charlie Inglese
Modified: 2016-02-10 14:18 EST (History)
6 users (show)

See Also:
Fixed In Version: oVirt-Engine-Appliance-CentOS-x86_64-7-20151211.ova
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 09:37:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fdeutsch: ovirt‑3.6.z?
fdeutsch: ovirt‑4.0.0?
rule-engine: planning_ack?
fdeutsch: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
ovirt hosted engine (3.29 KB, text/plain)
2015-12-07 11:42 EST, Charlie Inglese
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50123 master MERGED engine: Drop NIC configurato in files Never
oVirt gerrit 50411 ovirt-3.6 MERGED engine: Drop NIC configurato in files Never

  None (edit)
Description Charlie Inglese 2015-12-07 11:42:25 EST
Created attachment 1103288 [details]
ovirt hosted engine

Description of problem:

systemctl restart network fails due to incorrect /etc/sysconfig/network-scripts/ens3 file.

Version-Release number of selected component (if applicable):
ovirt-engine-appliance-20151104.0-1.el7.centos.noarch
ovirt-engine-setup-3.6.0.3-1.el7.centos.noarch


How reproducible:
Frequently (has occurred on every oVirt 3.6 HEappliance deployment)


Steps to Reproduce:
1. Install 3.6 ovirt appliance (using answer file)

Actual results:


Expected results:


Additional info:
If appears that the ens3 device is hard-coded into the KS for the appliance. Once the VM reboots, that device doesn't exist, which creates a failure condition for restarting the network service.
Comment 1 Charlie Inglese 2015-12-07 11:45:19 EST
For clarification, the ens3 device appears in the ovirt-appliance kickstart, however, after a reboot the only network devices recognized by the VM are eth0 and lo.
Comment 2 Fabian Deutsch 2015-12-08 05:46:12 EST
Thanks for the clarification.
Do you ever see the ens3 NIC name inside the appliance, or do you only see it in the kickstart?
Comment 3 Charlie Inglese 2015-12-08 09:10:24 EST
Fabian,
Yes, the ens3 NIC appears inside the appliance.

ls /etc/sysconfig/network-scripts/ifcfg-*:
ifcfg-ens3
ifcfg-eth0
ifcfg-lo

ls /sys/class/net:
eth0
lo

cat /etc/sysconfig/network-scripts/ifcfg-ens3:
# Generated by dracut initrd
NAME="ens3"
DEVICE="ens3"
ONBOOT=yes
NETBOOT=yes
UUID="a5279ae3-6818-496a-a48e-4316785c905b"
IPV6INIT=yes
BOOTPROTO=dhcp
TYPE=Ethernet
Comment 4 Fabian Deutsch 2015-12-08 12:04:01 EST
Thanks for the report, for now I'm simply removing the configuration, but there should be a more structured approach to do this post-processing.
Comment 5 Red Hat Bugzilla Rules Engine 2015-12-08 12:04:05 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 6 Red Hat Bugzilla Rules Engine 2015-12-09 08:09:50 EST
Fixed bug tickets must have version flags set prior to fixing them. Please set the correct version flags and move the bugs back to the previous status after this is corrected.
Comment 7 Red Hat Bugzilla Rules Engine 2015-12-09 08:09:50 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 8 Red Hat Bugzilla Rules Engine 2015-12-09 08:09:50 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Charlie Inglese 2015-12-09 08:40:14 EST
Will line 62 in https://gerrit.ovirt.org/#/c/50123/1/engine-appliance/data/ovirt-engine-appliance.ks.in also remove ifcfg-eth0?
Comment 10 Fabian Deutsch 2015-12-09 09:11:46 EST
Yep, during build it will remove all ifcfg-e* files - there should just be one, which will then get removed.
Comment 11 Fabian Deutsch 2015-12-09 09:12:30 EST
Please note: The file will be removed during the build. When the appliance is then booted up, NetworkManager and/or cloud-init should bring up the interface.
Comment 12 Fabian Deutsch 2015-12-09 09:39:20 EST
I just checked an older appliance:

$ guestfish -ia ./images/22b78c06-116e-4b81-ad19-535dc649db3f/f1c319d5-393b-4b7d-b273-3bfff94f4112

Welcome to guestfish, the guest filesystem shell for
editing virtual machine filesystems and disk images.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

Operating system: CentOS Linux release 7.1.1503 (Core) 
/dev/sda1 mounted on /

><fs> ls /etc/sysconfig/network-scripts/
ifcfg-ens3
ifcfg-lo
ifdown
…


This shows that ens3 is part of the image, but the in comment 3 shown eth0 is created during deployment.
Thus removing any ifcfg-e* file during the image build process, will only remove the ens3 file, not the eth0 file.
Comment 13 Artyom 2015-12-13 03:29:10 EST
Hi Fabian, we not check centos appliance, I deployed hosted engine with rhevm-appliance-20151119.0-1.el7ev.noarch.rpm and it worked fine, if it enough for verification?
Comment 14 Fabian Deutsch 2015-12-14 01:50:42 EST
Hey Artyom, please check the centos appliance separately because it is built in a slightly different way.
Comment 19 Artyom 2015-12-27 10:22:21 EST
Verified on oVirt-Engine-Appliance-CentOS-x86_64-7-20151216.ova, deploy succeed without any errors.
Comment 20 Sandro Bonazzola 2016-01-13 09:37:59 EST
oVirt 3.6.1 has been released, closing current release

Note You need to log in before you can comment on or make changes to this bug.