Bug 128922 - Patching at rebuilding PAM fails, if SELinux is disabled
Patching at rebuilding PAM fails, if SELinux is disabled
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jindrich Novy
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-31 12:27 EDT by Robert Scheck
Modified: 2013-07-02 19:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 12:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-07-31 12:27:49 EDT
Description of problem:
Patch applying at rebuilding PAM fails, if SELinux support is 
disabled.

Version-Release number of selected component (if applicable):
pam-0.77-53

How reproducible / Steps to Reproduce:
1. Set "%define WITH_SELINUX 0" in pam.spec
2. rpmbuild -ba pam.spec
3. Die with a patch applying error
  
Actual results:
I know, non SELinux is going away/is no longer available), but the 
following patch solves it simply for both situations (and the simple 
small change really doesn't hurt):

--- snipp ---
--- pam.spec       2004-07-29 21:30:51.000000000 +0200
+++ pam.spec.rsc   2004-07-31 18:28:17.000000000 +0200
@@ -150,9 +150,9 @@
 %if %{WITH_SELINUX}
 %patch60 -p1 -b .selinux
 %patch61 -p1 -b .pwdbselinux
-%endif
 %patch40 -p1 -b .grubb_leak
-%patch62 -p1 -b .closefd
+%patch62 -p1 -b .closefd
+%endif

 for readme in modules/pam_*/README ; do
        cp -f ${readme} doc/txts/README.`dirname ${readme} | sed -e 's|^modules/||'`
--- snapp ---

Expected results:
Patch applying with the next rebuild ;-)
Comment 1 Robert Scheck 2004-10-01 12:50:50 EDT
I think, this bug report isn't any longer of belong, because Fedora 
Core 3 will have SELinux support; closing with "wontfix" now.

Note You need to log in before you can comment on or make changes to this bug.