Bug 128923 - missing dependency between python and python-devel
missing dependency between python and python-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-31 12:46 EDT by Satish Balay
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 20:23:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2004-07-31 12:46:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Epiphany/1.0.8

Description of problem:
python & python-devel with different versions can coexist

Version-Release number of selected component (if applicable):
python-2.3.4-6

How reproducible:
Always

Steps to Reproduce:
1. using rawhide
2. yum update python
3. rpm -qa python*
    

Actual Results:  [root@localhost ~]# rpm -qa python*
python-2.3.4-6
python-devel-2.3.4-4


Expected Results:  python-2.3.4-6
python-devel-2.3.4-6


Additional info:

Perhaps there should be: 'python-devel depends on python' dependency -
so that - when 'python' is updated via yum - python-devel is also updated?

No depencency currently exits in python-devel

[root@localhost ~]# rpm -qp --requires
/var/cache/yum/development/packages/python-devel-2.3.4-6.i386.rpm 
/bin/sh  
/usr/bin/env  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
[root@localhost ~]#
Comment 1 Robert Scheck 2004-07-31 13:11:58 EDT
Yupp, you're right, but I also found some other missing requirements 
or requirements that should be changed:

--- snipp ---
--- python.spec       2004-07-31 17:00:56.000000000 +0200
+++ python.spec.rsc   2004-07-31 19:11:50.000000000 +0200
@@ -79,6 +79,7 @@
 %package devel
 Summary: The libraries and header files needed for Python development.
 Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
 %if !%{aspython2}
 Obsoletes: python2-devel
 Provides: python2-devel = %{version}
@@ -98,8 +99,8 @@
 %package tools
 Summary: A collection of development tools included with Python.
 Group: Development/Tools
-Requires: %{name} = %{version}
-Requires: tkinter = %{version}
+Requires: %{name} = %{version}-%{release}
+Requires: tkinter = %{version}-%{release}
 %if !%{aspython2}
 Obsoletes: python2-tools
 Provides: python2-tools = %{version}
@@ -112,6 +113,7 @@
 %package docs
 Summary: Documentation for the Python programming language.
 Group: Documentation
+Requires: %{name} = %{version}-%{release}
 %if !%{aspython2}
 Obsoletes: python2-docs
 Provides: python2-docs = %{version}
@@ -133,7 +135,7 @@
 Summary: A graphical user interface for the Python scripting language.
 Group: Development/Languages
 BuildPrereq:  tcl, tk
-Requires: %{name} = %{version}
+Requires: %{name} = %{version}-%{release}
 %if !%{aspython2}
 Obsoletes: tkinter2
 Provides: tkinter2 = %{version}
--- snapp ---

We always should require "%{name} = %{version}-%{release}" to 
prevent the problem of missing release updates or failures caused 
by the missing updates...
Comment 2 Mihai Ibanescu 2004-08-03 08:38:55 EDT
Agreed. Should be in python-2.3.4-7
Comment 3 Robert Scheck 2004-08-04 13:26:29 EDT
Okay...works for me, maybe Satish also should test it and close this 
bug after retesting...
Comment 4 Satish Balay 2004-08-04 15:03:07 EDT
I didn't  have any breakage example with the version mismatch. The
bugzilla entry was based on the yum output.

I guess things will work fine with yum if there is another python
update (and python-2.3.4-7 is the currently installed version)

rpm --provides has the dependency - so, from my point of view - this
issue is resolved.

thanks,
Comment 5 Robert Scheck 2004-11-07 06:08:26 EST
I think, this bug can be closed?!

Note You need to log in before you can comment on or make changes to this bug.