Bug 128924 - vixie-cron 4.1 using sysklogd 1.4.1 logs to /var/log/messages
Summary: vixie-cron 4.1 using sysklogd 1.4.1 logs to /var/log/messages
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sysklogd   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-31 17:05 UTC by Robert Scheck
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 4.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-02 17:16:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2004-07-31 17:05:27 UTC
Description of problem:
vixie-cron 4.1 using sysklogd 1.4.1 logs to /var/log/messages 
instead of /var/log/cron.

Version-Release number of selected component (if applicable):
sysklogd-1.4.1-21
vixie-cron-4.1-6

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. Install >= sysklogd-1.4.1-21 and >= vixie-cron-4.1-6
2. Perform some cron jobs
3. Check /var/log/messages and /var/log/cron
4. Find the cron job results in /var/log/messages instead of 
   /var/log/cron
  
Actual results:
Seems so, that the log prefix changed, from "CROND" to "crond", 
maybe that's of belong.

Expected results:
Same behaviour of cron logging as in 3.x ;-)

Comment 1 Jason Vas Dias 2004-08-01 20:21:29 UTC
PAM was silently re-opening our log to 'auth.info' in the child.
Now fixed (vixie-cron-4.1-7).

Comment 2 Robert Scheck 2004-08-02 15:14:08 UTC
Well, it works only partially for me, because with vixie-cron 3.x I 
had no messages about session opening and closing in syslog - and now 
I've got with -7 messages about session opening and closing in 
/var/log/messages. Two messages for every cron job not executed with
root - is it possible to remove that also?

--- snipp ---
Aug  2 15:45:01 tux crond(pam_unix)[4607]: session opened for user robert by (uid=0)
Aug  2 15:45:06 tux crond(pam_unix)[4607]: session closed for user robert
Aug  2 16:00:01 tux crond(pam_unix)[1723]: session opened for user robert by (uid=0)
Aug  2 16:00:07 tux crond(pam_unix)[1723]: session closed for user robert
--- snapp --- 

Would be very nice, thank you.

Comment 3 Robert Scheck 2004-08-02 17:16:07 UTC
Sorry Jason, I didn't really recognize, that my recent "problem" is PAM
related - thank you for the mail with the explanations. So vixie-cron-
4.1-7 is full working for me and solved my original issue, closing.


Note You need to log in before you can comment on or make changes to this bug.