Bug 1289278 - Automate | Quota exceeded, reason and log message values need formatting.
Automate | Quota exceeded, reason and log message values need formatting.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
low Severity low
: GA
: 5.5.3
Assigned To: William Fitzgerald
Aziza Karol
quota
: ZStream
Depends On: 1281597
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 14:49 EST by Greg McCullough
Modified: 2016-04-13 14:39 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1281597
Environment:
Last Closed: 2016-04-13 14:39:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0616 normal SHIPPED_LIVE CFME 5.5.3 bug fixes and enhancement update 2016-04-13 18:38:44 EDT

  None (edit)
Comment 5 Tina Fitzgerald 2016-01-20 17:14:18 EST
Hi Pavol,

Can you send me the logs or give me access to your environment?
The format change was to display the appropriate unit of measure.

Thanks,
Tina
Comment 8 CFME Bot 2016-02-04 16:06:08 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/e86d53f0723dd6f7d6e6f7ac5da00d5df14feeae

commit e86d53f0723dd6f7d6e6f7ac5da00d5df14feeae
Author:     Bill Fitzgerald <wfitzger@redhat.com>
AuthorDate: Wed Jan 27 18:27:25 2016 -0500
Commit:     Bill Fitzgerald <wfitzger@redhat.com>
CommitDate: Wed Jan 27 18:28:13 2016 -0500

    Automate - Quota - fixed issue with memory and storage sizes.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289278

 .../CommonMethods/QuotaMethods.class/__methods__/requested.rb    | 8 ++------
 .../System/CommonMethods/QuotaMethods.class/__methods__/used.rb  | 9 +++------
 .../unit/method_validation/calculate_requested_spec.rb           | 4 ++--
 spec/automation/unit/method_validation/calculate_used_spec.rb    | 5 +++--
 4 files changed, 10 insertions(+), 16 deletions(-)
Comment 10 CFME Bot 2016-02-11 13:27:07 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ce7a552d2bfd6b1f6123685cd32dc8edc7c44f26

commit ce7a552d2bfd6b1f6123685cd32dc8edc7c44f26
Author:     Bill Fitzgerald <wfitzger@redhat.com>
AuthorDate: Wed Jan 27 18:27:25 2016 -0500
Commit:     Bill Fitzgerald <wfitzger@redhat.com>
CommitDate: Thu Feb 11 12:02:11 2016 -0500

    Automate - Quota - fixed issue with memory and storage sizes.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289278

 .../CommonMethods/QuotaMethods.class/__methods__/requested.rb    | 8 ++------
 .../System/CommonMethods/QuotaMethods.class/__methods__/used.rb  | 9 +++------
 .../unit/method_validation/calculate_requested_spec.rb           | 4 ++--
 spec/automation/unit/method_validation/calculate_used_spec.rb    | 5 +++--
 4 files changed, 10 insertions(+), 16 deletions(-)
Comment 11 CFME Bot 2016-02-11 13:27:18 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8f39f210650aebe39dd560a87c1dfe7d4d66c202

commit 8f39f210650aebe39dd560a87c1dfe7d4d66c202
Merge: a0f3ae7 ce7a552
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Thu Feb 11 12:56:26 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Thu Feb 11 12:56:26 2016 -0500

    Merge branch 'cherry_pick_1289278' into '5.5.z'
    
    Automate - Quota - fixed issue with memory and storage sizes.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289278
    
    Clean cherry pick
    
    Original PR: https://github.com/ManageIQ/manageiq/pull/6381
    
    See merge request !784

 .../CommonMethods/QuotaMethods.class/__methods__/requested.rb    | 8 ++------
 .../System/CommonMethods/QuotaMethods.class/__methods__/used.rb  | 9 +++------
 .../unit/method_validation/calculate_requested_spec.rb           | 4 ++--
 spec/automation/unit/method_validation/calculate_used_spec.rb    | 5 +++--
 4 files changed, 10 insertions(+), 16 deletions(-)
Comment 13 CFME Bot 2016-02-15 10:35:53 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 15 Aziza Karol 2016-03-29 04:57:48 EDT
Units for storage and Memory is displayed in GB.see attached screenshot

Verified:5.5.3.2.20160318152106_92d2d67
Comment 18 errata-xmlrpc 2016-04-13 14:39:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.