Bug 1289380 - gstreamer1-vaapi-0.7.0 is available
gstreamer1-vaapi-0.7.0 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer1-vaapi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simon Farnsworth
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 19:15 EST by Upstream Release Monitoring
Modified: 2016-06-01 10:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-01 10:21:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 0.7.0 (#1289380) (1008 bytes, patch)
2015-12-07 19:15 EST, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 1.8.0 (2.74 KB, patch)
2016-03-30 07:18 EDT, Elad Alfassa
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2015-12-07 19:15:13 EST
Latest upstream release: 0.7.0
Current version/release in rawhide: 0.6.1-1.fc24
URL: http://www.freedesktop.org/software/vaapi/releases/gstreamer-vaapi/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-12-07 19:15:28 EST
Created attachment 1103399 [details]
[patch] Update to 0.7.0 (#1289380)
Comment 2 Upstream Release Monitoring 2015-12-07 19:20:47 EST
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=12104490
Comment 3 Laurent Aguerreche 2016-01-28 17:31:54 EST
Hi,

is there any news about fixing the build process?

I would like to get this new version of gst-vaapi because it is expected to fix playing videos with Totem and usage of clutter more generally.
See the bug report #1123536.

On my PC with a Sandy Bridge, the following command fails because of a bug related to OpenGL context management:

$ gst-launch-1.0 -e filesrc location='Jellyfish-3-Mbps-1080p-h264.mkv' ! matroskademux ! vaapidecode ! videoconvert ! autocluttersink
libva info: VA-API version 0.38.1
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_38
libva info: va_openDriver() returns 0
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Got context from element 'vaapidecode0': gst.vaapi.Display=context, display=(GstVaapiDisplay)NULL;
Redistribute latency...
Redistribute latency...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
ERROR: from element /GstPipeline:pipeline0/GstMatroskaDemux:matroskademux0: GStreamer encountered a general stream error.
Additional debug info:
matroska-demux.c(4636): gst_matroska_demux_loop (): /GstPipeline:pipeline0/GstMatroskaDemux:matroskademux0:
stream stopped, reason error
EOS on shutdown enabled -- waiting for EOS after Error
Waiting for EOS...

(gst-launch-1.0:9232): Cogl-WARNING **: driver/gl/cogl-framebuffer-gl.c:299: GL error (1280): Invalid enumeration value
...


The video comes from there: http://jell.yfish.us/


Rgds.
Comment 4 secarovuhe 2016-03-15 05:46:07 EDT
This page https://github.com/01org/gstreamer-vaapi says:

"*WARNING* this repository is not maintained anymore. Please use https://cgit.freedesktop.org/gstreamer/gstreamer-vaapi"

So, i guess, current version is 1.6. Source code here:

https://gstreamer.freedesktop.org/src/gstreamer-vaapi/

I've tried to install it via configure-make-install - after all - not works for me, but I'm noob) Could you try to update rpm?
Comment 5 Elad Alfassa 2016-03-15 06:25:30 EDT
There's no tarball for 1.6 in https://www.freedesktop.org/software/vaapi/releases/gstreamer-vaapi/

It seems weird to me that they'd release a version without generating a tarball and uploading it to their official web page.
Comment 6 Elad Alfassa 2016-03-15 06:30:28 EDT
Okay, here's the explanation:

https://blogs.igalia.com/vjaquez/2016/02/09/gstreamer-va-api-under-the-umbrella-of-gstreamer/

This means that the tarballs are now here:

https://gstreamer.freedesktop.org/src/gstreamer-vaapi/
Comment 7 Elad Alfassa 2016-03-30 07:18 EDT
Created attachment 1141693 [details]
[patch] Update to 1.8.0

Attached a patch.

This builds okay on rawhide, but not on F24 just yet because gstreamer1-1.8.0 is still in updates-testing due to the freeze.

All you need to do is apply this patch to master, download the source from upstream and upload it using fedpkg, commit the change to the sources file, and run fedpkg build.

Please apply the patch to update the version in rawhide at least.
Comment 8 Victor Jaquez 2016-04-08 06:46:48 EDT
Thanks Elad!

I was about to comment that gstreamer-vaapi 1.8 was released :)

Note You need to log in before you can comment on or make changes to this bug.