Bug 1289394 - [gtk3] [wayland] tooltips are misplaced before moving window for the first time
[gtk3] [wayland] tooltips are misplaced before moving window for the first time
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 20:56 EST by Christian Stadelmann
Modified: 2015-12-24 19:25 EST (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-5.0.4.2-2.fc23 libreoffice-5.0.4.2-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-24 19:25:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-12-07 20:56:55 EST
Description of problem:
Before moving libreoffice window for the first time, tooltips are misplaced.

Version-Release number of selected component (if applicable):
5.0.3.2-11.fc23

How reproducible:
always on wayland with libreoffice-gtk3 installed

Steps to Reproduce:
1. open libreoffice
2. hover over UI elements such as documents, menus, buttons, …
3. watch console

Actual results:
Tooltips are not placed where they should be (near mouse cursor) but on a fixed position.
Every time a tooltip should show up I get this warning:

(soffice:11730): Gdk-WARNING **: Couldn't map window 0x5595ff2b65c0 as popup because no grabbed seat found

Expected results:
Show tooltips just fine
Comment 1 Caolan McNamara 2015-12-08 11:21:48 EST
Yeah, I need to generate a grab somewhere. So if you e.g. activate a menu to get a manual grab then tooltips are placed correctly for a while.
Comment 2 Caolan McNamara 2015-12-14 10:15:26 EST
decided to try and implement this with native gtk tooltips instead. Making it "someone elses problem" if they are misplaced.
Comment 3 Fedora Update System 2015-12-20 15:46:05 EST
libreoffice-5.0.4.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-98c92e275f
Comment 4 Fedora Update System 2015-12-22 19:11:22 EST
libreoffice-5.0.4.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-98c92e275f
Comment 5 Fedora Update System 2015-12-24 19:25:03 EST
libreoffice-5.0.4.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.