Bug 1289406 - [virtio-win][vioser] Cannot install vioser driver successfully
[virtio-win][vioser] Cannot install vioser driver successfully
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Ladi Prosek
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 22:00 EST by Yu Wang
Modified: 2016-11-04 04:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:49:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 (44.84 KB, image/png)
2015-12-07 22:00 EST, Yu Wang
no flags Details
screenshot2 (43.66 KB, image/png)
2015-12-07 22:08 EST, Yu Wang
no flags Details
vioser_install_error (60.32 KB, image/png)
2015-12-23 04:47 EST, Yu Wang
no flags Details

  None (edit)
Description Yu Wang 2015-12-07 22:00:28 EST
Created attachment 1103424 [details]
screenshot1

Description of problem:
Cannot install vioser driver successfully

Version-Release number of selected component (if applicable):

virtio-win-prewhql-111
qemu-kvm-rhev-2.3.0-31.el7.x86_64
kernel-3.10.0-327.el7.x86_64


How reproducible:

100%

Steps to Reproduce:
1.boot cli with virtio serial device:
  /usr/libexec/qemu-kvm -M pc -m 6G -smp 4 -cpu host -usb -device usb-tablet -drive file=win.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=00:52:36:18:34:22,id=net0 -uuid 534daeff-e3af-451c-bbb7-b4ab8fb84079 -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=a,path=/tmp/monitor-win2k8R2-serial,server,nowait -mon chardev=a,mode=readline -name win2k8-R2-serial -vnc :3 -vga cirrus -device virtio-serial-pci,id=serial0 -chardev socket,id=chardev0,path=/tmp/tt,server,nowait -device virtserialport,id=port0,name=com.redhat.rhevm.vdsm,chardev=chardev0 -monitor stdio -cdrom driver.iso

2. install vioser driver with build 111


Actual results:

It shows error info as follows(attachment:screenshot1/2):

shows "This driver is not digitally signed" when selected to install the driver
shows "windows found driver software for your device bug encountered an error while attempting to install it" and "the system cannot find the file specified"

Expected results:

Install driver succesfully

Additional info:
1 it is a testblocker and regression bug , because the build 108 and 110 is normal
2 tried on win10-32/64, win8-32 and win2008R2, all hit this issue.
Comment 1 Yu Wang 2015-12-07 22:08 EST
Created attachment 1103426 [details]
screenshot2
Comment 2 Gal Hammer 2015-12-08 03:34:42 EST
Hi Vadim,

Build 111 is missing the virtio-serial and virtio-rng files (*.sys, *.cat, etc...). Only the inf files exists.

Can you please check it?

Thanks, Gal.
Comment 3 Vadim Rozenfeld 2015-12-08 04:29:31 EST
(In reply to Gal Hammer from comment #2)
> Hi Vadim,
> 
> Build 111 is missing the virtio-serial and virtio-rng files (*.sys, *.cat,
> etc...). Only the inf files exists.
> 
> Can you please check it?
> 
> Thanks, Gal.

Yes, build 111 has a problem due to introducing some virtio 1.0 support.
Comment 5 Yu Wang 2015-12-23 04:46:36 EST
try to verified this issue on virtio-win-prewhql-112

OS:* win7-64/win2008R2 
   * win7-32 
   * win2012-64
   * win8-32

step as comment#0

Actual result:
1  for win7-32  win2012-64 and win8-32,install vioser driver succesfully

2  for win7-64/win2008R2, still occurred error(Code 52), refer to attachment named "vioser_install_error"

Base on above, for win7-32  win2012-64 and win8-32 this issue has been fixed already. for win7-64/win2008R2 has not been fixed.
Comment 6 Yu Wang 2015-12-23 04:47 EST
Created attachment 1108877 [details]
vioser_install_error
Comment 7 lijin 2016-02-04 00:03:28 EST
win2008R2 still hit this issue with build 113
Comment 8 lijin 2016-02-17 03:31:47 EST
set Regression,TestBlocker keywords due to it block win7-64/win2008-64/win2008R2 guests' driver test.
Comment 9 Yu Wang 2016-03-04 02:09:07 EST
win7-64 still hit this issue with build 114

error code 52
Comment 10 Ladi Prosek 2016-03-11 07:21:25 EST
This seems to have started when virtio-win switched to the new certificate. Build 110 uses a cert issued by "VeriSign Class 3 Code Signing 2010 CA" which expired on 11/29/2015. Newer builds use a cert issued by "Symantec Class 3 SHA256 Code Signing CA".

Windows 7 doesn't come with built-in SHA-2 certificate support but it is available as an update. Here's the security update page:
https://technet.microsoft.com/en-us/library/security/3033929

And the Windows 7 x64 download page:
https://www.microsoft.com/en-us/download/details.aspx?id=46148

wangyu, please try installing this update to see if it resolves the issue. It worked for me.

Also, it is possible that some of your test machines picked up this update from Windows Update, which may make it look like the issue has been fixed.
Comment 11 Peixiu Hou 2016-03-14 05:46:25 EDT
Hello Ladi,

According to comment10, I have done following verified with virtio-win-prewhql build, please help to check~~

OS        build    "vioser driver update status"   "if install security update"
--------------------------------------------------------------------------------
win7-64    111         fail                                no
win7-64    113         fail(with code 52)                  no
win7-64    114         fail(with code 52)                  no

win7-64    111         fail                                yes
win7-64    113         success                             yes
win7-64    114         success                             yes

win2008R2  111         fail                                no
win2008R2  113         fail(with code 52)                  no
win2008R2  114         fail(with code 52)                  no

win2008R2  111         fail                                yes
win2008R2  113         success                             yes
win2008R2  114         success                             yes

For win2008-64, the security update is not available for windows server 2008.

kernel: 3.10.0-361.el7.x86_64
qemu: qemu-kvm-rhev-2.5.0-1.el7.x86_64
security update: Windows6.1-KB3033929-x64.msu


Best Regards~
Peixiu Hou
Comment 12 Ladi Prosek 2016-03-14 07:32:05 EDT
Hi Peixiu Hou,

Build 111 has other issues. A bunch of files are missing as noted by Gal and Vadim in comments 2 and 3, so it shouldn't be used at all.

Thanks for confirming that installing the update worked. From what you wrote it looks like the new SHA-2 certificate is a test blocker because some of the operating systems cannot be updated. Let me try to figure out why we switched to SHA-2.

Thanks,
Ladi
Comment 13 Vadim Rozenfeld 2016-03-17 23:17:08 EDT
Can we please give a try to build 115 available at http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/115/win/virtio-win-prewhql-0.1.zip

Thanks,
Vadim.
Comment 14 Peixiu Hou 2016-03-18 04:43:51 EDT
Hello Vadim,

I've verified this issue with build 115, the results as follows:

OS        build    "vioser driver update status"   "if install security update"
--------------------------------------------------------------------------------
win7-64    115         success                             yes
win7-64    115         fail(with code 52)                  no

win2008R2  115         success                             yes
win2008R2  115         fail(with code 52)                  no

win2008-64 115         fail(with code 39)                  no

For win2008-64, update vioser driver will report error message "Windows encountered a problem installing the driver software for your device" and  will show "Windows cannot load the device for this hardware, The driver may be corrupted jor missing.(Code 39)". And check the build 115 package, *.cat, *.inf, *.pdb, *.sys files are exist. 

Thanks~~

Best Regards~
Peixiu Hou
Comment 15 Peixiu Hou 2016-03-18 05:20:31 EDT
cancel needinfo
Comment 16 Yu Wang 2016-03-28 02:02:29 EDT
Reproduced this issue on virtio-win-prewhql-115
Verified this issue on virtio-win-prewhql-116

Verified guest os :
*win7-64
*win2008-64 
*win2008R2.

Verified driver

*viorng
*balloon
*vioser
*pvpanic
*netkvm
*viostor
*vioscsi

steps same as comment#0

on build 116,driver can all successfully installed 
Above all, bug has been fixed, fix version virtio-win-prewhql-116.

Thanks for your great support!:)

BR
wyu
Comment 17 Ladi Prosek 2016-05-26 04:17:23 EDT
Over to MODIFIED as we've already produced a build with the fix.
Comment 18 Yu Wang 2016-05-26 04:30:14 EDT
change status to "verified" according to comment#16
Comment 21 errata-xmlrpc 2016-11-04 04:49:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html

Note You need to log in before you can comment on or make changes to this bug.