Bug 1289410 - Nova hostname required in nova.conf
Nova hostname required in nova.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: James Slagle
Prasanth Anbalagan
: Triaged
Depends On:
Blocks: 1185030
  Show dependency treegraph
 
Reported: 2015-12-07 22:11 EST by Andrew Beekhof
Modified: 2016-04-15 10:30 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.11-1.el7ost
Doc Type: Enhancement
Doc Text:
Feature: The "host" configuration setting in nova.conf and neutron.conf on compute nodes is now set to the fqdn of the compute node. Reason: In order for instance HA to function safely, the NovaCompute agent needs access to the name by which nova knows the current compute node. Neutron agents running on the compute nodes also need the equivalent value for their "host" configuration configured, otherwise instances can not be scheduled to the compute node. Result: The "host" configuration setting is now set to the fqdn of the compute node in /etc/nova/nova.conf and /etc/neutron/neutron.conf on each compute node deployed by OSP Director.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-15 10:30:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 288866 None None None 2016-03-05 08:35 EST
OpenStack gerrit 291881 None None None 2016-03-11 14:40 EST

  None (edit)
Description Andrew Beekhof 2015-12-07 22:11:53 EST
Description of problem:

In order for instance HA to function safely, the NovaCompute agent needs access to the name by which nova knows the current compute node.

The code currently tries to obtain it on compute nodes with:

  openstack-config --get /etc/nova/nova.conf DEFAULT host

However this does not appear to be set/configured by director.

Could we either get it set here or have a pointer to a more appropriate location to obtain it?
Comment 3 Hugh Brock 2016-02-05 07:13:27 EST
Steve, I know you're already working on this so I assigned it to you. Please update the bug status accordingly.
Comment 7 Prasanth Anbalagan 2016-04-12 21:43:09 EDT
Verified as follows,

*******
VERSION
********
[stack@instack ~]$ rpm -qa openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-0.8.14-5.el7ost.noarch


**********
LOGS
**********

[heat-admin@overcloud-novacompute-0 ~]$ sudo openstack-config --get /etc/nova/nova.conf DEFAULT host
overcloud-novacompute-0.localdomain

[heat-admin@overcloud-novacompute-1 ~]$ sudo openstack-config --get /etc/nova/nova.conf DEFAULT host
overcloud-novacompute-1.localdomain
Comment 9 errata-xmlrpc 2016-04-15 10:30:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0637.html

Note You need to log in before you can comment on or make changes to this bug.