Bug 1289428 - Test ./tests/bugs/fuse/bug-924726.t fails
Test ./tests/bugs/fuse/bug-924726.t fails
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
mainline
All All
medium Severity medium
: ---
: ---
Assigned To: Raghavendra G
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 00:34 EST by Raghavendra G
Modified: 2016-06-16 09:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:49:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2015-12-08 00:34:54 EST
Description of problem:
++ ps ax
++ grep -i /mnt/glusterfs/0
++ grep glusterfs
++ sed -e 's/^ *\([0-9]*\).*/\1/g'
++ grep -v grep
+ GLFS_MNT_PID='7056
17109'
++ netstat -nap
++ grep 7056 17109
++ grep ESTABLISHED
++ wc -l
grep: 17109: No such file or directory
+ SOCKETS_BEFORE_SWITCH=0
+ set +x

As can be seen above we got two values for GLFS_MNT_PID resulting in failure of other tests.

Version-Release number of selected component (if applicable):
master

How reproducible:
consistently

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-12-08 00:38:22 EST
REVIEW: http://review.gluster.org/12906 (tests/bug-924726.t: fix grep pattern to get correct glusterfs pid) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 2 Vijay Bellur 2015-12-08 16:46:29 EST
REVIEW: http://review.gluster.org/12906 (tests/bug-924726.t: fix grep pattern to get correct glusterfs pid) posted (#2) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 3 Vijay Bellur 2015-12-09 08:18:48 EST
COMMIT: http://review.gluster.org/12906 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 8424674e7046136728e5f43adb19bb1fa5b19f5a
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Tue Dec 8 11:06:33 2015 +0530

    tests/bug-924726.t: fix grep pattern to get correct glusterfs pid
    
    Change-Id: Ia2444b1b3e45e3e224bcd59e780a0f38c492f133
    BUG: 1289428
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/12906
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Niels de Vos 2016-06-16 09:49:19 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.