Bug 128943 - cups needs dbus = 0.21, this is not available
cups needs dbus = 0.21, this is not available
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-01 13:00 EDT by Bob Gustafson
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 14:02:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-08-01 13:00:58 EDT
Description of problem:

cannot update dbus\* components

The cups needs dbus = 0.21 seems like odd syntax.

Version-Release number of selected component (if applicable):

  see blow

How reproducible:

  Has been this way for about a week or so - from the 490 kernels
through 501

Steps to Reproduce:
1. yum update dbus\*

Actual results:

[root@hoho2 ~]# yum update dbus\*

Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
.....Unable to satisfy dependencies
Package cups needs dbus = 0.21, this is not available.
[root@hoho2 ~]#

Expected results:

  Should update cleanly

Additional info:

[root@hoho2 ~]# date
Sun Aug  1 11:46:56 CDT 2004

[root@hoho2 ~]# rpm -q dbus
dbus-0.21-10

[root@hoho2 ~]# rpm -q dbus-devel
dbus-devel-0.21-10

[root@hoho2 ~]# cat /proc/version
Linux version 2.6.7-1.501smp (bhcompile@tweety.build.redhat.com) (gcc
version 3.4.1 20040714 (Red Hat 3.4.1-7)) #1 SMP Fri Jul 30 08:51:22
EDT 2004
[root@hoho2 ~]#
Comment 1 John (J5) Palmieri 2004-08-02 12:01:42 EDT
Actually this was a planned breakage that happened on friday.  CUPS
imports the exact version number because DBUS's API is in flux.  I
needed to updated DBUS so that a few apps could test against it before
updating themselves.  CUPS should follow shortly.  I don't expect the
breakage to last past tomorrow depending on how fast it gets synced to
public servers.  I will keep this bug open until CUPS is updated in
rawhide.
Comment 2 Bob Gustafson 2004-08-10 14:02:43 EDT
Seems to work OK now.

Thanks for the feedback.

Works for me

Note You need to log in before you can comment on or make changes to this bug.