Bug 128944 - Can't mount USB camera Nikon D70
Can't mount USB camera Nikon D70
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-01 13:01 EDT by Gérard Milmeister
Modified: 2015-01-04 17:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:36:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2004-08-01 13:01:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.16

Description of problem:
I can access my Nikon D70 via PTP using gthumb or gphoto2 just fine,
but as mass storage device it doesn't work.

Here is the relevant information from /var/log/messages:
Aug  1 18:54:57 scriabin kernel: usb 2-2: new full speed USB device
using address 18
Aug  1 18:54:57 scriabin kernel: scsi26 : SCSI emulation for USB Mass
Storage devices
Aug  1 18:54:57 scriabin kernel:   Vendor: NIKON     Model: D70      
        Rev: 1.02
Aug  1 18:54:57 scriabin kernel:   Type:   Direct-Access             
        ANSI SCSI revision: 02
Aug  1 18:54:57 scriabin kernel: SCSI device sdf: 1000945 512-byte
hdwr sectors (512 MB)
Aug  1 18:54:57 scriabin kernel: sdf: assuming Write Enabled
Aug  1 18:54:57 scriabin kernel: sdf: assuming drive cache: write through
Aug  1 18:54:57 scriabin kernel:  sdf:end_request: I/O error, dev sdf,
sector 1000944
Aug  1 18:54:57 scriabin kernel: Buffer I/O error on device sdf,
logical block 1000944
Aug  1 18:54:57 scriabin kernel: end_request: I/O error, dev sdf,
sector 1000944Aug  1 18:54:57 scriabin kernel: Buffer I/O error on
device sdf, logical block 1000944
Aug  1 18:54:57 scriabin kernel:  sdf1
Aug  1 18:54:57 scriabin kernel: Attached scsi removable disk sdf at
scsi26, channel 0, id 0, lun 0
Aug  1 18:54:57 scriabin kernel: Attached scsi generic sg5 at scsi26,
channel 0, id 0, lun 0,  type 0
Aug  1 18:54:57 scriabin kernel: Device not ready.  Make sure there is
a disc in the drive.
Aug  1 18:54:57 scriabin last message repeated 8 times
Aug  1 18:54:57 scriabin kernel: updfstab: Using deprecated /dev/sg
mechanism instead of SG_IO on the actual device
Aug  1 18:54:57 scriabin last message repeated 5 times
Aug  1 18:54:58 scriabin scsi.agent[18160]: disk at
/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0/host26/26:0:0:0


Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435

How reproducible:
Always

Steps to Reproduce:
1. Plugin Nikon in
2. Switch on

    

Additional info:
Comment 1 Pontus Enhager 2004-08-11 18:36:09 EDT
I can confirm that i cannot reach it as mass storage
Comment 2 Michael Fischer 2004-08-17 00:51:18 EDT
I can also confirm that Nikon D70 mass storage mode does not work for
me under FC2.  It used to work under FC1.
Comment 3 Quy Tonthat 2004-12-14 05:28:08 EST
Not working for FC3 (up-to-date with kernel 2.6.9-1.667) either.
Generated lots of log messages such as:

Dec 14 20:27:55 qpad kernel: end_request: I/O error, dev sda, sector 63
Dec 14 20:27:55 qpad kernel: Buffer I/O error on device sda1, logical
block 0
Dec 14 20:27:55 qpad kernel: Buffer I/O error on device sda1, logical
block 1
Dec 14 20:27:55 qpad kernel: Buffer I/O error on device sda1, logical
block 2

Note that the same CF card works fine using CF reader.
The same problems happen on all 5 different machines (all FC3) I tried
so far. Going back to earlier kernel won't help either.
Comment 4 Quy Tonthat 2004-12-14 05:51:17 EST
Correction: the latest kernel version from my last
post should be 2.6.9-1.681_FC3.
Just for the sake of accuracy.
Comment 5 Quy Tonthat 2004-12-15 07:16:24 EST
Disabling EFI_PARTITION in kernel config will fix this problem.
Comment 6 Duncan Grisby 2004-12-31 15:06:45 EST
I have the same issue on FC3, and with the kernel-smp-2.6.9-1.715_FC3
kernel from
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/3/SRPMS/
Comment 7 Dave Jones 2005-07-15 13:32:33 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 Michael Fischer 2005-07-15 14:56:23 EDT
It works for me now in FC4 with kernel-2.6.12-1.1390_FC4.

Note You need to log in before you can comment on or make changes to this bug.