Bug 128946 - poweroff leaves system in "half-power" state
poweroff leaves system in "half-power" state
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-01 16:52 EDT by long
Modified: 2015-01-04 17:08 EST (History)
3 users (show)

See Also:
Fixed In Version: kernel-smp-2.6.9-1.3_FC2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 18:38:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description long 2004-08-01 16:52:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The poweroff command leaves the machine in a semi powered down state.
 It flushes the IDE disks, sounds like it shuts them off, then shuts
off the display.  However, everything else (fans, etc.) are still
running and the power light remains on.  Sometimes the reset button
will restart the machine, at other times I have to use the switch on
the power supply to turn the machine off.  The power button definitely
doesn't work in this state, no matter how long I hold it down for.  In
RH9 and earlier the apm=power_off option worked for me, but FC2 uses
ACPI by default.  I've tried adding the nolapic kernel option (as read
elsewhere) but that seemed to have no effect.  Let me know what other
information I can supply.  The MB is a Tyan S2460 and I'm running
kernel-smp-2.6.6-1.435.2.3.  BIOS version is 1.05 (latest).



Version-Release number of selected component (if applicable):
SysVinit-2.85-25

How reproducible:
Always

Steps to Reproduce:
1. poweroff
2.
3.
    

Actual Results:  The poweroff command leaves the machine in a semi
powered down state.  It flushes the IDE disks, sounds like it shuts
them off, then shuts off the display.  However, everything else (fans,
etc.) are still running and the power light remains on.  Sometimes the
reset button will restart the machine, at other times I have to use
the switch on the power supply to turn the machine off.  The power
button definitely doesn't work in this state, no matter how long I
hold it down for.

Expected Results:  Machine should completely power down.


Additional info:
Comment 1 David Masterson 2004-08-19 14:35:21 EDT
I have a similar setup (TYAN MB S2460/Dual-CPU) and see the same
problem with shutdown (which, I think, calls poweroff at the end).  I
have upgraded to kernel-smp-2.6.7-1.494.2.2.  I haven't seen
documentation on kernel options to try, so I haven't tried any.  In
FC1 (same system), the system would shutdown to the point where it
would tell me to turn the power off, but it wouldn't try to poweroff
on its own.
Comment 2 G. Michael Carter 2004-10-05 15:41:10 EDT
I get the same problem on my Dell Poweredge 300.  Which is a Dual-CPU.
 This wasn't a problem on FC1.  But since I replaced all my systems to
FC2 this Dell is the only one which doesn't shutdown properly.

I have a Dell Latitude D600, Compac 700M, and a Cicero which are
running FC2 and they all work fine.

I wonder if it's something to do with the SMP version?
Comment 3 long 2004-10-05 15:52:39 EDT
This still happens also with:

kernel-smp-2.6.5-1.358
kernel-smp-2.6.6-1.435.2.3
kernel-smp-2.6.7-1.494.2.2
kernel-smp-2.6.8-1.521
Comment 4 Stefan Hoelldampf 2004-10-31 14:52:51 EST
Maybe this problem is related to bug 132761
Comment 5 long 2004-12-22 18:38:43 EST
Problem seems to have disappeared at 2.6.9-1.3_FC2.

Note You need to log in before you can comment on or make changes to this bug.