Bug 1289460 - epel7 libkmahjongg has broken deps with EL 7.2
epel7 libkmahjongg has broken deps with EL 7.2
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: libkmahjongg (Show other bugs)
epel7
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7aarch64
  Show dependency treegraph
 
Reported: 2015-12-08 03:04 EST by Yaakov Selkowitz
Modified: 2015-12-28 16:26 EST (History)
6 users (show)

See Also:
Fixed In Version: libkmahjongg-4.10.5-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 16:26:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaakov Selkowitz 2015-12-08 03:04:04 EST
RHEL kdelibs was rebased to 4.14.8 in 7.2, but epel7 libkmahjongg has:

Requires: libkdegames%{?_isa} >= %{_kde4_version}

As epel7 libkdegames is still at 4.10.5, this results in a broken dependency tree.
Comment 1 Anssi Johansson 2015-12-08 04:17:25 EST
Are you sure about this? Installing kmahjongg 4.10.5-1.el7 from EPEL seems to work fine on CentOS 7.2.1511.
Comment 2 Rex Dieter 2015-12-08 07:39:45 EST
Well, it'll be broken when/if libkmahnongg is ever rebuilt
Comment 3 Fedora Update System 2015-12-08 09:32:12 EST
libkmahjongg-4.10.5-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-a4bfe56b6e
Comment 4 Fedora Update System 2015-12-09 00:20:44 EST
libkmahjongg-4.10.5-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update libkmahjongg'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-a4bfe56b6e
Comment 5 Fedora Update System 2015-12-28 16:26:22 EST
libkmahjongg-4.10.5-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.