Bug 1289465 - Disable server-side quorum for virt-store usecase
Disable server-side quorum for virt-store usecase
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core (Show other bugs)
3.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ravishankar N
SATHEESARAN
: ZStream
Depends On:
Blocks: Gluster-HC-2
  Show dependency treegraph
 
Reported: 2015-12-08 03:32 EST by SATHEESARAN
Modified: 2016-09-17 10:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEV-RHGS Integration
Last Closed: 2016-02-01 06:29:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2015-12-08 03:32:57 EST
Description of problem:
-----------------------
'virt' group file which contains the volume options for optimizing volume for virt-store usecase, includes server side quorum.

Server-side quorum is not fool-proof for preventing split-brain in the volume

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1

How reproducible:
-----------------
NA

Steps to Reproduce:
-------------------
1. cat /var/lib/glusterd/groups/virt

Actual results:
---------------
server-side quorum is enabled in virt group file

Expected results:
-----------------
server-side quorum should be disabled

Additional info:
----------------
By default, server-side quorum is turned off, and so its simple to remove the entry "server-quorum-type=server" from virt group file
Comment 3 Ravishankar N 2016-01-12 06:17:26 EST
Apparently GSS are finding that for replica 2 set-up, adding a dummy node and enabling server quorum is reducing the probability of files ending up in split-brain. So it might be better to retain this option for now. Once arbiter volumes are made available for downstream, it might make sense to remove this option.
Comment 4 Ravishankar N 2016-02-01 06:29:37 EST
Closing this bug since there is no consensus on the future of server-quorum as of today. If a firm decision can be arrived at for disabling it or even removing it altogether, the bug can be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.