Bug 1289483 - FSAL_GLUSTER : Rename throws error in mount when acl is enabled
FSAL_GLUSTER : Rename throws error in mount when acl is enabled
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nfs-ganesha (Show other bugs)
3.1
All All
medium Severity medium
: ---
: RHGS 3.1.2
Assigned To: Jiffin
Apeksha
: Triaged, ZStream
Depends On: 1286900
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 04:40 EST by Jiffin
Modified: 2016-03-01 01:02 EST (History)
5 users (show)

See Also:
Fixed In Version: nfs-ganesha-2.2.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286900
Environment:
Last Closed: 2016-03-01 01:02:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiffin 2015-12-08 04:40:04 EST
+++ This bug was initially created as a clone of Bug #1286900 +++

Description of problem:
When acl is enabled and if rename is performed gettattr() call in FSAL_GLUSTER may return ENOENT for replaced(or removed) file. This will throw an error in mount even though rename was successful.

Version-Release number of selected component (if applicable):
latest

How reproducible:
using pynfs test it is 100% reproducible.

Steps to Reproduce:
1.Create a volume and export it via nfs-ganesha with acl enabled
2.Run RNM15 test in the pynfs suite for nfsv4


Actual results:
throws error in mount saying "No such file or directory"

Expected results:
Should throw this error

Additional info:
Error is sent from glfs_h_acl_get() in FSAL

--- Additional comment from Jiffin on 2015-11-30 23:53:00 EST ---

Upstream patch reference https://review.gerrithub.io/#/c/253518/
Comment 2 Jiffin 2015-12-16 01:02:46 EST
The patch got merged in upstream https://review.gerrithub.io/#/c/253518/
Comment 3 Apeksha 2015-12-18 04:46:53 EST
Ran the RNM15 tests from pynfs test suit, he test passed on nfs-ganesha-2.2.0-12.el7rhgs.x86_64. Hence marking it as verified.

Results of the tests:
MKDIR    st_create.testDir                                        : RUNNING
MKDIR    st_create.testDir                                        : PASS
INIT     st_setclientid.testValid                                 : RUNNING
INIT     st_setclientid.testValid                                 : PASS
MKFILE   st_open.testOpen                                         : RUNNING
MKFILE   st_open.testOpen                                         : PASS
RNM15    st_rename.testFileToFile                                 : RUNNING
RNM15    st_rename.testFileToFile                                 : PASS
**************************************************
INIT     st_setclientid.testValid                                 : PASS
MKDIR    st_create.testDir                                        : PASS
MKFILE   st_open.testOpen                                         : PASS
RNM15    st_rename.testFileToFile                                 : PASS
**************************************************
Command line asked for 4 of 662 tests
Of those: 0 Skipped, 0 Failed, 0 Warned, 4 Passed
Comment 5 errata-xmlrpc 2016-03-01 01:02:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.