Bug 1289498 - keyingtries=0 is broken - meaning it is interpreted as keyingtries=1
keyingtries=0 is broken - meaning it is interpreted as keyingtries=1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreswan (Show other bugs)
6.7
All Linux
high Severity medium
: rc
: ---
Assigned To: Paul Wouters
Jaroslav Aster
Tomas Capek
Regression
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 05:31 EST by Ondrej Moriš
Modified: 2017-03-21 05:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
The *keyingtries* libreswan option set to `0` is mistakenly interpreted as `1` The default value of *keyingtries* is `0` which means 'retry forever'. Due to this bug, if a temporary problem occurs during an active negotiation, the connection will not be attempted more than once. To work around this problem, set the *keyingtries* option to a sufficiently large number.
Story Points: ---
Clone Of: 1283468
Environment:
Last Closed: 2017-03-21 05:05:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0575 normal SHIPPED_LIVE libreswan bug fix update 2017-03-21 08:23:23 EDT

  None (edit)
Comment 10 errata-xmlrpc 2017-03-21 05:05:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0575.html

Note You need to log in before you can comment on or make changes to this bug.