Bug 1289510 - Foreman uses docker0 ip address as primary interface if docker package is installed
Foreman uses docker0 ip address as primary interface if docker package is ins...
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
: 1445692 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 06:31 EST by Dirk Herrmann
Modified: 2017-08-01 15:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 15:57:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 18252 None None None 2017-01-26 08:42 EST

  None (edit)
Description Dirk Herrmann 2015-12-08 06:31:31 EST
Description of problem:

While provisioning a new host which has docker package installed the primary network interface foreman is using is set to docker0 instead of eth0.

This prevents edit and rebuild operations of this host.

Version-Release number of selected component (if applicable):

Tested with Satellite 6.1.2,3,4.

How reproducible:

Provision a new host using a Puppet module or provisioning template to install docker package.

Steps to Reproduce:
1. Provision a host using docker package
2. Go to Hosts -> All Hosts -> Select the host
3. IP Address is set to docker0 IP which is not reachable from Sat6

Actual results:

docker0 IP is set to primary interface

Expected results:

eth0 should be the primary interface used by foreman


Additional info:

As a workaround you can disable update_environment_from_facts: Go to Administer -> Settings -> Puppet and set update_environment_from_facts to False (default: true).
Comment 1 Maxim Burgerhout 2016-04-29 06:17:02 EDT
SAtellite 6.2 has a configurable list of interfaces that are to be ignored. The docker0 interface isn't part of that list out of the box, but it would make sense to include it there by default.

Settings -> Provisioning -> Ignore interfaces with matching identifier

As we now include the possibility to install Atomic hosts from Satellite, this becomes more important imo

Makes sense to change component to Provisioning?
Comment 2 Bryan Kearney 2016-07-26 15:09:04 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 Tom McKay 2017-01-26 08:42:42 EST
Created redmine issue http://projects.theforeman.org/issues/18252 from this bug
Comment 4 pm-sat@redhat.com 2017-01-26 10:19:32 EST
Upstream bug assigned to tomckay@redhat.com
Comment 5 pm-sat@redhat.com 2017-01-26 10:19:35 EST
Upstream bug assigned to tomckay@redhat.com
Comment 6 pm-sat@redhat.com 2017-01-26 16:19:41 EST
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18252 has been resolved.
Comment 8 Evgeni Golov 2017-05-30 06:12:06 EDT
FWIW, You can manually apply the fix from the upstream PR (https://github.com/theforeman/foreman/pull/4233) by adding "docker*" to "ignored_interface_identifiers" in the settings of Satellite.
Comment 9 Sachin Ghai 2017-05-30 07:33:30 EDT
*** Bug 1445692 has been marked as a duplicate of this bug. ***
Comment 10 Bryan Kearney 2017-08-01 15:57:58 EDT
The fix to this bug will be delivered with release 6.3 of Satellite.

Note You need to log in before you can comment on or make changes to this bug.