Bug 1289515 - compiz-mate does not pick up titlebar font settings from marco
compiz-mate does not pick up titlebar font settings from marco
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 06:36 EST by JJ Keijser
Modified: 2015-12-30 20:50 EST (History)
1 user (show)

See Also:
Fixed In Version: compiz-0.8.10-2.fc23 compiz-0.8.10-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-30 19:55:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the defect (1.21 KB, patch)
2015-12-08 06:36 EST, JJ Keijser
no flags Details | Diff

  None (edit)
Description JJ Keijser 2015-12-08 06:36:18 EST
Created attachment 1103558 [details]
patch to fix the defect

Description of problem:

In the "Mate" spin of Fedora 22, compiz-mate does not pick up the titlebar font settings from marco. The theme is correctly picked up.


Version-Release number of selected component (if applicable):

compiz-mate-0.8.9-2.fc22.x86_64.rpm

How reproducible:

Always

Steps to Reproduce:
1. change title bar font settings (e.g. increase size) in Marco (default mate WM)
2. turn on compiz
3. title bar font reverts to some compiz default

Actual results:

some compiz default font is used for the title bar

Expected results:

I'd *like* the same font as select in the Mate (marco) control-center to be used. 


Attached is a patch to the compiz-decorator-gtk and compiz-mate-gtk scripts which fix the problem. A similar fix can/should be added for the fusion-icon code.
Comment 1 Wolfgang Ulbrich 2015-12-08 07:20:52 EST
Thanks,
we did that already in upstream project :)
https://github.com/raveit65/compiz/commit/bf62aaa5a51a038e0ce41a9ad7191349e74243eb
But in next upstream release we go another way.
https://github.com/raveit65/compiz/commit/8c49931658283960c6d197ee556eb1831e7f3b9a#diff-6534e241c86d2de3c2df0810f074dcaa
With that compiz itself reads the font and theme value when compiz starts, from what is set in mate dconf values.
Also the start scripts will gone.
New release will have 2 menu entries for starting compiz and changing the decorator if it was changed mate-control-center during runtime of comiz,
same as in old versions.
Only the dconf value for starting compiz via session management will change from
'compiz-mate-gtk/compiz-mate-emerald' to 'compiz'
[rave@mother ~]$ gsettings get org.mate.session.required-components windowmanager
'compiz-mate-gtk'
This is better because it can start compiz with gtk or emerald decorator, depends what is set in compiz config.
Well, i will publish this change in forums.
I think i will prepare a new upstream release in the next weeks.

So, can you live a while without appying your patch ;)  ?
Comment 2 JJ Keijser 2015-12-08 11:26:33 EST
sure I can live with that - I just wanted to make sure that the problem was reported and taken care of. Looks like you beat me to it ;)
Comment 3 Fedora Update System 2015-12-19 17:22:28 EST
fusion-icon-0.1.2-2.fc22 compiz-manager-0.7.0-1.fc22 compiz-0.8.10-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ffe086cf8f
Comment 4 Fedora Update System 2015-12-20 06:55:59 EST
compiz-0.8.10-1.fc22, compiz-manager-0.7.0-1.fc22, fusion-icon-0.1.2-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update compiz compiz-manager fusion-icon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ffe086cf8f
Comment 5 Fedora Update System 2015-12-20 07:24:12 EST
compiz-0.8.10-1.fc23, compiz-manager-0.7.0-1.fc23, fusion-icon-0.1.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update compiz compiz-manager fusion-icon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-a608b3a667
Comment 6 Fedora Update System 2015-12-20 17:26:27 EST
compiz-manager-0.7.0-2.fc23 emerald-0.8.9-3.fc23 fusion-icon-0.1.2-4.fc23 compiz-0.8.10-2.fc23 marco-1.12.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-155fbf7d55
Comment 7 Fedora Update System 2015-12-20 17:26:27 EST
compiz-manager-0.7.0-2.fc22 emerald-0.8.9-3.fc22 fusion-icon-0.1.2-4.fc22 compiz-0.8.10-2.fc22 marco-1.12.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-166c19ee89
Comment 8 JJ Keijser 2015-12-20 19:06:01 EST
Just tested this update, fixes the problem on my fc22 box.
Comment 9 Fedora Update System 2015-12-22 10:33:45 EST
compiz-0.8.10-2.fc22, compiz-manager-0.7.0-2.fc22, emerald-0.8.9-3.fc22, fusion-icon-0.1.2-4.fc22, marco-1.12.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-166c19ee89
Comment 10 Fedora Update System 2015-12-22 19:11:14 EST
compiz-0.8.10-2.fc23, compiz-manager-0.7.0-2.fc23, emerald-0.8.9-3.fc23, fusion-icon-0.1.2-4.fc23, marco-1.12.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-155fbf7d55
Comment 11 Fedora Update System 2015-12-30 19:55:46 EST
compiz-0.8.10-2.fc23, compiz-manager-0.7.0-2.fc23, emerald-0.8.9-3.fc23, fusion-icon-0.1.2-4.fc23, marco-1.12.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-12-30 20:50:20 EST
compiz-0.8.10-2.fc22, compiz-manager-0.7.0-2.fc22, emerald-0.8.9-3.fc22, fusion-icon-0.1.2-4.fc22, marco-1.12.1-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.