Bug 1289528 - volume control does not work
volume control does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qmmp (Show other bugs)
23
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Karel Volný
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-08 06:51 EST by customercare
Modified: 2016-01-09 16:57 EST (History)
2 users (show)

See Also:
Fixed In Version: qmmp-0.9.5-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-09 16:57:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description customercare 2015-12-08 06:51:49 EST
Description of problem:


you can use the volume slider as you like, the playback sound does not change.

Version-Release number of selected component (if applicable):

0.8.5

Expected results:

working volume control.
Comment 1 customercare 2015-12-08 06:55:31 EST
Additionla Info:

Volumecontrol via 9+0 Keys does not work either.
Comment 2 Karel Volný 2015-12-08 11:02:19 EST
Which audio output do you use?

In case of ALSA, do you have correct mixer device & channel set?

Properties => Modules => Output => ALSA => Settings ...
Comment 3 customercare 2015-12-08 11:06:47 EST
It's a fresh installation of Fed 23 with PulseAudio Defaults.

I can adjust the volume via PulseAudio.

I noticed, that QMMP starts with a set volume of "0", the slider is max left. 

I added fedora basis pluginpack and the RPMFusion freeworld plugins

I did not have time to adjust qmmps options, so image them to be defaults.

BTW.. the QMMP main window still gets dragged to a new position, if the options window is open and moved. Theres an old bugreport in the system for F17 or F18 ( roundabout ) for the same unhandled bug.
Comment 4 Karel Volný 2015-12-08 11:48:17 EST
(In reply to customercare from comment #3)
> It's a fresh installation of Fed 23 with PulseAudio Defaults.
...
> I did not have time to adjust qmmps options, so image them to be defaults.

the thing is that qmmp defaults to ALSA

you can check the value of 'current_plugin' in [Output] section of the configuration file ~/.qmmp/qmmprc

if it is missing, qmmp is not using PulseAudio - the options should show ALSA selected

if you switch to PulseAudio, the value becomes

current_plugin=pulse

> I noticed, that QMMP starts with a set volume of "0", the slider is max
> left.

supposing the real volume value is not zero, this happens when it cannot read the volume value - which would indicate that there is wrong mixer device selected as I've suspected ...

so, please

1) try to set correct device when using ALSA

2) try switching to PulseAudio output

if it helps in both cases then we will know that it is just configuration issue

if it does not help then there has to be something rotten in qmmp's volume code


well, maybe I should change the configuration defaults anyways, considering how hardwired PulseAudio is in Fedora :-/


-----

> BTW.. the QMMP main window still gets dragged to a new position, if the
> options window is open and moved. Theres an old bugreport in the system for
> F17 or F18 ( roundabout ) for the same unhandled bug.

I cannot reproduce this one ... when I open the options, I cannot move the main window, neither it would move itself when dragging the options dialogue
Comment 5 customercare 2015-12-08 13:22:16 EST
there is no .qmmp directory in /home/user/  , which would explain this.

Should thats be created if it does not exist ?
Comment 6 customercare 2015-12-08 18:16:06 EST
Reason:

After the .qmmp subdirectory was created and filled with content by qmmp..
the option line: 

software_volume=false

caused the problem.

Solution: 

software_volume=true


Slider works now as expected.

btw.. no "current_plugin" in the entire configuration file. 


No more questions from my side for this report.
Comment 7 Karel Volný 2015-12-09 04:32:11 EST
(In reply to customercare from comment #6)
> Reason:
> 
> After the .qmmp subdirectory was created and filled with content by qmmp..
> the option line: 
> 
> software_volume=false
> 
> caused the problem.
> 
> Solution: 
> 
> software_volume=true
> 
> 
> Slider works now as expected.

but that is just workaround, it is not a fix - it doesn't control the mixer, it just multiplies the samples sent to output by some constant

qmmp should be able to control the mixer - and I was able to reproduce the problem when using ALSA output after deactivating PulseAudio on my system which shuffled the cards around a bit and produced invalid configuration

that's why I asked if it can be fixed by choosing the right ALSA device in configuration

now Fedora has decided to make PulseAudio something that it can't live without ... not that I would like to contribute to the problem, but given the circumstances, it would be easier just to default to PulseAudio output (while still providing ALSA and JACK support); but before making the change, I'd like to know if that would work for you ...
Comment 8 customercare 2015-12-14 03:35:36 EST
> 
> if you switch to PulseAudio, the value becomes
> 
> current_plugin=pulse
> 

Ich if add this to the qmmprc, it works as expected.
Comment 9 Karel Volný 2015-12-25 06:34:47 EST
so let's try with pulse as default ...
Comment 10 Fedora Update System 2015-12-25 06:35:40 EST
qmmp-0.9.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6
Comment 11 Fedora Update System 2015-12-28 19:56:36 EST
qmmp-0.9.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6
Comment 12 Fedora Update System 2015-12-29 17:45:09 EST
qmmp-0.9.5-1.fc23 qmmp-plugin-pack-0.9.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6
Comment 13 Fedora Update System 2016-01-02 13:52:28 EST
qmmp-0.9.5-1.fc23, qmmp-plugin-pack-0.9.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-26fa02a2e6
Comment 14 Fedora Update System 2016-01-09 16:57:37 EST
qmmp-0.9.5-1.fc23, qmmp-plugin-pack-0.9.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.